troubleshooting Question

Visual Foxpro 9 reporting says file not found when run remotely

Avatar of bhag2
bhag2Flag for United Kingdom of Great Britain and Northern Ireland asked on
Microsoft Development
1 Comment1 Solution761 ViewsLast Modified:
Hello,

I have an application written in VFP9, it has a couple of screens and a couple of reports in it, when I run it on a local drive it works fine, but when I run it remotely I get error #202 (invalid path or file name) :-(

The rest of the app seems to work fine, you can see the database, click run report a screen appears, put your search criteria in there and press go, it then extracts the data but it the final command which is "Report format report2" which creates the error.

Report2 is in the project and if I copy the exe to the PC it works but when I create a shortcut pointing to it on a remote PC it generates this error. The start in dir is set to \ full UNC just like the target is.

I have had similiar problem with class libraries not being found but by adding Set classlib to...... fixed that even though they were also in the project.

I guess what I need is a set reportlib to.. type command but I cant find one.

Any ideas would be most welcome thank you.
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 1 Comment.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros