troubleshooting Question

File does not begin with %pdf-

Avatar of Mike Howard
Mike Howard asked on
HTTP ProtocolMicrosoft IIS Web Server
2 Comments1 Solution2297 ViewsLast Modified:
We are using fpdf to dynamically create a pdf based on search strings against a database.  On our test box it works just fine, but our production boxes return "File does not begin with %pdf-".

All of the boxes are Windows 2003 SP2 running IIS6.

I've gone through the config for IIS6 on the test box and compared it to the production boxes.  (We load balance the site, hence the two production boxes.)  The MIME file type for .pdf is set to application/pdf.  I've tried application/x-pdf as well and gotten the same result.  

I saw a mention of KB944533 potentially interfering, but that is not installed on any of the servers in question.  .NET version is set to the same (1.1) on all of the boxes.  I've tried 2.0 and same result.

As I said, the .pdf displays on the client when browsing to the test box, not from the production boxes though.  To make things better, if I try to browse to a .pdf directly on the production boxes, it works fine.

Odd issue, so any insight is welcome.
ASKER CERTIFIED SOLUTION
wolfman007

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Log in to continue reading
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform for $9.99/mo
View membership options
Unlock 1 Answer and 2 Comments.
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
The Value of Experts Exchange in My Daily IT Life

Experts Exchange (EE) has become my company's go-to resource to get answers. I've used EE to make decisions, solve problems and even save customers. OutagesIO has been a challenging project and... Keep reading >>

Mike

Owner of Outages.IO
Phoenix, Arizona, United States
Member Since 2016
Join a full scale community that combines the best parts of other tools into one platform.
Unlock 1 Answer and 2 Comments.
View membership options
“All of life is about relationships, and EE has made a virtual community a real community. It lifts everyone's boat.”
William Peck

Member since 2004