troubleshooting Question

Dell TouchPad no longer working after installing USB Mouse and Keyboard

Avatar of Jared_mc
Jared_mc asked on
Laptops NotebooksMicrosoft HardwarePeripherals
6 Comments1 Solution5412 ViewsLast Modified:
On my fathers Dell Inspiron 8500 laptop, I installed a Microsoft Wireless Laser 4000 USB keyboard and Mouse. At some point after the install the Touchpad stopped working totally. In the system tray the Touchpad icon is no longer present.

The first steps I took to fix the problem were to reinstall the drivers for the Touchpad from Dells website (below).

http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R113813&SystemID=INS_PNT_P4_8500&servicetag=&os=WW1&osl=en&deviceid=2514&devlib=0&typecnt=0&vercnt=6&catid=-1&impid=-1&formatcnt=1&libid=17&fileid=149404

After the driver was installed and the computer restarted the touchpad still did not work. So from that point I went into the Device Manager to see if the device was disabled. When I looked under the Input Devices options it only lists the Microsoft Mouse, so I went to views then turned on the View Hidden Devices. Now the Touchpad appears as the Alps Touchpad but has a yellow exclamation point. I then when into the properties and it says that the device can not start but that it is enabled.

So then I restart the computer and go into the BIOS to see if the Touchpad is disabled there but when I go to the settings for the Mouse it says that it is enabled.

So I go back to the Dell support site and download the Driver Reset Tool I run it, it detects that the Touchpad is disabled and will reset the driver. After the computer restarts again its still not working.

So now I try to use an older version of the driver located on the dell site as well but that doesnt work either. So I go back into the Device Manager and uninstall the Touchpad driver. Then I go into the locations were the drivers were installed and delete all of them. Then I restarted the computer upon restart normally when an integrated device is uninstalled a new hardware balloon will pop up when the computer boots but I noticed it didnt in this case for the Touchpad.

So I go back into the device manager the yet again the Touchpad is only visible under the Hidden Device view with the Yellow exclamation point again.

At this point I try to see if there are any more up-to-date drivers for the device and I located these at this site. (Below)

http://www.laptopvideo2go.com/forum/index.php?showtopic=7121

From this site I used the drivers for version v7.1.102.7 which came from Dells website. The install was successfully but the touchpad still did not work even after the restart. When I went into the Device Manager I was only able to locate the Touchpad under the Hidden Device again but this time the name for it was called Dell Touchpad and in the properties it gave an Error Code 24.

At this point I uninstall the drivers again and am back to square one. So at this point the next time I am going I was going to try to uninstall the Microsoft USB Combo and if that didnt work I was going to open the computer up to see if the ribbon cable for the Touchpad and the trackball is either broken or damaged.

So I am looking for any advice to fix this problem if anyone can offer me some guidance or suggestions I can try please let me know.

Thank You
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 6 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 6 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros