troubleshooting Question

Config Save for a CISCO 1841 has a % Invalid input detected at '^' marker - media-type 100BaseX

Avatar of Raymond-Aldridge
Raymond-Aldridge asked on
RoutersNetworking Hardware-Other
4 Comments1 Solution4624 ViewsLast Modified:
Hi Experts,

I am not an IT professional but I do know a little about the configuration of CISCO routers. I am using a CISCO 1841 to pass limited data between the two FE interfaces in a test environment. The configuration is very simply and is accomplishing the desired job but I received an error upon saving the setup configuration which is a little troubling to me.

When I save the configuration I received the following error:

**** START copied text from config ****

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2
media-type 100BaseX
 ^
% Invalid input detected at '^' marker.

media-type 100BaseX
 ^
% Invalid input detected at '^' marker.

Building configuration...
[OK]Use the enabled mode 'configure' command to modify this configuration.


Press RETURN to get started!

**** END copied text from config ****

The configuration I am using consist of two FE interfaces each with a 248 submask. I am not using any routing protocol or statements as shown below. The complete configuration command is shown below in the code secetion.

**** START copied text from config ****

Configure SNMP Network Management? [yes]: no

Configure IP? [yes]: yes
Configure RIP routing? [yes]: no
Configure bridging? [no]: no

Configuring interface parameters:

Do you want to configure FastEthernet0/0  interface? [yes]: yes
  Use the 100 Base-TX (RJ-45) connector? [yes]: yes
  Operate in full-duplex mode? [no]: no
  Configure IP on this interface? [yes]: yes
    IP address for this interface: 205.12.34.237

    Subnet mask for this interface [255.255.255.0] : 255.255.255.248
    Class C network is 205.12.34.0, 29 subnet bits; mask is /29

Do you want to configure FastEthernet0/1  interface? [yes]: yes
  Use the 100 Base-TX (RJ-45) connector? [yes]: yes
  Operate in full-duplex mode? [no]: no
  Configure IP on this interface? [yes]: yes
    IP address for this interface: 205.12.34.230
    Subnet mask for this interface [255.255.255.0] : 255.255.255.248
    Class C network is 205.12.34.0, 29 subnet bits; mask is /29

Would you like to go through AutoSecure configuration? [yes]: no
AutoSecure dialog can be started later using "auto secure" CLI

**** END copied text from config ****

If you can shed some light on my dilemma I would be most appreciated.
 Thanx
Raymond


Complete terminal capture of the configuration process with error upon saving.
 
*********
 
System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2006 by cisco Systems, Inc.
PLD version 0x10
GIO ASIC version 0x127
c1841 platform with 131072 Kbytes of main memory
Main memory is configured to 64 bit mode with parity disabled
 
 
Readonly ROMMON initialized
 
program load complete, entry point: 0x8000f000, size: 0xcb80
program load complete, entry point: 0x8000f000, size: 0xcb80
 
 
program load complete, entry point: 0x8000f000, size: 0xe08298
Self decompressing the image : ############################################################################################################################################# [OK]
 
 
Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ         TYPE
                0X003AA110 public buffer pools
                0X00211000 public particle pools
                0X000021B8 Onboard USB
 
If any of the above Memory Requirements are 
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
 
 
Allocating additional 7681423 bytes to IO Memory.
PMem allocated: 117440512 bytes; IOMem allocated: 16777216 bytes
 
 
              Restricted Rights Legend
 
Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.
 
           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706
 
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(3i), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 28-Nov-07 18:17 by stshen
Image text-base: 0x6008873C, data-base: 0x61480FA0
 
Port Statistics for unclassified packets is not turned on.
Cisco 1841 (revision 7.0) with 114688K/16384K bytes of memory.
Processor board ID FTX1236W0E1
2 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
31488K bytes of ATA CompactFlash (Read/Write)
 
 
         --- System Configuration Dialog ---
 
 
Would you like to enter the initial configuration dialog? [yes/no]: yes
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
 
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
 
 
Would you like to enter basic management setup? [yes/no]: no
 
 
First, would you like to see the current interface summary? [yes]: yes
 
 
Any interface listed with OK? value "NO" does not have a valid configuration
 
Interface                  IP-Address      OK? Method Status               Protocol
FastEthernet0/0            unassigned      NO  unset  up                    down    
FastEthernet0/1            unassigned      NO  unset  up                    down    
 
 
Configuring global parameters:
 
 
Enter host name [Router]: Router
 
 
The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: enable
 
The enable password is used when you do not specify an
enable secret password, with some older software versions, and  some boot images.
Enter enable password: cisco
 
The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: enable
 
Configure SNMP Network Management? [yes]: no
 
Configure IP? [yes]: yes
Configure RIP routing? [yes]: no
Configure bridging? [no]: no
 
Configuring interface parameters:
 
Do you want to configure FastEthernet0/0  interface? [yes]: yes
  Use the 100 Base-TX (RJ-45) connector? [yes]: yes
  Operate in full-duplex mode? [no]: no
  Configure IP on this interface? [yes]: yes
    IP address for this interface: 205.12.34.237
 
    Subnet mask for this interface [255.255.255.0] : 255.255.255.248
    Class C network is 205.12.34.0, 29 subnet bits; mask is /29
 
Do you want to configure FastEthernet0/1  interface? [yes]: yes
  Use the 100 Base-TX (RJ-45) connector? [yes]: yes
  Operate in full-duplex mode? [no]: no
  Configure IP on this interface? [yes]: yes
    IP address for this interface: 205.12.34.230
    Subnet mask for this interface [255.255.255.0] : 255.255.255.248
    Class C network is 205.12.34.0, 29 subnet bits; mask is /29
 
Would you like to go through AutoSecure configuration? [yes]: no
AutoSecure dialog can be started later using "auto secure" CLI
 
 
The following configuration command script was created:
 
hostname Router
enable secret 5 $1$dWvJ$kncYfXlEXFiL3Rc0PJe/R.
enable password cisco
line vty 0 4
password enable
no snmp-server
!
ip routing
no bridge 1
!
interface FastEthernet0/0
media-type 100BaseX
half-duplex
ip address 205.12.34.237 255.255.255.248
no mop enabled
!
interface FastEthernet0/1
media-type 100BaseX
half-duplex
ip address 205.12.34.230 255.255.255.248
no mop enabled
dialer-list 1 protocol ip permit
!
end
 
 
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
 
Enter your selection [2]: 2
media-type 100BaseX
 ^
% Invalid input detected at '^' marker.
 
media-type 100BaseX
 ^
% Invalid input detected at '^' marker.
 
Building configuration...
[OK]Use the enabled mode 'configure' command to modify this configuration.
 
 
Press RETURN to get started!
 
 
*Oct 20 16:05:49.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
*Oct 20 16:05:49.279: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
*Oct 20 16:14:46.627: %IP-5-WEBINST_KILL: Terminating DNS process
*Oct 20 16:14:57.987: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(3i), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 28-Nov-07 18:17 by stshen
*Oct 20 16:14:57.991: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start
*Oct 20 16:14:58.151: %SYS-6-BOOTTIME: Time taken to reboot after reload = 776 seconds
 
 
 
Router>enable
Password: 
Router#show run
Building configuration...
 
Current configuration : 775 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$dWvJ$kncYfXlEXFiL3Rc0PJe/R.
enable password cisco
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
 
 --More-- 
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 205.12.34.237 255.255.255.248 
 speed auto
 half-duplex
 no mop enabled
!
interface FastEthernet0/1
 ip address 205.12.34.230 255.255.255.248
 speed auto half-duplex
 no mop enabled
!
 
 --More--
  ip classless
 
!
ip http server
!
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password enable
 login
!
end
 
 
Router#exit
 
 
 
Router con0 is now available
 
 
 
Press RETURN to get started.
 
 
Router>
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 4 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros