troubleshooting Question

How can I stop the language from changing as I travel?

Avatar of lisfolks
lisfolks asked on
Web DevelopmentWeb BrowsersEmail Clients
9 Comments1 Solution1628 ViewsLast Modified:
I am an American English-speaking student traveling to different countries for five terms (8 weeks each, plus some time in between) over a year.

Every time I switch countries, various search engines and Google Mail detect the new location and change the language to match - even if I have everything set to English.

So, for example, in the Netherlands, even when I entered "www.google.com", Google detected that I was there and returned "www.google.nl" - which is all in Dutch.  I then had to figure out which word meant "preferences" and set my language from Dutch to English.  That might seem easy enough, but the words were "voorkeuren" and "engels", respectively - not automatic to translate without looking them up.  In the UK, it was easy enough, but now I am in Switzerland - and it's all in German, so "Einstellungen", and "Englisch".

Now, even when I successfully reconfigure the language to English, Google still returns primarily results from the country I'm in - so in the Netherlands, my results showed ".nl" pages;  in the UK, it was ".co.uk" pages;  and here in Switzerland it's ".ch" pages.  Again, as a result, most of the returned pages are in the "mother tongue" of that country, so I don't get results I can read without limiting my search to English pages, which I don't necessarily want to do.

Even my Google Mail changes languages on me.  Once I set the preferences there to English again, it works - except the web clips are still in the alternate language.  Their support told me that to fix this, I had to turn labs off.  Well, first of all, I don't have labs turned on - all of them are set to "off".  Secondly, when I use the "labs=0" add-on to the URL, it fixes the web clips - but breaks all kinds of other things.  For example, my mail won't refresh anymore without me having to logout and log back in.  Or, it hangs when sending messages.  Or, etc, etc, etc - I never know which aspect will break at any given time.  Once I remove the "labs=0" part, it all works fine again - except the web clips are back to the alternate language I can't read!

With the Google home page, I've learned that I can enter the URL as "www.google.com/webhp/", and it will always come up with the US home page and give me results in primarily English-written pages.  But, then I have to set a bookmark for that - Firefox and Safari's search bars will still come back with the other country results.

So, I basically have two questions:
1)  How can I configure Firefox and Safari's search bars to set the URL to what I want (the "webhp" version, for example, for Google)?  And,
2)  How can I get the web clips in Google to show in the language I have set in my preferences (English!) without turning labs off?
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 9 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 9 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros