SBS2008 Premium - "Network Policy Server" Service won't start-gives 0x80072740 Error

Hi I am running a new/clean installation of sbs2008 Premium, I have 1 service as mentioned above which when startedmanually gives the following error :

Error: 0x80072740:nly one usage of each socket address (protocol/network address/port) is normally permited.

There is NO referance to this error on the net, can some one please help as I am having intermittant network/security/connection errors and I think it is this.
HornwoodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mayank_chaudharyCommented:
http://support.microsoft.com/kb/888650

Have you tried netstat to see if 8080 is listening and what is it that is listening??  netstat -a -b will show you what ports are listening and the executable associated with the listening port.

This is issue on a SBS machine, so IIS is installed. You need to successfully apply the WPAD workaround from what I can tell, clients manage to find it.
         
Go to Internal Network Properties -> Web proxy -> Enable HTTP is set to port 8080.
Internal Properties -> Auto Discovery -> 'Publish automatic discovery information' is checked and on port 80.
         
Try stopping the "World Wide Web Publishing Service" if it is running, and setting the startup mode to manual. I didn't think IIS was the problem, but if it is, that will fix it.

This ususlly works with 2003, Am not sure if it will work with 2008
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mayank_chaudharyCommented:
Also do check your firewall
0
HornwoodAuthor Commented:
netstat did not function ???
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tekguy79Commented:
In my case, this was a conflict between IIS (certificate services web enrollment site) and the Health Registration Authority component of Network Policy and Access Services.  The HRA uses ports 80 and 443 be default, and my certificate services web enrollment site was using the same ports.  I have removed the HRA for now until I plan to use it.  I will likely end up changing the ports on my certificate services site, as I think that the HRA needs to run on the default ports.  Can anyone confirm this?
0
tconkleCommented:
Tekguy: I'm having the exact same issue. I followed http://support.microsoft.com/kb/956189 and was able to get it to start until I rebooted.

I don't have Health Resources Authority Installed at all.
0
tconkleCommented:
I can confirm a conflict with WWW Publishing service and the Network Policy Server Service.
I do not have HRA installed.  Not quite sure where specifically the conflict is coming from.
0
danesmondCommented:
I am having this exact same issue! The solution that worked in the SBS 2003 era of adding more exceptions to the ReservedPorts registry entry is not working for SBS 2008. I have done endless Google searches, and this page is the ONLY reference I can find to this issue.

I just don't even know where to begin to try to troubleshoot this. I have already tried setting the service to disabled and then booting the server and manually starting it myself after logging in (to see if it was some sort of timing issue) but got the very same error "The Network Policy Server service terminated with the following error:
Only one usage of each socket address (protocol/network address/port) is normally permitted."

The TSGateway service depends on NPS so Remote Web Workplace is effectively down for me until I can manage to get this resolved. So far nothing I have done has allowed me to get the NPS service started.

Any help much appreciated.
0
ConcentricsIncCommented:
Do you have Symantec Endpoint Protection Manager installed on the same server?  If so, follow this thread:
http://www.symantec.com/connect/forums/endpoint-protection-manager-breaks-network-policy-server-windows-server-2008
0
pc-buddyCommented:
Did anyone fix this in the end, I have the same problem

thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.