Avatar of servicad
servicadFlag for Canada asked on

OMA ON SBS 2003

Hi, I'm trying to setup OMA for a client on SBS 2003.  I was following a guide from
http://www.petri.co.il/configure_oma.htm .  I was able to get the OMA to work when I was logged in internally to the server.  When I try to access it externally it doesnt not allow me too.  I get the following error when trying to access this link:  http://servername.dnsalias.com/oma

You are not authorized to view this page
The Web server you are attempting to reach has a list of IP addresses that are not allowed to access the Web site, and the IP address of your browsing computer is on this list.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator if you believe you should be able to view this directory or page.
HTTP Error 403.6 - Forbidden: IP address of the client has been rejected.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 403.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled About Security, Limiting Access by IP Address, IP Address Access Restrictions, and About Custom Error Messages.

I allowed HTTP and HTTPS access and pointed them both to the IP of the exchange server.  Is there something I'm missing?
SBS

Avatar of undefined
Last Comment
servicad

8/22/2022 - Mon
Hypercat (Deb)

SBS by default is set up to allow only internal IP addresses to access the web site. If you haven't checked this yet, you may need to edit the properties of the Default Web Site and the OMA virtual directory and remove the restriction. You would see this setting in the web site properties/Directory Security/IP address and domain name restrictions tab.
ASKER
servicad

Ya right after I posted this question, I went into the IIS properties and the IP address was set to deny unless it was listed.  Fixed issue.
ASKER
servicad

I was able to get the login box, when I login it tells me this:

Unable to connect to your mailbox on server GRMASRV. Please try again later. If the problem persists contact your administrator.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Hypercat (Deb)

Can you connect to it through Internet Explorer - did you test this as described in the article?  
ASKER
servicad

When I type http://servername.dnsalias.com/oma I am able to get a login screen (I'm doing this from outside the network) When I type in a login that I made jsut for this (I configured email on exchange server in outlook) it tells me this:

Unable to connect to your mailbox on server GRMASRV. Please try again later. If the problem persists contact your administrator.

And the heading of the tab is : Server Off-Line.

I was able to login locally before I removed the IIS IP deny settings.  Now when I try locally as well I get same message.
ASKER
servicad

Do I need ActiveSync installed on the server as well?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Hypercat (Deb)

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
servicad

Ok, now when I went to run that it said it found a plug and play router and that if I say yes it would automatically configure my settings in the router.  I was afraid to press Yes because I dont want it to change any other settings that we already have on the router.  Do I have to be worried about that?  Or can I press Yes?
Hypercat (Deb)

I usually say No because I have already manually configured the router.  If you say "yes" it may change the router's DNS settings, etc., which you might not want to do. Saying "No" to this question doesn't affect anything else in terms of reconfiguring your IIS settings.
ASKER
servicad

Yea I did what you said, I said no and it worked! Thanks a lot.
Your help has saved me hundreds of hours of internet surfing.
fblack61