We help IT Professionals succeed at work.
Get Started

Cisco ASA 5505 VPNs from two remote offices to one central office. Remotes are DYNAMIC IPs

PlusInc
PlusInc asked
on
1,084 Views
Last Modified: 2013-11-16
I am charged with creating VPNs between two remote offices that are on Dynamic IPs and a central office on a static IP.  All three locations have Cisco ASA 5505 devices.

Main office:

WAN: 216.176.xx.xx
LAN: 192.168.1.x (ASA is 192.168.1.254)

Remote Office 1:
WAN: Dynamic
LAN: 192.169.1.x (ASA is 192.169.1.1)

Remote Office 2:
WAN: Dynamic
LAN: 192.170.1.x (ASA is 192.170.1.1)

Below are the working configs from the Central office and one of the remote sites.... I had tried to use some VPN configs from a working PIX system I created a number of years ago, but failed, so ignore that part of the config =)

Oh, and it would be a HUGE help if the Easy VPN was not needed, as I currently do not have a way to configure the ASA's using the GUI, only SSH in for now.

As always, thank you all for your help!!!!!!

John

CENTRAL OFFICE CONFIG:
 
: Written by enable_15 at 12:30:58.482 UTC Thu Jan 22 2009
!
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name drumm.local
enable password xxx encrypted
passwd xxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 216.176.xx.xx 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name drumm.local
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit tcp any any eq smtp
access-list outside_access_in extended permit tcp any any eq www
access-list outside_access_in extended permit tcp any any eq pop3
access-list outside_access_in extended permit tcp any any eq imap4
access-list outside_access_in extended permit tcp any any eq https
access-list outside_access_in extended permit tcp any any eq 987
access-list outside_access_in extended permit tcp any any eq 3389
access-list outside_access_in extended permit udp any any eq 443
access-list outside_access_in extended permit tcp any any eq 3390
access-list nonat extended permit ip 192.168.1.0 255.255.255.0 192.169.1.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.250 smtp netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.250 www netmask 255.255.255.255
static (inside,outside) tcp interface pop3 192.168.1.250 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface imap4 192.168.1.250 imap4 netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.250 https netmask 255.255.255.255
static (inside,outside) tcp interface 987 192.168.1.250 987 netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.1.250 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 3390 192.168.1.32 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 216.176.xx.xx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map VPN 1 set transform-set ESP-3DES-SHA
crypto map VPN 65535 ipsec-isakmp dynamic VPN
crypto map VPN interface outside
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 50
ssh 192.168.1.0 255.255.255.0 inside
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.128-192.168.1.129 inside
dhcpd dns 64.89.xx.xx interface inside
!
 
tunnel-group DefaultL2LGroup ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:78ef18a614ccfb0c327b384b5e5fd1b8
ciscoasa#
 
 
REMOTE SITE ONE CONFIG:
 
ciscoasa2(config)# show config
: Saved
: Written by enable_15 at 12:39:47.132 UTC Thu Jan 22 2009
!
ASA Version 7.2(4)
!
hostname ciscoasa2
domain-name drumm.local
enable password xxx encrypted
passwd xxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.169.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 68.115.xx.xx 255.255.255.248      <--- NOTE this is set static only as a test for now, it WILL be dynamic
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name drumm.local
access-list VPN extended permit ip 192.169.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list nonat extended permit ip 192.169.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_access_in extended permit icmp any any echo-reply
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 68.115.xx.xx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.169.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map VPN 1 set peer 216.176.xx.xx
crypto map VPN interface outside
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 0.0.0.0 0.0.0.0 outside
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 50
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.169.1.25-192.169.1.50 inside
dhcpd dns 192.168.1.250 24.197.96.15 interface inside
dhcpd wins 192.168.1.250 interface inside
dhcpd domain drumm.local interface inside
dhcpd enable inside
!
tunnel-group 216.176.xx.xx type ipsec-l2l
tunnel-group 216.176.xx.xx ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:06e001ba3aea0f35a1c965c1c98728bb

Open in new window

Comment
Watch Question
Top Expert 2010
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE