Avatar of ntssupport
ntssupport asked on

One way audio on SIP calls Cisco ASA 5510 transparent firewall

I have two sites that are connected via 8 bonded pairs of SHDSL on two Zhone EtherXtend 3384's in a bookend configuration. One side is the CO or central office, the other is just our main office. The CO side has our Metaswitch VP2510 (Class 4/5 Softswitch) and a Cisco 3845 router, the office has a Cisco 2851 router with an extremely long access list, and houses our corporate/public network. In an attempt to allow the router at the office to simply route traffic I recently put a Cisco ASA 5510 in front of our router at the office as a transparent firewall and set it to pass all traffic from the outside interface inwards. Before I put the firewall in place I had no problems whatsoever passing SIP traffic through our ACL to my Linksys 942 IP phones from the Metaswitch, All calls worked fine. I did not make any changes at all to our ACL on the router at the office, simply have put the firewall in place in front of the router and set to pass all traffic. Everything appears to work correctly, I have not had any complaints as far as any services being down except now I only get one way audio on my voip calls. I can make a call from my ip phone, it connects, I can hear audio from the other party but the person on the far end has no audio at all. I am not at the office right now to post my config of the ASA which I will do tomorrow but does anyone have any ideas of what could be happening or any suggestions? To verify the ASA is the problem I could take it back out of the loop but I would have to do it during our service window but I really need to find the actual problem.
Cisco

Avatar of undefined
Last Comment
ntssupport

8/22/2022 - Mon
Les Moore

Disable inspect SIP on the ASA
ASKER
ntssupport

I disabled SIP inspection on the ASA and the problem still persists. I have attached my config.
ASA Version 7.0(8)
!
firewall transparent
hostname xxxxxxx
domain-name xxxxxxxxxx
enable password DG2Nk9r7PxRRpaCk encrypted
passwd DG2Nk9r7PxRRpaCk encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
!
interface Ethernet0/1
 nameif inside
 security-level 100
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
!
interface Management0/0
 nameif mgmt
 security-level 100
 management-only
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
dns domain-lookup mgmt
dns name-server 10.1.1.x
dns name-server 10.1.1.x
access-list outside_access_in remark Allows all traffic
access-list outside_access_in extended permit ip any any
pager lines 24
logging enable
logging timestamp
logging trap warnings
logging asdm informational
logging device-id ipaddress mgmt
logging host mgmt 10.1.1.x
logging debug-trace
logging permit-hostdown
no logging message 418001
mtu outside 1500
mtu inside 1500
mtu mgmt 1500
ip address 10.1.1.x 255.255.255.0
asdm image disk0:/asdm-508.bin
no asdm history enable
arp timeout 14400
access-group outside_access_in in interface outside
route mgmt 0.0.0.0 0.0.0.0 10.1.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.1.1.0 255.255.255.0 mgmt
http 10.1.2.0 255.255.255.0 mgmt
snmp-server location xxxxxxxxxxxxxxxxxx
snmp-server contact xxxxxxxxxxxxx
snmp-server community xxxxxxxxxxxx
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 10.1.1.0 255.255.255.0 mgmt
telnet 10.1.2.0 255.255.255.0 mgmt
telnet timeout 5
ssh timeout 5
console timeout 0
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect netbios
  inspect tftp
  !
service-policy global_policy global
Cryptochecksum:db99416e0fcdbdceb3fd9409905aa029
: end

Open in new window

ASKER CERTIFIED SOLUTION
ntssupport

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck