Avatar of snyderkv
snyderkv asked on

WDS deployment error ?

having an issue deplyoing captured images via WDS.

After the successfull capture I go to images and right click install images and add the newly captured image.

Then I inject my drivers into the default boot.wim image created when setting up WDS and F12 the reference machine into it. It waits a while then errors out with this error:

WdsClient: An error occurred while communicating with the Windows Dpeloyment Services service.. Please check to ensure the server is operational and necessary ports are open ,... firewall blah

Thanks in advance.
Microsoft Server OS

Avatar of undefined
Last Comment
snyderkv

8/22/2022 - Mon
James Haywood

Are you definately injecting the correct drivers into the boot image? x32/x64 etc. Are you exporting the boot image, injecting drivers then importing it back into WDS?
Try removing the reference machine IP address from your DHCP server as i've found this can stop the machine from picking up a new address.
ASKER
snyderkv

1) >Are you definately injecting the correct drivers into the boot image
Answer: Yes, infact, it worked for the capture. I did not have to export them. I disabled the boot image in WDS and then injected, then reanabled boot image in WDS. It seemed to work as stated above.

2) >x32/64
Answe: It's 64bit hardware however the OS is 32bit Server 2008 so I'm sure it's fine?

3) > Rmove DHCP IP's before deploying.
Ansewer: I will try this but running slim on ideas now. WIll be back at work on my Thursday your wednesday. Any other ideas before I try this out?
James Haywood

Hmmm
Try the simple things like disabling the firewall and checking permissions on the shared folder. If you've had images deploying previously then this probably isn't a problem.
Have you tried different machines to image to? Even if the image isn't suitalble you should still be able to boot into the wds server.
How far do you get with pxe booting? does the machine pick up an ip address? does it recognize the WDS server and load any installation files (on a black background the wds ip should appear with a status bar across the bottom)?
We need to isolate the problem to WDS server, the image or the target machine
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
ASKER
snyderkv

I was just going to mention that my Firewall is stopped and disabled. I turned network shareing on and EVERYONE has full control to the root of the folder.

I never said I had images deployed. I said I captured images no problem. Can't deploy to other machines beacuse they are all the same hardware. Dell PowerEdge 2950s

Here is an interesting link. Guy had the same exact issue as me except my firewall is turned off so it may not be port 5040 or whatever it was.
http://nssadoc.blogspot.com/2008/07/follow-up-differential-analysis-wds.html
ASKER
snyderkv

Some other things I will try is
1) Making sure the client has at least 512 memory (not in OS install mode in BIOS)
2) Deleting all IPs in DHCP
3) Checking permissions on RemoeInstall Share and "Install image" in WDS snap in.
4) Add default install images to Install image
5) Reset Domain Controller policies to default
6) Press Shift + F10 at boot or at error, type Netstat -an 5 to check for RPC connection to port 5040
7) Press Shift + F10 at boot or at error, type notepad.exe \windows\Panther\setuperr.log & setupact.log
8) Enabling logging on the WDS Server "WDSUTIL /Set-Server /WDSClientLogging /Enabled:Yes" AND "WDSUTIL /Set-Server /WDSClientLogging /LoggingLevel:Info" then chacking Event Viewer, Apps,Servi,Microsoft,Windows, Deployment Services Diagnostics.
9) Reinstall WDS
10) Wipe server reinstall Server 2003 R2 instead of 2008.

This is what I have after hours of cramming various error messages using different search switches.
ASKER
snyderkv

Ok I checked the setuperr.log and setupact.log when deploying the new captured image from AIK from MDT.

2009-01-29 01:59:17, Error      [0x060635] IBS    SetWindowsImageInfoOnBB:Failed while updating EditionID for volume PID.[gle=0x00000057]
2009-01-29 01:59:17, Error      [0x060079] IBS    Callback_SetImageInfoOnBB:Failed to read and cache the Windows image's metadata; GLE is [0x0]
2009-01-29 01:59:17, Error      [0x06007d] IBS    Callback_SetImageInfoOnBB:An error occurred while trying to read and cache the images' metadata; GLE is [0x0]

The answer is in here. Hope someone can help.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
James Haywood

What is the OS you are capturing? How did you load it originally?
ASKER
snyderkv

I'm capturing a 2008 OS fully patched and ready to go. I loaded it with a CD or "special copy" that is locked down, kinda like Gold Disk but is automatied via LiteTouch. We get this from higher up. All it is is the OS with current patches and a popup box that asks if you want to install certain software exc.

I don't want you to think tha tis the cause of the issues thats why I didn't mention it. Our hardware is 64bit and the OS is 32 running on the latest Dell PE 2950 with all updates.

Well I got down as low a level as I can get with those setup errors. Don't know what else to do. We are currently reimaging the WDS server with a base 2003 R2 instead. Will once again load all services, DHCP, DNS, DC, WDS exc and try again.
James Haywood

2008 shouldn't be a problem as its designed to use .wim formats.
A fresh install may clear any problems regarding corrupted files or permissions.

If client side:
Back to basics: When pxe booting how far does the process go? Do you get an identification of the WDS server (IP address and client IP address? That error is suggesting this part is happening but do you see it?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
ASKER
snyderkv

Yes I have captured an image so its all good. When clicking Shift+F10 at the command prompt I type netstat -an and can see the connection and can ping by host name, map drives exc. This is during the error when deploying that says something like "can't communicate with the server blah blah" sorry I have been trying to get this working for three weeks and tried everything. The setuperr.logs are useless due to the fact that even if you get them, nobody knows what the hell they mean. Good stuff! Thanks for your time
ASKER
snyderkv

I'm sure I listed everything I done. I have even tried capturing via AIK with the wimscript.ini exclusions. They have spaces in them. Is this ok? Maybe thats why it didn't work?
James Haywood

You could try using MDT 2008 for deploying & capturing. If your still having errors after a reinstall you could try it

http://www.deployvista.com/Default.aspx?tabid=70&EntryID=77

http://technet.microsoft.com/en-us/desktopdeployment/default.aspx
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
snyderkv

Thanks but the problem with MDT is that it doesent let you capture a custom image. Instead it forces you to install all the required components and software via the MDT GUI, not a server already configured. I tried this over and over. When you select pre defined task sequence or client whatever, it has the install image task. I tried to modify one by removing the install part but then it doesent capture the image. Weird. I don't think MDT was meant to do what WDS does.

Unless you know a way for MDT to capture an already created configured server without deploying its crap to it let me know. Otherwise I have to use WDS to capture and MDT to deploy. Ofcourse WDS had issues deploying as well.

By the way, I think I figured it out.

The AIK WinPE image I have to capture the image had the wrong server flag switch. I used /Flag "StandardServer" instead of ServerStandard. If you look at the error the first line does bark at you about this. DOH! I wiped the server already and reinstalling with Server 2K3.

Will update you

ASKER CERTIFIED SOLUTION
James Haywood

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
snyderkv

Fixed after reinstalling the OS but with Server 2003 SP2 instead of Servery 2008 (which was gold disked)

Now in WDS I don't get the cant find server error stated above. Im almost sure it was the build.

Havent tried MDT but for anybody else who has the same issue, I'm almost positive it would have worked as well.

Thanks