Exchange ActiveSync Issues

Hi,

I have setup Exchange ActiveSync in the following environment:

WIndows 2003 Domain
Exchange 2003 Service Pack 2
Windows Mobile 6.1 Device

I have enabled Activesync in Exchange system manager.
Outlook Mobile access and web access is working from the device but when I try to use Exchange Activesync from the device, the following is logged on my exchange server (application log):

Source: ServerActiveSync
Event ID: 3005

Unexpected Exchange mailbox Server error: Server: [Our Mail Server DNS Name] User: [User Email address] HTTP Status code: [501]. Verify that the Exchange mailbox Server is working correctly

Please assist, Ive tried lots of things but I cant seem to sync the device with the server.
The purchased owa certificate seems ok.

Thankyou
wk6838Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MesthaCommented:
Does the user have an email address in the default domain?
The default domain is the same as your Windows domain - domain.local for example. It doesn't have to be the default email address.

You could also test it with the Microsoft test site and a test account.
https://www.testexchangeconnectivity.com/

-M
wk6838Author Commented:
Hi,
Yes the user has an email address in the default domain. (and AD user account)

eg username is xxx@abc.com
default domain is @abc.com

Just tried the weblink test:- get as far as
 Http Authentication Test failed

Authentication method Negotiate is enabled but is not an allowed Authentication method for this service.

Any pointers?
Thanks


RaghuvCommented:
Hi,

Since you are using a certificate, can you confirm if you have enforced "Require Secure Channel" on the Exchange virtual directory under IIS Mananger or if you are using form based authentication for OWA ? if yes, then you will have to follow the KB article http://support.microsoft.com/kb/817379.

If you are not using the settings as mentioned above, then you need to ensure the Exchange Virtual directory has "Windows Integrated Authentication" enabled under IIS Manager.
Maximize Customer Retention with Superior Service

The IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more to help build customer satisfaction and retention.

wk6838Author Commented:
Raghuv,

Require Secure Channel is enforced and form based authentication is enabled for OWA
I will give the kb a try later and let you know.
Thanks

Does require Secure channel mean ssl cert required?  I have one purchased from an external company.


wk6838Author Commented:
I have tried the kb817379 but appear to have the exat error. Even after recreating the exchange-oma virtual directory.

Using this website, https://www.testexchangeconnectivity.com/ 
I get the following error code:

Attempting FolderSync command on ActiveSync session
  FolderSync command test failed
   Tell me more about this issue and how to resolve it
 
 Additional Details
  Exchange Activesync returned an HTTP 500 response.

Struggling to understand where I have gone wrong...
Please help,
thankyou
wk6838Author Commented:
After some tweaking the error code is now HTTP Status code: [400]
instead of HTTP Status code: [501].

Any ideas?
Thanks
jonesgilesCommented:
Hi wk6838

I have the exact same issue as you - got the same results from https://www.testexchangeconnectivity.com/ too.  I'm still getting a 500 error though and I'm sure I've tried all the kb's at least 10 times each!  It's driving me mad!

Did you managed to get to the bottom of this?  Any suggestions would be much appreciated.

Thanks

Adrian
wk6838Author Commented:
This has been sorted, after a lot of troubleshooting it was down to the default web site config in IIS. In Web Site tab, the IP Address was reset back to (All Unassigned) from the IP address of the mail server.

I dont know what the significance of this setting is but this is now solved

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphone Programming

From novice to tech pro — start learning today.