Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 378
  • Last Modified:

MediaWiki - Uploading is disabled and whatever I do I can't set it to on

* MediaWiki version: 1.12.0
* PHP version: 5.2.6
* MySQL version: 4.0.24
* URL:

When logged in as WikiSysop (the only user on the system so far) and I try and upload an image in my Wiki (version 1.12.0) I get the following message:-

"File uploads are disabled on Systems."

I have followed the instructions at:-

mediawiki.org/wiki/Manual:Configuring_file_uploads

I have confirmed the following settings:-

file_uploads = On

www.mydomain.com/wiki/images is set to 755 I have also tried 777

Safe Mode is off

$wgEnableUploads = true;

As far as I can see there are no permissions set in LocalSettings.php in fact no variables at all with the text "permissions" in them.

$wgFileExtensions = array( 'png', 'gif', 'jpg', 'jpeg' );

upload_max_filesize is 8Mb
0
cescentman
Asked:
cescentman
  • 10
  • 9
1 Solution
 
EMB01Commented:
Put this in your LocalSettings.php:
$wgEnableUploads = true; # Enable uploads
0
 
cescentmanAuthor Commented:
Thanks for getting back to me, I am a little confused. In the original question above I confirmed that $wgEnableUploads = true is this not the same as your suggestion without the remark?
0
 
EMB01Commented:
Sorry, I thought you said, "... there are no permissions set in LocalSettings.php..."

So, I thought to add that to your file as it can sometimes be removed. If you do have it there, try adding it to the end of the LocalSettings.php file. I think there are two of those lines in that file. Wiki will use the last setting it reads, so your "true" may have been overwritten by the "false."
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
cescentmanAuthor Commented:
Sorry if what I wrote was ambiguous, what I was referring to was that there are no group or user permissions set in LocalSettings.php.

$wgEnableUploads is only set once.
0
 
EMB01Commented:
You are using MediaWiki version 1.12. According to the document referenced below, you must add this variable to your LocalSettings.php page (it's backwords):
$wgDisableUploads = false; # Enable uploads

Ref. http://www.mediawiki.org/wiki/Manual:Configuring_file_uploads

"... older versions of the software, the attribute to be set resides in LocalSettings.php, but is backwards, i.e. $wgDisableUploads."

Thank you!
0
 
cescentmanAuthor Commented:
I had certainly missed that, I thought bingo this is it. :>(

sadly no change  so tried setting images and the sub folders to 777 as well to be sure it wasn't a double whammy. I think I might try an upgrade to 1.5 to see if that makes any differernce.
0
 
cescentmanAuthor Commented:
I'm even more confused now I go to http://www.mediawiki.org/wiki/Download and lo and behold the latest version for download is 1.13.4 nowhere near 1.5. I'm tearing my hair out over this.
0
 
EMB01Commented:
Yeah, I'm really sorry. I was thinking bingo, too! Maybe you can repost the question or get more attention to it as I'm out of ideas. The 1.5 thing could be just a typo... This is wiki. One other thing: Are you sure your server owner is "apache?" I would just try to go through the link above (and below) to double-check. Otherwise, repost (maybe get somebody smarter than me) for more help. Sorry, again.
0
 
EMB01Commented:
By the way, I saw this:
"Set the /images folder (or the /uploads folder in previous versions) to have permission '755'"

Maybe your folder is uploads and not images?
0
 
cescentmanAuthor Commented:
Nope /images I'm afraid
0
 
EMB01Commented:
Well, if you go through all of the configuration manual stuff and it doesn't help and if it's not a big deal to upgrade, I think you should upgrade. Maybe you had a bad install.
0
 
cescentmanAuthor Commented:
Guess so, I'll try. Nothing to lose except my sanity.
0
 
cescentmanAuthor Commented:
Time has gone on and I don't seem to have a moment to try this. I will come back to it.
0
 
cescentmanAuthor Commented:
The upgrade made no difference.
0
 
EMB01Commented:
Wow. Did you uninstall the original version or was it just an upgrade?

I did some additional research. Have we tried this solution:
http://forum.siteground.com/showthread.php?t=2814

Summary of above reference:
Add the following line to the end of LocalSettings.php (which I think we already tried):
$wgEnableUploads = true;

Moreover, try this from:
http://www.110mb.com/forum/mediawiki-file-uploads-are-disabled-in-this-wiki-t14087.0.html

Summary of above reference:
Remove the following two lines from LocalSettings.php:
require_once( "htmlets/HTMLets.php" );
$wgHTMLetsDirectory = "$IP/htmlets";

If these don't work, I can do more research; but post up your LocalSettings.php source.

Thank you.
0
 
cescentmanAuthor Commented:
This has stalled and I'm not sure when I'll get back to it. I am happy to allocate the pints in recognition of the work put in trying to help me resolve it. D I just accept a solution and annotate that it isn't resolved?
0
 
EMB01Commented:
Yeah, the solutions provided above may help someone else. I can't figure out what the root of your problem is. We've tried like five different things! You can just delete it if you want, or accept your own answer (of there is no solution) and award partial points.
0
 
cescentmanAuthor Commented:
There was no solution n the end but EMB01 deserves the points.
.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 10
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now