We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Attempting Printer Share on Network and It Won't Turn On

Medium Priority
858 Views
Last Modified: 2012-05-06
While attempting to turn on Printer Shareing for my wireless network, I click on "ON" then apply and the screen pops out and returns with the Printer Shareing STILL turned "OFF".  There are no error messages.  Oddly related, when I try to turn on the Public Folders section - I am returned an error message "RPC unavailable cannot find server".  

The RPC service is loaded and running.

All I want to do is share my printers with my laptop.  Is that asking too much?? :)

Thanks,

AFTerry
Comment
Watch Question

Ok so I am a bit confused..

How many computers.. where is the printer being connected to.. is this where you are getting the error or on the PC you want to connect to the error?

Author

Commented:
Thanks,  2 computers.  I'm using a wireless network router.  The Desktop computer (1) and the laptop (2) are communicating just fine, I've turned on printer shareing, file shareing, etc., on laptop (2) and the Desktop (1) reads Laptop (2) just fine.  However, on Desktop (1) I can not turn on Printer Shareing (see previous post of mine for explaination).

Further, on Desktop (1) I can turn of individual properties of each printer to "share", except the Dell P1500, which gives an error message that "Printer settings could not be saved..."

thanks,
afterry
Have you tried uninstaling the printer are using update drivers to reinstall?

Author

Commented:
Yes, unfortunately same problem.

I would run an SFC /scannow and test your system files.. Is this on Vista SP1 yet?

Author

Commented:
Did the SFT /scannow and nothing came up.  Yes this is on Vista Ultimate 32 bit SP1.

Author

Commented:
DMTechGrooup;

Thanks, but to no avail.  Tried all the steps and still problems:

Author

Commented:
Dm...,(

(Sorry, hit the enter key by mistake)  . . .

The problems are:  1) When I try to turn on Printer Sharing the screen "bleeps" and returns with the Printer Sharing option still "OFF".  No error reported.

2) When I try to turn on Public File Sharing I receive the error "PRC is unavailable" even though it is running according to the Task Manager.

I don't know if they are related, but the most important issue for me is to get the PRINT SHARING in Network's Properties to turn "ON".

Please help,

Thanks,
AFTerry

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Hi, well that was informative and close. . . my brother did a search on why "custom" was highlighted instead of "ON"  under Network and Sharing Center' Sharing and Discovery section for "Network discovery" and "File sharing" .  Something that I hadn't paid any attention to.  Well it turns out that there were services and/or processes that needed to be turned on that weren't .  

I asked him which but he doesn't remember.  He used Vista's F1 key to find the answer!!!  He turned them on and suddenly "Printer sharing" an Public folder sharing became available.

You were right about the processes needing to be checked.  The link just didn't have the ones necessary.  Thanks
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.