Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

FTP and IIS7, cannot get to work.

Posted on 2009-02-08
11
Medium Priority
?
2,396 Views
Last Modified: 2012-05-06
I've followed every guide out there but cannot get the FTP site to work.

I installed the new IIS7 FTP site application from MS.  Server 2008 64 bit.  I set up the site and everything seems to work.  I can FTP into the server and it logs me in as anonymous.  If I do PWD I get:

257 "/" is the current directory

ok...if I do an ls I get:
150 Opening ASCII mode data connection.

And it hangs....when I go into IIS and the FTP site I created and use the Test settings button I get:
Cannot verify access to path (c:\innetpub\ftp).

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.

I've tried everything.  I've given ANONYMOUS USERS access to the folder, I've given IIS_IURS access to the folder.

I've triple checked all the anonymous access stuff...the firewall is configured correctly.

I've seen a ton of people post about this but never a resolution.
0
Comment
Question by:eric_ptek
  • 6
  • 5
11 Comments
 
LVL 22

Expert Comment

by:cj_1969
ID: 23594316
You are logging in to the server and able to do a pwd ... then nothing surrounding file access is working.
This sounds like you have a permissions issue.

Try configuring the server to access the local drive and make sure that things work locally first.
If this is working, then work on redirecting the directory/site to another location.
As a thought, try leaving the default site/directory on the IIS server and just create a virtual directory within the main site as a link to the other server ... MS has been known to have problems when redirecting the root folder of certain things to remote locations or when granting permissions to root folders.

Let me know how this goes and we'll take it from there.
0
 

Author Comment

by:eric_ptek
ID: 23595337
Understand what your saying, but how do I go about doing that?

When you configure the server, are you speaking of IIS?  I did give the IIS group permission to the folder, and even added NT SERVICE/ANONYMOUS_LOGON access to the folder.

IIS7 is new to me...originally I wanted to just throw a file up on my server for someone to grab and figured I'd configure the FTP server for the task but ran into these issues.  

There was no default directory when setting up the FTP site.  I'm not using the FTP that came with Server 08 DVD, I'm using MS's updated FTP that was released a while ago.

Thanks
0
 

Author Comment

by:eric_ptek
ID: 23595351
Sorry forgot the link, this is the FTP server I'm using:

http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1619
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 22

Accepted Solution

by:
cj_1969 earned 2000 total points
ID: 23600170
Hmmm ... some interesting changes in IIS 7 and ftp.
First question ... check your directory path for the ftp site ... is this correct? "c:\innetpub\ftp"  ... is it supposed to be "inn..."?  Even without this working, from what I read ftp to the point it is working for you could still work since it binds to the same site structure as the www server.   This might mean that you are accessing the root of the default web site with the ability to log in as anonymous but have not been granted the ability to list or view files (this is a feature for blind dropping of files into a directory for upload capability so that people can send files and not see what other people have sent to the same directory ... a known standard, and useful, configuration).

Confirm that the ftp site you have created is the default that you are going to and that you do have full permissions to it.  

This sounds like a configuration problem due to the new changes in the ftp service integration with IIS.

I will see if I can find something that details how to set up a new site and do the configuration you are looking for.
0
 
LVL 22

Assisted Solution

by:cj_1969
cj_1969 earned 2000 total points
ID: 23600219
Here is some documentation from MS on ftp7 ...
An installation guide ... http://learn.iis.net/page.aspx/263/installing-and-troubleshooting-ftp7/
Creating a new site ... http://learn.iis.net/page.aspx/301/creating-a-new-ftp-site/ 
   *** make sure you read the authentication section
Adding ftp publishing to an existing site ... http://learn.iis.net/page.aspx/303/adding-ftp-to-a-web-site/

Look at the pages.  There are additional links on these pages that take you to other step by step pages for other configurations.
0
 

Author Comment

by:eric_ptek
ID: 23600597
I'll double check it all, I went through those guides but do not remember the part about authentication which is where my problem most likely is.

Thanks
0
 
LVL 22

Expert Comment

by:cj_1969
ID: 23600632
It looks like anonymous the the only default authentication enabled.  I can see them leaving that with a blind drop configuration as the default ... it is the most secure while still allowing access to the ftp server.
0
 

Author Comment

by:eric_ptek
ID: 23600655
I had anonymous access turned on.

I also know the path is right, you don't type it in, you pick it via a dialog box.

I've tried it with both that folder and another folder off the root of the C: drive called rdshare, no luck.
0
 
LVL 22

Expert Comment

by:cj_1969
ID: 23600705
I think you need to enable some basic authentication other than anonymous, or you need to change the anonymous permissions in the ftp server.  Try following the steps for the admin ID and see if you can get that part to work.  At least then you will know the the server is set up correctly and it is just a matter of tweaking the permissions on the anonymous account to make it do what you want.
0
 

Author Comment

by:eric_ptek
ID: 23677208
Thanks, went through it all again and it worked.
0
 
LVL 22

Expert Comment

by:cj_1969
ID: 23681045
I'm glad you got it working  :)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …
Is your OST file inaccessible, Need to transfer OST file from one computer to another? Want to convert OST file to PST? If the answer to any of the above question is yes, then look no further. With the help of Stellar OST to PST Converter, you can e…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question