We help IT Professionals succeed at work.

HyperV - problem copying large files  to virtualized SBS 2003/DC's

Line One
Line One asked
on
Medium Priority
706 Views
Last Modified: 2012-05-06
I have discovered a problem with an SBS2003 server running in a HyperV session.  When I copy a large file (100mb+) to the virtual SBS2003 server it will time out and fail. All internal file copy operations work okay.  It is like the Hyper-V virtual Nic is faulty. The system was using an internal NIC so I tried adding an Intel NIC and made it the NIC for the SBS 2003 virtual machine and left the original NIC for the host server. Same issue. When I copy a large test file (1gb VHD) to the SBS2003 drive(s) or domain controller I get a "Read-only" error message after 5-10 seconds and the copy aborts.  Small files copy okay.  No problem with virtualized 2003 member servers. I tried turning off large packets and also tried 100 megabit through flow control

System is running with one virtual processor.
My version of Hyper-V is 6.00.6001.1816

Comment
Watch Question

Commented:
I had a simlar wierd problem with HyperV. I fixed it by mistake by changing the virtual hard drive connection from SCSI to IDE. I'm unsure if this will help you but its worth a shot. Doing this does require the machine to go down while you make the change.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
CERTIFIED EXPERT
Commented:
I wonder if this has something to do with SMB signing. When a server is made a domain controller, the SMB signing policies are changed. http://technet.microsoft.com/en-us/library/cc773388.aspx#BKMK_SMBSigning.

Also, I know that TOE can cause similar issues, if you run MS KB 948496, SNP will be disabled, which will also disable TOE / RSS.
za_mkhIT Manager
Commented:
I was also goint to recommend the TOE issue as being the cause. Normally you will find, this problem if you try to copy a file from your Hyper-V HOST to your GUEST - but if you do it from another PC to to your HYPER-V Guest then the problem doesn't appear - if that is what you experience you will need to disable TOE.

Author

Commented:
Thanks for all the tips.  Let me get some downtime on the system and I will try these out and report back.

Commented:
YES TOE!!! I had this problem also. Disable this on the host NIC & your slowness should go away.

Author

Commented:
I am hoping to get to this over the weekend.

Commented:
Great! Let us know what happens.

Author

Commented:
Ok.  I tried all the remedies. Nothing worked. I changed the RAM and the problem seemed to get 'better' but not completely go away. The copying would go through  but when I compared some large files - copied from/copied to -  there were size differences/corruption.  Unfortunately at this point I stopped being methodical - it was taking too long to do 'step-by-step' and I was under time pressure to get the system into production so I worked  by 'feel/desperation'. I played with BIOS and changed hard drives, put back old RAM, etc.  At the end of a lot of these shots in the dark the problem seems to have gone away - with the old RAM and the original settings minus any of the tweaks recommended here.  So it's working but I can't say why. I guess that's better than not working and not being able to say why.  Sorry I can't be more helpful.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.