• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 857
  • Last Modified:

RPC over HTTP in Exchange 2007

I have tried configuring RPC over HTTP but it does not work in my Exchange 2007 Enviroment.
I have 1 CAS Server and 1 Mailbox Server.
 
I have a purchased a 3rd party Certficate that support multiple DNS Names. The primary Name of the Certificate is lenz-akl-sv17.lecom.lcoal FQDN of my Exchange Server. I ahev put in access.lecom.co.nz as one of Names in the Certificate.

The address I have put for my External DNS records is access lecom.co.nz.

I checked the net and installed RPC over HTTP components, also have added access.lecom.co.nz in the HOST addres in the propertieds of Outlook anywhere.

I went and did a Get-ClientAccessServer | fl and it came stating the AutodiscoverServiceInternalURL : https://lenz-akl-sv17.lecom.local/Autodiscover.......

I thought that I will have to change the Autodiscover  URL to https://access.lecom.co.nz/Autodiscover.......but when I try to change it I get the error below:

Set-ClientAccessServer : A parameter cannot be found that matches parameter nam

e 'https://access.lecom.co.nz/autodiscover/autodiscover.xml'.

At line:1 char:23

+ Set-ClientAccessServer  <<<< -Identity lenz-akl-sv17 -AutodiscoverServiceInte

rnal URi https://access.lecom.co.nz/autodiscover/autodiscover.xml

I have read some Microsoft Doc and they have stated that I do not need to Modification of SCP object or Modification of Web services URLs

I need to get the RPC over HTTP working before I can migrate from Exchange2003 to Exchange2007. OWA and Activesyn works fine, the only thing not working is RPS over HTTP.

I am not sure what I am doing wrong.
0
aij170278
Asked:
aij170278
1 Solution
 
jhautaniCommented:
Hmmm...could it be just a simple typo.
Your error message suggests that you had a space between 'l' and 'U' in parameter -AutodiscoverServiceInternalUri.
So the command treats the 'https://....' part as a parameter instead of a value.

HTH
0
 
unnivishwanathanCommented:
+Please read through the below article and related links in it.
Managing Outlook Anywhere
http://technet.microsoft.com/en-us/library/bb123513.aspx 

+ http://office.microsoft.com/en-us/ork2003/HA011402731033.aspx : "Configuring Outlook 2003 for RPC over HTTP"

+I understand that your external host name on Exchange 2007 is still not exposed to Internet. Are you testing your Outlook anywhere internally?

+Autdiscover SCP is nowhere related to Outlook Anywhere.

+If your certificate prinicipal name, i.e "issued to" name on the certificate does not match the external host name set for Outlook Anywhere then you must run
Set-OutlookProvider -identity EXPR -CertPrincipalname msstd:<issued to name of certificate> in this case : lenz-akl-sv17.lecom.lcoal
Ref : http://technet.microsoft.com/en-us/library/cc535023.aspx
0
 
MesthaCommented:
Your first mistake was making the primary name the internal name. It should have been the external name.
Things will get complicated when the certificate has an internal name as the common name.

-M
0
 
aij170278Author Commented:
Hi,

This has been fixed now.

There was a typo error in my URL Command and I had made chnegs to my Firewall but it did not update on time, so did it again and all went well.

Thanks
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now