We help IT Professionals succeed at work.

Backup Exec cannot attach to resource

markpetch
markpetch asked
on
Medium Priority
625 Views
Last Modified: 2013-12-01
Hi,

I'm running a Windows 2003 Server with SP2 and MS Exchange 2003 (SP2). Backup Exec is installed with all the latest updates for 11d (Remote Agent).

I can successfully backup this server using GRT but I cannot perform a restore to any of the mailboxes. The error I receive is, Final error: 0xe000848c - Unable to attach to a resource,  V-79-57344-33932.

Please help!
Comment
Watch Question

Commented:
Is your original backup going to disk?
If it is, and the restore doesn't work, make sure that the following applies for the logon account you use in the restore group:
* Logon account has a mailbox associated. The mailbox has been sent at least one email
* The logon account's mailbox  is not hidden from the global address list
* The logon account has been delegated Full Exchange Administrator permissions from organisation level in Exchange System Manager.
* The logon account's mailbox name is unique in the organization (http://seer.entsupport.symantec.com/docs/256537.htm)

Author

Commented:
Yes we are writing to disk and then to tape. The restore is coming from the tape though because we only keep the disk backup for 1 week and use the tapes for longer periods.

All the points you made have been adhered to but I'm still getting the problem.

Commented:
Is the logon account a domain admin? And is the logon account a local administrator on the Exchange server (make sure it is a local administrator on its own, and not explicitly through group membership).

Also try the following: in Tools/Options/Microsoft Exchange enable the option for "Legacy mailbox backup". This will add a new entry with name "Microsoft Exchange Mailboxes" to the selection list. Try selecting that selection with the same Logon Account you use for the restore. Does that work or does it throw an "Access Denied" or "unable to attach" error.

Author

Commented:
The account is an administrator on the local server.

Already had the legacy option enabled before I posted this.

When I run a test with the account I use, it passes. I've tried accessing mailboxes through Outlook with this account also and it can open them fine. You would think that you could do a restore with the same account but for some reason it fails...

Commented:
I  suggest create a completely new account with all the requirements and try again.

Try enabling debug logging on the Remote Agent service. I can't guarantee I'll see something, but I'll try.

Author

Commented:
Just a quick question, do I need to take the store offline whilst trying to do a recovery?

Author

Commented:
Hmm,

I am now getting this error after tweaking the resource credentials to use my purposely created veritas account,

Job ended: 12 February 2009 at 14:27:35
Completed status: Failed
Final error: 0xe0008488 - Access is denied.
Final error category: Security Errors

For additional information regarding this error refer to link V-79-57344-33928
Commented:
No - you don't need to take the store offline.

It still looks like you're logon accounts have sufficient permissions.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
When I researched the article it claimed the error was due to the job trying to write the data to a compressed disk. That is not the case for me so I'm still lost...

Commented:
I meant to say "insufficient permissions" in my previous post.

Try enabling debug logging on the Remote Agent service. I can't guarantee I'll see something, but I'll try.

Author

Commented:
Could you explain how I go about this please?

Author

Commented:
Never mind. Cracked it by completely deleting the temp staging area and tweaking the permissions.

Author

Commented:
Just need to delete the staging area because this might have been written back to disk in a corrupt manner.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.