We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Need help with Windows Essential Business Server Preparation Wizard DC error.

Medium Priority
1,098 Views
Last Modified: 2013-11-10
I have got an issue with the Windows Essential Business Server Preparation Wizard.
Im running the wizard from the DC with admin rights.

When trying to scan for data, I get the following message :
Error: A list of domain controllers could not be collected.

We have 2 DC's in the AD, and both of these show up just before this error in the logfile.

Here's the error info from the WEBS.BPA.Console.log if this helps :

[9824],"2009-02-09 14:02:37.177","DirectoryServices","Error","failed to FindAll domaincontroller entries"
[9824],"2009-02-09 14:02:37.209","DirectoryServices","Error","System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.WEBS.Networking.DirectoryServices.GetDomainControllerEntries(String DcToQueryAgainst, String SiteName)"
[9824],"2009-02-09 14:02:37.256","ServerInfoCollector","Error","Microsoft.WEBS.Networking.DirectoryServicesMmsNwException: A list of domain controllers could not be collected. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.WEBS.Networking.DirectoryServices.GetDomainControllerEntries(String DcToQueryAgainst, String SiteName)
   --- End of inner exception stack trace ---
   at Microsoft.WEBS.Networking.DirectoryServices.GetDomainControllerEntries(String DcToQueryAgainst, String SiteName)
   at Microsoft.WEBS.Networking.DirectoryServices.GetDomainControllersFqdn(String DcToQueryAgainst, String SiteName, Collection`1& undiscoverableDcs)
   at Microsoft.WEBS.BPA.Extensions.DataCollectors.ServerInfoDataCollector.PopulateData(DataSet& collectedData)"
[9824],"2009-02-09 14:02:37.256","WEBSBPA_Engine","Error","Microsoft.WEBS.BPA.Engine.DataCollectionException: A list of domain controllers could not be collected.
   at Microsoft.WEBS.BPA.Extensions.DataCollectors.ServerInfoDataCollector.PopulateData(DataSet& collectedData)
   at Microsoft.WEBS.BPA.Extensions.DataCollectors.ServerInfoDataCollector.CollectData(IExecutionEngineDataContext executionEngineDataContext, IDictionary`2 executionParameters, DataSet& collectedData)
   at Microsoft.WEBS.BPA.Engine.DataCollector.Execute(IExecutionEngineDataContext executionEngine, IDictionary`2 executionParameters, DataSet& outputData)
   at Microsoft.WEBS.BPA.Engine.ExecutionModule.Execute(IExecutionEngineDataContext executionEngine, IDictionary`2 executionParameters, Logger logger, DataSet& outputData)
   at Microsoft.WEBS.BPA.Engine.ExecutionEngine.ExecuteModule(ExecutionModuleContext executionModuleContext)
   at Microsoft.WEBS.BPA.Engine.ExecutionEngine.ExecuteModuleMain()"
[9824],"2009-02-09 14:02:37.256","WEBSBPA_Engine","Information","Marking executing module ServerInfo as failed"
Comment
Watch Question

Are your domain controllers in the "Domain Controllers" OU?

Also, try running the prep wizard on a normal PC logged in with Domain Admin priv's.

Author

Commented:
I have tried from other PC's with admin rights which does not make any difference.

Heres what the log says about the DC's right before the error occurs...:
I have replaced the domain name with xxxxx for security reasons.

[9824],"2009-02-09 14:02:37.052","DirectoryServices","Information","search root: LDAP://CN=Sites,CN=Configuration,DC=xxxxx,DC=com"
[9824],"2009-02-09 14:02:37.146","DirectoryServices","Information","GetDomainNameFromDN with DN CN=RP-VENUS,OU=Domain Controllers,DC=xxxxx,DC=com"
[9824],"2009-02-09 14:02:37.146","DirectoryServices","Information","domainName for DN CN=RP-VENUS,OU=Domain Controllers,DC=xxxxx,DC=com is xxxxx.com"
[9824],"2009-02-09 14:02:37.146","DirectoryServices","Information","Adding directory entry to DCList: LDAP://CN=RP-VENUS,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=xxxxx,DC=com"
[9824],"2009-02-09 14:02:37.162","DirectoryServices","Information","GetDomainNameFromDN with DN CN=RP-MERKUR,OU=Domain Controllers,DC=xxxxx,DC=com"
[9824],"2009-02-09 14:02:37.162","DirectoryServices","Information","domainName for DN CN=RP-MERKUR,OU=Domain Controllers,DC=xxxxx,DC=com is xxxxx.com"
[9824],"2009-02-09 14:02:37.162","DirectoryServices","Information","Adding directory entry to DCList: LDAP://CN=RP-MERKUR,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=xxxxx,DC=com"
[9824],"2009-02-09 14:02:37.177","DirectoryServices","Error","failed to FindAll domaincontroller entries"

....


ok - so from the brief look it seems that there is a DNS issue... from the look of it LDAP can see the DC but for some reason the Ad services can't see or connect to the other DC's. Firstly, make sure the firewalls on both DC's are disabled (2008 is a pain in the arse like this), secondly make sure all DC's are resolving properly... especially remove the ipv6 resolution if your using 08 as it breaks heaps of things. just add hosts file entries to make sure your dc's are resolving each other OK.

You can also add extra AD logging to establish exactly what is causing the AD DC search to fail by http://support.microsoft.com/kb/314980 

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Tried to add the entries into the hosts files. This did not change anything.
The DC's are booth running 2003 Ent. The AD is a Windows 2000 native AD, dont know if this could be the problem somehow.
well the pre-reqs of bes is 2003 sp2 and a native 2003 domain.

Author

Commented:
Its Windows2003 , but I dont see any requirements that states native 2003 domain anywhere.

Also the error message does not refer to an incompatible domain version?
but the error messages look like ad lookup errors...

Author

Commented:
Is there some kind of util, that will be able to check for AD lookup errors somehow ?
ah you can enable debug logging - not sure if it will give you much tho... http://support.microsoft.com/kb/314980 

worth a try i suppose

Author

Commented:
Found the solution, heres what i did:

I tried to update the domain functions to windows 2003 functionallity, this gave me an errorlog of servers which did not support win 2003 functionallity.

The list had a dead DC which is not in the domain at all (the server crashed a while ago), so i tried removing it using this guide:
http://support.microsoft.com/kb/216498

After it was removed from the ad, the Planning tool moved on successfully! :-)

So the issue seemed to be a dead dc in the ad.
Thanks for the help.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.