We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

SBS 2003 not receiving E-mails, Relay issue

LZ1
LZ1 asked
on
Medium Priority
579 Views
Last Modified: 2012-05-06
Hey Experts!!
I want to thank the experts who graciously helped me earlier. However it seems that I am still open to relaying.  My Exchange message queues are filling up very quickly.  Please see my previous question:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24125658.html 

I have checked out other posts and came across this KB:
http://support.microsoft.com/default.aspx?scid=KB;EN-US;324958 

Is this one going to work?  I did try to do this before, but still no luck.

PLEASE HELP!!!
Comment
Watch Question

Are you using single NIC or dual NIC configuration?

You're... Exchange System Manager>Servers>Protocols>SMTP Server>Properties>Access>Relay settings should by default be only accepting from your Exchange local IP address and 127.0.0.1 using the 'Only in the list below' checkbox.
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
so you think that your server is open for relay...
check this :
go to properties of Default smtp virtual server--> access tab--> relay button..
you should have a check on 1st option "Only the list below" and there should be nothing inside the list"

then do this..telnet test....on the command prompt

telnet localhost 25
ehlo

mail from: abc@abc.com
rcpt to: xyz@xyz.com


As soon as you hit the enter key.. it should give "Unable to relay"... if it gives OK.. let me know...
if you get OK... then your server is Open for relay




LZ1
Top Expert 2011

Author

Commented:
MarkMichael: We are only a single NIC. I have removed our server's static IP (192.168.1.xxx) from the Relay settings box and am only using the localhost IP.  
x-sam: I have tried this and the mail from is fine.  I get a 'sender OK' response.  When I do the rcpt to:xxx@aol.com it gives me a 'send hello first' message.
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
can  you show me the screen shot of the command prompt.. i thnk we are doing somethng wrong there..
LZ1
Top Expert 2011

Author

Commented:
Here you go.  I was unable to recreate the last error message prior.  Now it's giving me either an unrecognized command or invalid address.  Is this because the Exchange queue is filling up so quickly?
cmd.jpg
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
just use :

mail from: abc@abc.com
rcpt to: xyz@xyz.com

and test.. dont use other emails... and on telnet session do not do a backspace...
LZ1
Top Expert 2011

Author

Commented:
first one came back with 'send hello first'
rcpt to came back with 'send hello first'
LZ1
Top Expert 2011

Author

Commented:
Just did a Checkor.com and these are the results.
220 aventric.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at Mon, 9 Feb 2009 18:52:07 -0500
HELO ortest.checkor.com
250 aventric.com Hello [204.16.252.112]
RSET
250 2.0.0 Resetting
MAIL FROM: test@checkor.com
250 2.1.0 test@checkor.com....Sender OK
RCPT TO: test1@checkor.com
550 5.7.1 Unable to relay for test1@checkor.com

RSET
250 2.0.0 Resetting
MAIL FROM:
501 5.5.4 Invalid Address
RCPT TO: test1@checkor.com
503 5.5.2 Need Mail From: first

RSET
250 2.0.0 Resetting
MAIL FROM: spam@mail.aventric.com
250 2.1.0 spam@mail.aventric.com....Sender OK
RCPT TO: test1@checkor.com
550 5.7.1 Unable to relay for test1@checkor.com

RSET
250 2.0.0 Resetting
MAIL FROM: spam@mail.aventric.com
250 2.1.0 spam@mail.aventric.com....Sender OK
RCPT TO: test1@checkor.com
550 5.7.1 Unable to relay for test1@checkor.com

RSET
250 2.0.0 Resetting
MAIL FROM: spam@mail.aventric.com
250 2.1.0 spam@mail.aventric.com....Sender OK
RCPT TO: test1@mail.aventric.com
550 5.7.1 Unable to relay for test1@mail.aventric.com

RSET
250 2.0.0 Resetting
MAIL FROM: spam@mail.aventric.com
250 2.1.0 spam@mail.aventric.com....Sender OK
RCPT TO: "test1@test.com"@mail.aventric.com
550 5.7.1 Unable to relay for "test1@test.com"@mail.aventric.com

RSET
250 2.0.0 Resetting
MAIL FROM: spam@mail.aventric.com
250 2.1.0 spam@mail.aventric.com....Sender OK
RCPT TO: @mail.aventric.com:spamtest@checkor.com
550 5.7.1 Unable to relay for spamtest@checkor.com
 
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
1) check if you are getting any errors on the application Log regarding XCH50
2) DO You have a  smtp connector to internet created on the SBS ?
3) if not create one smtp connector with address space * and add the local server as bridge head server. and then on the properties of the smtp connector --> advance tab--> check the option send HELO instead of EHLO...
Restart the smtp and microsoft routing engine service...
test again...

-x
LZ1
Top Expert 2011

Author

Commented:
2nd update:
I do have the "apply recipient filter" checked.  I have also made sure that there are NO IP addresses under the "relaying" button for my virutal SMTP server.  
Queue's still filling up at the rate of about 20,000 per minute.
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
you are gettign Unable to relay..... so thats a good news...
your server is NOT OPEN FOR RELAY... its not allowing mails to relay to any external domain using your exchange server... it proves it..........
LZ1
Top Expert 2011

Author

Commented:
x-sam:
  1. No error's regarding the XCH50
  2. I think I do, how can I check?  

LZ1
Top Expert 2011

Author

Commented:
Well that is good news.  So then why is the exchange server still filling up?
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
what is filled up in the queue.. is it the spams or valid emails ?
Senior System Engineer
CERTIFIED EXPERT
Commented:
first lets stop the SPAMS......

Just follow this :
1) fist and the formost thing is to enable all the spam filterings on the exchange server :

--> On the properties of Message Delivery under Global Settings in the Recipients Filtering tab checked the 'Filter recipients who are not in the directory'
--> On the Sender Filtering tab checked the 'Filter messages with blank sender'
-->  On the Connection Filtering tab added a rule in the Block List Service Configuration as a display name of Spam Haus, DNS suffix of zen.spamhaus.org and on the return status code clicked on the Match filter rule to any of the filter responses and added the IP address from 127.0.0.2 to 127.0.0.12 with an exception
of 127.0.0.1, 127.0.0.3 and 127.0.0.9
-->  On the IMF tab changed the Gateway Blocking Configuration threshold to 7 and Archive When blocking messages and the Store Junk Email Configuration threshold to 6
-> then go to properties of default smtp virtual server--> general tab-->advance button--> edit--> and check mark all the filters except sender id filtering.................

-> enable tarpeting through the registry path :
-> NOW we wil add a regustry key so that if the spammer is using any kind of script exchange will break it....HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters and added a deword value TarpitTime and gave it a value of 5.

2) now stop the SMTP service. and go to "C:\Program Files\Exchsrvr\Mailroot location and rename Mailroot to MailrootOLD.
3) restart SMTP...... check the mail flow and monitor the queues......

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
LZ1
Top Expert 2011

Author

Commented:
Ok, did almost everything.  In the Internet Message Formats tab (IMF) I couldn't find the Gateway Blocking Config.  Is that still under message delivery properties?
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
yes yes.. go to message delivery properties--> IMF TAB
;-)
LZ1
Top Expert 2011

Author

Commented:
There is no IMF tab under the message delivery properties.  :(
LZ1
Top Expert 2011

Author

Commented:
Looks like everything works again.  Thank you so much X.  
I really appreciate you taking your time and guiding me through step-by-step.  
SurajSenior System Engineer
CERTIFIED EXPERT

Commented:
you should have Service pack 2 for IMF... make sure you install it... and configure it...

Thanks
-x-sam-
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.