We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now


Wireless Connectivity erratic

Medium Priority
Last Modified: 2013-12-27
I frequently lose the connection to my wireless router at home. My laptop never loses a connection at work (also a linksys).

When that happens, I can't see my wireless network in the list, and I can't repair the connection because of this. The router is 1 foot from my laptop. Why is that? My laptop is running windows XP.

My internet connection tends to die before my wireless connection goes. I frequently lose a connection to the internet as well. When this happens internet access can be regained by cloning the mac address. What I do notice though is that when I clone the mac address, my DHCP server becomes the cable modem instead of the wireless router. Which should I use as my dhcp server, the router or the cable modem?
Watch Question

Check for firmware updates for both your linksys and surfboard. You should be using your router as the DHCP server. Also make sure you have the latest drivers installed for your wireless card.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Check the firmware on the router at home, its good practice to keep it up to date. I might suggest trying using different channels, here in the US our the FCC regulates 11 channels on the 2.4Ghz band. If i remember correctly, Linksys wrt54g routers are set at the default channel 6. As well as many other manufactures. If theres alot of access points in or around where you live, there maybe be too much interfeirance from neighboring routers. I'd suggest channel 1 or 11 that'll keep you out range with other routers running on 6. Also, (if you happen to have one) alot wireless household phones run at 2.4Ghz and the base emits a broadcast every 10ms. They don't typically interfere but could be worth looking into.

 Possibly, relocating your router might be a resonable solution. radio waves can bounce all over the place and cause what are called "dead zones", just the way wave happen to bounce around. Keep it away from large metal objects, that can obstruct the path of RF getting around.
Also, i just read that your router is 1 foot away from your laptop... you'd think there should be no issue with it. I've seen diagrams of wireless devices needing a few feet of room before the RF is correctly received by the client. Best practices is to keep the router a little further away. I'd say maybe 6-7 feet.

 The MAC cloning thing, I used to have this problem with Verison DSL. They'd take a snapshot of my mac address during the term of the IP lease. When successfully connected, go into the router do a "DCHP Release" change the mac address back to its original, and renew the IP. If that doesn't work, change the MAC address on your router back, call your ISP and have them release it. Hope this all helps


Actually upon further tests the problem is not my cable modem, but my vonage voip router.  For some reason it is serving up the DHCP addresses, when my wireless card decides to connect. Note: I can be 30 feet away from the wireless router and experience the same issue
Can you access a GUI on your Vonage router and turn its DHCP feature off? Then I'd suggest setting up a static IP outside your linksys' routers DHCP scope, and setup port forwards to your Vonage routers static ip. Heres a little walk through along with the need-to-know port numbers you'll need.



At this point I have tried every solution and nothing works. I will keep this log open, and when I find a solution I will post it for everyones reference
what model vonage router and wireless router do you have? make/model?
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.