We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Can ping external IP addresses but not wwws - error "ping request could not find host ........."

worded
worded asked
on
Medium Priority
669 Views
Last Modified: 2012-05-06

e.g.
ping 216.239.59.147   (this is googles IP I found out on another machine)
works fine I get replies.

Ping www.google.ie or google .com or any www
"ping request could not find host .................................   Please check the name and try again"

Scratching head on this one.

Set up is a simple router with two PCs on it.  This one - working fine, and the other this one customers XP
Ive tried a winsock fix tool - same.

TCPIP - obtain IP auto / obtain dns server address - both on auto

 
Comment
Watch Question

Commented:
Sounds like a DNS issue.

run ipconfig /all and make sure that the DNS servers listed are correct.

Also, use nslookup to see if you can resolve www.google.com 

Using NSLOOKUP - http://support.microsoft.com/kb/200525

Commented:
I agree with -DJL-, if you can ping an IP address directly but not by name it is definitely a DNS issue.  Can you ping any of the DNS servers that are listed in the output of the ipconfig /all command?
You could also chack the hosts file found in the directory \Windows\System32\drivers\etc to see if there are any entries in the file that could be causing the issue.

Author

Commented:


hosts file looks normal

Yes I can ping the dns servers - Ive added these new ones.

159.134.237.6
159.134.248.17



Author

Commented:

NS lookup looks normal

It throws up four IP addresses
Aliases .. www.google.ie  and www.google.ie 

Any ideas?

Author

Commented:


Mad ..........

I can put googles IP address in the address bar and it shows it!

But I cant ping www.google.com 





Commented:
Just out of curiosity what problem is this causing, are you unable to browse to sites using a browser?
I am at a loss as to why you can get a DNS response and can ping IP addresses fine but cannot ping hostnames.
The only other thing I would say to try is to reset your TCP/IP stack using the following command and see if it clears up the issue...
netsh int ip reset c:\tcpipreset.log
If you want to post the output in the log file created I could take a look and see if anything looks strange.

Author

Commented:

I cannot browse to any www at all using either IE or firefox  (customer was onto netgear for hours / same problem.  Im using a different router / same problem)

Will try  c:\tcpipreset.log and report back


Author

Commented:

How often does a XP windows repair using the install cd work? i.e For any problem?

Ive done it about 10 times on different PCs over the years and Ive always had to totally wipe them anyway.

Commented:
I have had luck with it once or twice in the 10-15 times I have tried it.  I personally had to reformat and reinstall from scratch approx. every 6 months to get optimal performance from XP but I did a lot of software installing and uninstalling.
Commented:

Thanks to everyones efforts but Ive spent about four hours and Im throwing in the towel.  Netgear spent about three hours with the customer as well.

Windows is corrupt somewhere.  

I went to "repair" xp reinstall and it started looking for a file not on the cd.  

Im giving up on the repair option - it doesnt work IMO.

>>>>>>>>>>> requesting this Q is deleted.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.