UNC path fail to work when server is on fixed IP address

Posted on 2009-02-09
Last Modified: 2012-05-06

I'm currently encountering a strange problem in my office, I have a main server running on Windows Small Business Server 2003 and two other servers, a Terminal Server and a File Server both running on Windows Server 2003.

We used to have the terminal server and file server's IP address set to dynamic, but I find it just a better practice to set them to static since they are servers.

Our DHCP server on SBS 2003 is set to exclude the range from, and SBS2003's local network is on

 We used to be able to connect to share drives on all the server by typing //fserver/sharename$

After I set our file server's IP address to, the UNC path failed to work.
but if I type in the IP of the server directly \\\sharename it will work just fine.

I first thought it was a DNS issue so I flushed out all the cached DNS record from SBS 2003. Also on one of the client machine I ran nslookup on fserver.domain.lan and it finds the proper IP address for file server, also I tried to ping that IP address as well as its UNC path, both is working just fine.

But when I tried to type the UNC path into explorer window, it just stuck for about 5 minutes and says "Windows cannot find \\fserver\tool$, check the spelling and try again."

I'm just totally puzzled by this issue as the DNS resolve is correct and I just don't see what's the difference between typing in IP directly or using UNC path since they will get resolved to the same thing anyway.
Question by:a1454
    LVL 6

    Expert Comment

    That is pretty strange, you might want to make sure you don't have a secondary DNS server set up that is giving your PC the wrong address.  What response do you get from trying to ping the IP address and name of the server?

    How long has it been since you changed the IP address to static?  Even in a small network if you have multiple domain controllers, there might be replication issues requiring at least 30 minutes.
    LVL 8

    Expert Comment

    Hello a1454,

    Please try to disable the Windows Firewall service on \\
    I am not recommending this as a solution, just to test to isolate any firewall issues. Please Stop or Disable the Windows Firewall Service, and then once again on the client machine, try the UNC path.
    LVL 24

    Expert Comment

    Not just windows firewall but any firewall running and the antivirus (just for testing)

    Author Comment

    Thanks for all the comments.

    Windows Firewall on File Server is already off, also there are nothing else that will control network traffic on that machine, it has a Symantec Client Security running on it and that's about it.

    I get the exactly same ping result no matter if ping the IP address or the server name, as I've said earlier, nslookup is able to resolve the name to the proper IP address.

    There is only one domain controller in our network, SBS 2003 will not allow another DC in the same network. (one forest only, that is)

    The part that really have my puzzled is why I'm able to get to the share drive immediately if I type in \\\share$ in explorer window while typing \\fserver\share$ won't.

    Again thanks for all the comments, really appreciate the help
    LVL 6

    Expert Comment

    Did you try using the FQDN with your file share?  \\fserver.mydomain.whoreadsthis\share ?

    Author Comment


    I was testing just that and when I'm ready to come back and post update on the issue, I saw your comment!

    This just puzzles me even more, now with the fixed IP on the server, using FQDN worked!
    \\fserver.ykamerica.lan\share$ works

    But I'd still like to know why \\fserver itself won't work while it used to work.

    LVL 4

    Expert Comment

    Possible reasons.
    You don't have the search domain set.
    You have a wins server running(I can't remember if thats a standard sbs thing) which hasn't updated its database.(or even a local name cache)
    If you do have wins running trying typing nbtstat -RR on the file server. But probably just check the wins server to see what the name points to.
    LVL 6

    Expert Comment

    It is, as DJ Relentless said, most likely a WINS issue.  The short name is your NetBIOS name, which uses LMHosts / WINS vs.  FQDN or IP using DNS / Hosts.

    Author Comment

    Sorry I haven't respond to the thread for the past two days, I was performing a server restore over the weekend and was just exhausted from that.

    Thanks for the comments, I think I'm getting really close to find out the cause for this.

    Here is an update, I've tested and find out one thing, NOT every client machine have the same issue.

    Some client machine can still use \\fserver\share$ without problem, but some client machine just won't work with UNC.

    I actually don't know too much about WINS Server, I thought that's something belong to the Windows 2000 family?

    But I think its very likely a local name cache issue, as some machine will work and some won't, so in that case how do I manually have a client machine purge its local name cache?

    Again, thanks for all the comment, really appreciated!!
    LVL 6

    Accepted Solution

    Try running ipconfig /flushdns from your command line.

    Author Closing Comment

    ipconfig /flushdns worked, thanks a whole bunch!! :)

    Also thanks for everyone who answered, its been a great help!!

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    by Batuhan Cetin In this article I will be guiding through the process of removing a failed DC metadata from Active Directory (hereafter, AD) using the ntdsutil tool in a Windows Server 2003 environment. These steps are not necessary in a Win…
    A quick step-by-step overview of installing and configuring Carbonite Server Backup.
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now