We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now


DynDNS setup on Linksys router doesn't return the correct IP, modem interferes.

Ronino asked
Medium Priority
Last Modified: 2012-05-06

I have come up against the first instance of DynDNS failing its purpose.

Setup: Cox cable broadband, generic Motorola modem ( lan) , Linksys wireless router ( wan, lan), then workstations.

I want to access the FTP server on one of the workstations via  DynDNS, so I set up the Linksys router with my DynDNS account.

Problem: instead of reporting my actual IP address at the school, i.e., it actually reports its own wan address, Obviously if I try to access my FTP server with the hard IP it works, and if I tru to use mydomain.dyndns.org, it doesn't.

How can I fix it?

Watch Question

There are a 1000 ways to skin the technology cat.
I don't think you will be able to open ports back to your LAN.  I have seen this before.  Your ISP is masking your home LAN behind their modem.  This is why you are seeing a differing public IP than that of your router.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts


It doesn't seem to be some purposeful action on the part of the ISP. If I download the DynDNS Windows client on a PC, it works fine - gets the IP as if was a lookup on www.whatismyip.com. However, the router doesn't seem to be "smart" enough to do the same - it just looks at the IP on the WAN port.

Strangely enough, I remember being able to use a router's embedded DynDNS function successfully, although that was DSL not cable.

You need to see if you can turn off the router function in your Motorola modem so that instead of it offering a DHCP address to your router, it "passes through" the address it's getting from your ISP, so that your router's WAN address is coming from your ISP rather than from your Motorola modem.


Tried switching Motorola to 'bridge' or 'switch' mode, not possible.
Irwin W.There are a 1000 ways to skin the technology cat.

I really don't believe that you will be able to disable any functions on the router.  Your ISP uses it to manage and provision their clients.  In some cases they may have a limited number of Public IP's.


i am not trying to gain a new Ip, though - all I want is for DynDNS to display my actual, current, public IP - not a local LAN IP which is useless outside of my network.
Irwin W.There are a 1000 ways to skin the technology cat.

I understand what you are trying to do but I don't think that A: your ISP does not want you doing that or B: Your ISP has more customers than public IP's and this is how they support have more customers that public IP's.

You may have to end up paying your ISP for a static IP for business usage.
With all respect,I think nappy_d is incorrect.  If you are able to ftp successfully to your server using the numeric IP address (or whatever it really is), then you're not being issued a private IP address at the WAN port of your router.  Rather, your ISP anticipates that you might have multiple PC's, and that you'd rather use the router built into their modem than your own.  (I presume their modem has multiple LAN ports on it and/or wireless capability.)

Can you ask your ISP if you can trade the modem they have given you for a cable modem that does not have a router built into it?


That is correct guys. Modem's WAN IP works - I do have my own address.

The modem has a built-in router and multiple LAN ports - will seek alternative device.

Thanks for your help.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.