[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1577
  • Last Modified:

Cisco 837 ADSL Set up !

HI there,
I've done a basic config on a Cisco 837 for ADSL connection .... Config is below (with dummy ip's and passwd) that if it will work when i give it the real passwords, ip, etc ? One thing I dont understand is that router shows 4 interfaces ... ethernet 1 - ethernet 4 and 1 ADSL interface ofcourse .... When I do a show ip int brief on the router, it shows me 4 fastethernet interfaces (L2) and two ethernet interfaces (L3) ... I have assigned my I.P to ethernet0 which i cant physically find on the router ? can someone tell me how its like with 837 series router....given below are my show run and sh ip int brief ?

Main Question:
1. Is config for ADSL connection ok ?
2. Where is interface ethernet 0 ?
Current configuration : 3199 bytes
!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Villawood-Router1
!
boot-start-marker
boot system flash c837-k9o3sy6-mz.123-14.T3.bin
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
 
no ip ips deny-action ips-interface
ip sla monitor 1
 type echo protocol ipIcmpEcho 4.2.2.2 source-interface Ethernet0
 frequency 10
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
 type echo protocol ipIcmpEcho 4.2.2.3 source-interface Ethernet0
 frequency 10
ip sla monitor schedule 2 life forever start-time now
!
no ftp-server write-enable
!
!
username admin privilege 15 password 7 xxx
!
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
track 3 list boolean or
 object 1
 object 2
!
no crypto isakmp ccm
!
!
!
interface Ethernet0
 description Inside Interface
 ip address 1.1.1.1 255.0.0.0
 ip nat inside
 ip virtual-reassembly
 no ip mroute-cache
 standby 1 ip 1.1.1.5
 standby 1 preempt
 standby 1 track 3
!
interface Ethernet2
 no ip address
 no keepalive
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 ip virtual-reassembly
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap
 ppp chap hostname testname
 ppp chap password 7 testpwd
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 track 3
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit any
 
!
!
control-plane
!
 
line con 0
 exec-timeout 120 0
 password 7 xxx
 login
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 120 0
 password 7 xxx
 login local
 length 0
!
scheduler max-task-time 5000
end

Open in new window

0
nabeel92
Asked:
nabeel92
  • 6
  • 3
1 Solution
 
memo_tntCommented:
2- your Ethernet 0 apears well,,
here is it
interface Ethernet0
description Inside Interface
ip address 1.1.1.1 255.0.0.0
ip nat inside
ip virtual-reassembly
no ip mroute-cache
standby 1 ip 1.1.1.5
standby 1 preempt
standby 1 track 3
!
 
 
1- here is a 100% working Config.
 
!
interface Ethernet0
description link to LAN
no shutdown
ip address 192.168.1.1 255.255.255.0
 ip address 10.10.10.1 255.255.255.0 secondary
 ip nat inside
 ip tcp adjust-mss 1452
 hold-queue 100 out
!
interface ATM0
no shutdown
 no ip address
 atm vc-per-vp 64
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
 
!
interface FastEthernet1
 no ip address
 no shutdown
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 no shutdown
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 no shutdown
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 no shutdown
 duplex auto
 speed auto
!
interface Dialer1
no shutdown
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip inspect myfw out
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer remote-name redback
 dialer-group 1
 ppp authentication pap  callin
 ppp pap sent-username ******* password xxxxxxxx
 ppp ipcp dns request
 ppp ipcp wins request
!
ip nat inside source list 102 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1

!
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 23 permit 192.168.1.0 0.0.0.255

access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
!
!
P.S: interfaces 1-4 are as you minstiopned a L2 switch you can connect your LAN to any one of them,,
use config i posted and reply results
 
 
 
0
 
nabeel92Author Commented:
thanks for the post ...
I shall copy paste this config at work tomorrow and reply you with the results .... regarding ethernet0, it does appear in teh config but i just cudnt figure out the exact physical interface for it ... I'll double check it again at work tomorrow though !
0
 
nabeel92Author Commented:
will really appreciate if u cud reflect ur thoughts in ur spare time on the following topic

http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_24124410.html
0
The Growing Need for Data Analysts

As the amount of data rapidly increases in our world, so does the need for qualified data analysts. WGU's MS in Data Analytics and maximize your leadership opportunities as a data engineer, business analyst, information research scientist, and more.

 
nabeel92Author Commented:
hi there,
i just realized tht my backup adsl line on which i can test connections is not available for atleast another 1 week ... So I will post my results in about 1 week time ...
0
 
nabeel92Author Commented:
your configuration worked ... just tested it today by bringing the 837 home and tested it with adsl line ..... thanks for that...

now the question is that on my cisco 837 router, i have 4 interfaces and 1 adsl interface ... the interfaces are named ethernet 1,ethernet 2,ethernet 3,ethernet 4.....but when i do sh ip int brief,
i see ethernet 0, ethernet 2, fa 1,fa2,fa3,fa4 ...  

only when i plug my ethernet cable from PC to ethernet 1 or ethernet 2, and then check interface status, it shows ethernet0 as up ...  

I'm just kind of confused how it works with cisco 837 where it shows me interfaces ethernet 1-4 whereas in config, it shows me interfaces ethernet0, ethernet2, and 4 fast ethernet interfaces ? ?
0
 
nabeel92Author Commented:
sorry if i made the above confusing ... All I'm after is that physically when i look at the router I see the following interfaces
ethernet 1, ethernet2, ethernet3, ethernet 4

but when i do sh ip int brief or show run (as i did above)
i see ethernet 0, ethernet 2, fastethernet 1,2,3 and 4......

why the mismatch and which 1 is which ? or am i making a silly mistake here ?
0
 
memo_tntCommented:
no this is noraml
your active interface is ethernet0
and your switch L2 interfaces are
FE0,1,2,3
and forget others
BR
0
 
nabeel92Author Commented:
yes, but how do u explain that ethernet0 interfaces (the layer 3 interface) , where does it exist on the router ? is it a logical interface by default in 837 ?
0
 
memo_tntCommented:
send show version results
BR
0

Featured Post

Cyber Threats to Small Businesses (Part 2)

The evolving cybersecurity landscape presents SMBs with a host of new threats to their clients, their data, and their bottom line. In part 2 of this blog series, learn three quick processes Webroot’s CISO, Gary Hayslip, recommends to help small businesses beat modern threats.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now