We help IT Professionals succeed at work.

Routing issue with L3 3550

discmakers
discmakers asked
on
Medium Priority
378 Views
Last Modified: 2012-05-06
Hello all,
We have 3 subnets that are not able to communicate across VLAN's on a Cisco L3 3550. Subnets are as follows, 192.168.31.X, 130.144.122.X, 130.144.123.X. Each device in each subnet can ping it's gateway (for example 192.168.31.254) but can not ping across to the devices on the other vlan's. I can ping from 1 subnet and see 1 of the other subnet gateways housed on the 3550 but can't get further. A traceroute dies out at the 3550. Below I'll have a trace output from a switch at 192.168.31.241, to the gateway and then to a device on the subnet itself.

In the code area is a copy of the conf for the L3 3550 (lbrcore),31_241 switch, it's directly connected to port g0/1 of the 3550, and 123_253 switch which is directly connected to port g0/3.

Any and all help is appreciated. Thanks much,
Brett
31_241_switch#traceroute 130.144.123.254
 
Type escape sequence to abort.
Tracing the route to 130.144.123.254
 
  1 192.168.31.254 0 msec 0 msec *
 
31_241_switch#traceroute 130.144.123.90
 
Type escape sequence to abort.
Tracing the route to 130.144.123.90
 
  1 192.168.31.254 0 msec 0 msec 0 msec
  2  *  *  *
  3  *  *  *
  4  *  *
 
31_241_switch#
 
 
lbrcore#sh run
Building configuration...
 
Current configuration : 1754 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname lbrcore
!
enable secret 5 X
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
interface GigabitEthernet0/1
 switchport access vlan 31
 switchport mode access
!
interface GigabitEthernet0/2
 switchport access vlan 122
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet0/3
 switchport access vlan 123
 switchport mode access
!
interface GigabitEthernet0/4
 switchport access vlan 31
 switchport mode access
!
interface GigabitEthernet0/5
 switchport access vlan 31
 switchport mode access
!
interface GigabitEthernet0/6
 switchport access vlan 31
 switchport mode access
!
interface GigabitEthernet0/7
 switchport mode dynamic desirable
!
interface GigabitEthernet0/8
 switchport mode dynamic desirable
!
interface GigabitEthernet0/9
 switchport mode dynamic desirable
!
interface GigabitEthernet0/10
 switchport mode dynamic desirable
!
interface GigabitEthernet0/11
 switchport mode dynamic desirable
!
interface GigabitEthernet0/12
 switchport mode dynamic desirable
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan31
 ip address 192.168.31.254 255.255.255.0
!
interface Vlan32
 ip address 192.168.32.254 255.255.255.0
!
interface Vlan122
 ip address 130.144.122.254 255.255.255.0
!
interface Vlan123
 ip address 130.144.123.254 255.255.255.0
!
router rip
 network 130.144.0.0
 network 192.168.31.0
!
ip classless
ip http server
!
!
line con 0
 password 7 X
 logging synchronous
 login
line vty 0 4
 password 7 X
 logging synchronous
 login
line vty 5 15
 login
!
!
end
 
lbrcore#
 
 
 
cdplantswitch1#sh run
Building configuration...
 
Current configuration : 2647 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cdplantswitch1
!
enable secret 5 X
!
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/2
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/3
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/4
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/5
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/6
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/7
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/8
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/9
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/10
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/11
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/12
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/13
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/14
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/15
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/16
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/17
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/18
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/19
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/20
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/21
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/22
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/23
 switchport access vlan 31
 bandwidth 10000000
!
interface GigabitEthernet0/24
 switchport access vlan 31
 bandwidth 10000000
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan31
 ip address 192.168.31.241 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.31.254
ip http server
!
control-plane
!
!
line con 0
 password 7 X
 logging synchronous
line vty 0 4
 password 7 X
 logging synchronous
 login
line vty 5 15
 password 7 X
 login
!
end
 
31_241_switch#
 
123_253_switch#sh run
Building configuration...
 
Current configuration : 2785 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname lbrswitch2
!
enable secret 5 $1$oWL0$R7I43.Ji5AS00Xz63Vap20
!
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/3
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/4
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/5
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/6
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/7
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/8
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/9
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/10
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/11
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/12
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/13
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/14
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/15
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/16
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/17
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/18
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/19
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/20
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/21
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/22
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/23
 switchport access vlan 123
 spanning-tree portfast
!
interface GigabitEthernet0/24
 switchport access vlan 123
 spanning-tree portfast
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan123
 ip address 130.144.123.253 255.255.0.0
 no ip route-cache
!
ip default-gateway 130.144.123.254
ip http server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 password 7 X
 logging synchronous
 login
line vty 0 4
 exec-timeout 0 0
 password 7 X
 logging synchronous
 login
line vty 5 15
 no login
!
end
 
123_253_switch#

Open in new window

Comment
Watch Question

Your VLANs are configured on the core switch with switchport access. Take the VLANs off of the other switches. the core switch is expecting all traffic arriving on a port to not have any VLAN information attached to the packet. You could also change the uplink ports to "switchport mode trunk", and leave the VLANs on the other switches.

Author

Commented:
So changing it to trunking on the 3550 will do the trick? If I have "switchport mode access" set on the port on the other switches, will this also need to change to trunking?
Commented:
Here is a silly question. Did you remember to turn on routing on the switch? Not on by default.

I can tell you havent because there are no routes in your running config.

under global config mode, jsut type "ip routing"

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.