[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 174
  • Last Modified:

it is enabled but it shows again same error

Hi,
when i try to login phpmyadmin it shows cannot load mcrypt extension and when i check it through command line it shows mcrypt enabled
Please help

Thanks
phpmyadminerror.png
0
iilv
Asked:
iilv
  • 5
  • 4
  • 2
1 Solution
 
isaackhaziCommented:
you can get it to work by placing the libmcrypt.dll file into the
windows and system32 directory and restaring apache.
0
 
iilvAuthor Commented:
Hi,
where can i get libmcrypt.dll from?



Thanks
0
 
isaackhaziCommented:
Search your computer or download it from here:

http://www.down-dll.com/index.html?frameA=dll/l/libmcrypt.dll
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
PhatzerCommented:
Sorry that won't help you as that's for Windows servers, and by the look of the categories this question sits in you are using debian?

Right, you were saying that the extension is loaded OK? Have you made a info.php file containing the code below to check that PHP is showing all the correct settings, including a section for mcrypt?
<?php
 
// Show PHP information
phpInfo();
 
?>

Open in new window

0
 
iilvAuthor Commented:
Hi,

i have already checked it, it shows no section for mcrypt so what should i do now

please help

Thanks
0
 
PhatzerCommented:
Are you familiar with installing debian packages? Also, what version of PHP are you using?
0
 
iilvAuthor Commented:
Hi,

Yes and i am using php5


Thanks
0
 
iilvAuthor Commented:
Hi,

Please guide me on this how to resolve this issue

Thanks
0
 
PhatzerCommented:
Try installing the 'php5-mcrypt' package if it's not already and see if that makes any difference.
0
 
iilvAuthor Commented:
Hi,

i have already executed the command apt-get install php5-mcrypt

Thanks
0
 
PhatzerCommented:
Then really it's simply a case of checking that 'extension=mcrypt.so' (I think it is) is in your php.ini file, and that the mcrypt.so file exists in the extension directory for PHP, and then finally, restart apache... '/etc/init.d/apache2 restart'
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now