Connecting to SQL Server 2000 From Windows Vista Client

I am using SQL Server 2000 installed on Windows Server 2003 on a seperate dedicated server machine.

When Trying create a DSN from Windows Vista Client I am not able to create this DSN

Screen shot of the error message is attached.

This error message only occurs when the user tries to connect from the Vista Client.
There are several other Clients that run XP or 2000 professional and these can connect without any problem

Does anyone have any idea what might be causing the problem? and how can we get around it?

All Machines are on same local area network.

Thanks in advance

Vimal Sheth

Who is Participating?
VimalShethConnect With a Mentor Author Commented:
Finally i found the solution
the problem was need to install SQL server 2000 service pack 4 in the sql server

Thanks all
Raja Jegan RConnect With a Mentor SQL Server DBA & ArchitectCommented:
Try this from the command prompt:

telnet serverip 1433 (ur port opened on server firewall)

If you are able to connect, then its not an issue with server instead it is with the client.
Otherwise you need to enable or open ports from the server for the clients to access.
VimalShethAuthor Commented:
i tried
telnet 1433
this is wat i get

Connecting to not open connection to the host, on port 1433: Connect failed

but this fails even on XP n 2000 client machines where it works
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

VimalShethAuthor Commented:
i am having mixed OS on clients
most of them are XP machines and a few of them are 2000 machines
i can create ODBC DSN from those machines to the same server
It is a problem only on vista machines

even on xp machines where i can create the DSN s
if i telnet i still get the errorr
Raja Jegan RSQL Server DBA & ArchitectCommented:
Kindly check whether Local and Remote Connections are enabled in Surface Area Configuration and Both TCP/IP and named pipes are enabled in that server.

I hope till now, you have been connecting within your network.

To connect to this machine, check for the earlier one and then add an exception in Windows Firewall on the server machine for the port which you use to connect to server. The default is 1433.
VimalShethAuthor Commented:
What is Surface Area Configuration?
TCP/IP and Named pipes are both enabled on 2000 server

as i told earlier i am able to connect ot same server from my other XP n 2000 clients

itz only with these new installations of vista that i have this problem with

i have other vista clients installed 3 months back...i can connect from them

but not from these new vista machines

all of them have same hardware configuration too
VimalShethAuthor Commented:
i am using sql server 2000
do they have any surface area configuration tooll for that?
Raja Jegan RSQL Server DBA & ArchitectCommented:
Surface Area Configuration is a tool in SQL Server 2005, I just confused it over here.

Check this out:
VimalShethAuthor Commented:
checked the link

the machine on which my sql server runs is windwows 2003 server
and the sql server is 2000
i am not using nything 2008

Just to isolate the problem, turn the vista firewall off temporarily.
VimalShethAuthor Commented:
turned off the firewall

still does not work :|
Wouldn't think this would matter but you're signed on with admin rights on the Vista box?
Otherwise, last thought would be 64 bit.  If you're doing 64 bit we had a couple that wouldn't work until we selected 32 bit native sql drivers.  Then I'm out of ideas :-(
VimalShethAuthor Commented:
i'm signed in with admin rights in on vista box

n i am using 32 bit version of windows

still this is not working

earlier it was working.....but after reinstallation of windows vista it is not working :-(
Raja Jegan RSQL Server DBA & ArchitectCommented:
This should help you out:

As per the second post, In Vista eventhough you set the SQLSERVER service to automatically start, it will say it as started but actually it wont. Hence we may obtain this kind of problems.

To resolve this, you need to set it as Automatic(Delayed Start) which should fix your problem.
VimalShethAuthor Commented:
my sql server is not installed on vista
itz installed on windows 2003  server machine
itz my client that is on vista
Raja Jegan RSQL Server DBA & ArchitectCommented:
Ok.. First site is for you, confused the second site..
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.