Companyweb declined to show this webpage

I have a problem trying to use Sharepoint on 2003 SBS (release 1).
When i go to http://companyweb I get the error message The website declined to show this webpage.  This error shows if I enable anonymous access in IIS.
With anonymous access disabled, the site requres authentication and not even the administrator account can get to the site.

I have reinstalled intranet from the installation disk and I have tried resetting the IUSER and IWAM passwords.  The permissions on companyweb are authenticated users have read/write access.

We tried to force an upgrade of sharepoint but get the error message:
Cannot upgrade virtual server http://companyweb. Windows SharePoint Services doe
s not support in-place upgrading of SharePoint Team Services v. 1.0 from Microso
ft or FrontPage Server Extensions. You must migrate the content from this virtua
l server to a new virtual server extended with Windows SharePoint Services.
johnstuartcowellAsked:
Who is Participating?
 
orkinoksConnect With a Mentor Commented:
Ok, till that, we may check some other things.Is your asp file trying to include some other files? If there, check the permissions of those files as well. Also have you got any referance to a file like ../1.jpg where ../ means the upper folder. You need to open parent paths option if you have any links or including files.

If you are reading or writing some information to/from a access database, you also need to give write permissions to IUSR user for that  database and the folder including the database.

By the way, these are my last ammos :)
0
 
orkinoksCommented:
Hi;
what is the http error message you got and what is the default document set to be loaded when you try to access site with folder name? It can be a mime type issue, as well as the default document problem. Please check whether your existing default document (like default.asp) is added as homepage under IIS site properties and the extension of the file is added to mime types of the site.
0
 
johnstuartcowellAuthor Commented:
The error message when not using anonymous access is:
HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)
The default document is default.aspx (iIt is at the top of the list) and I have now added .aspx to the mime types.

Still get the same error message.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
orkinoksCommented:
Have you tried giving execute or full access to IUSR user?
0
 
johnstuartcowellAuthor Commented:
I have just tried your sugestion.  I gave the IUSR read and execute permissions and set directory security to enable anonymous access again.  I still get the error 403 Forbidden  The website declined to show this webpage.
0
 
orkinoksCommented:
Can you find which 403 error you are taking? Click Control Panel / Administrative Tools / Event Viewer / Security.

When you try to browse the site and get an error, a record will be created here.There should be more detailed error here like 403.1 or 403.2, there are several different 403 errors, we need to find out which one it is. Also look at the application part under event viewer, there may be useful information displayed as errors or warning.
(Dont mind the infomation records)
0
 
johnstuartcowellAuthor Commented:
I can't find any failure audits, errors or warnings regarding IIS or sharepoint in the security event log.  I've got no errors in Application log either.

I know that sounds wrong but I have checked twice and got someone else to look in case I missed something.
0
 
johnstuartcowellAuthor Commented:
Thanks for your time on this, although I have just circumvented the problem by installing Sharepoint 3.  I had no data in Sharepoint so this is a good new start.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.