?
Solved

Cisco 2800 upgrade IOS effected Fax service ?

Posted on 2009-02-10
18
Medium Priority
?
935 Views
Last Modified: 2012-05-06
I have upgraded IOS of my two sites cisco 2821 and one site cisco 2811 to the latest IOS. The actually problem fixed, but another problem came. Fax between two sites is getting issue now. Intermittent delays. Can any one explain the side effects of latest Cisco IOS for 2800 series router. The IOS name is (c2800nm-entservicesk9-mz.124-20.YA.bin).

Thanks
0
Comment
Question by:superludite
  • 10
  • 5
15 Comments
 
LVL 28

Expert Comment

by:asavener
ID: 23604298
Does the fax line use VoIP?
0
 

Author Comment

by:superludite
ID: 23610033
The fax machine is connected to the FXO port on the Voice Gatway Router.


0
 
LVL 28

Expert Comment

by:asavener
ID: 23611437
And have you configured QoS between the sites?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:superludite
ID: 23612840
Yes. I have configured QoS on both sites.
0
 

Author Comment

by:superludite
ID: 23719765
Thanks very much! I will be waiting for reply!
0
 
LVL 28

Expert Comment

by:asavener
ID: 23734706
Can you provide the router configuration so that we can review the QoS settings?
0
 

Author Comment

by:superludite
ID: 23735779
Yes. I will paste the router configs in a while

Thanks
0
 

Author Comment

by:superludite
ID: 23743560
Current configuration : 7410 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXX_VGW
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
enable password cisco
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
!
!
ip cef
!
!
ip domain name cexp.ie
ip multicast-routing
!
isdn switch-type primary-net5
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!voice translation-rule 1
 rule 1 /^3/ //
!        
voice translation-rule 2
 rule 1 /^/ /90/ type national national
 rule 2 /^/ /900/ type international international
 rule 3 /^/ /90/
!        
!        
voice translation-profile PRI-DID
 translate calling 2
 translate called 1
!        
voice translation-profile in-did
 translate calling 2
!        
!        
!        
application
 global  
  service alternate Default
 !        
!        
!        
!        
!        
!        
controller E1 0/0/0
 pri-group timeslots 1-26 service mgcp
!        
class-map match-any AutoQoS-VoIP-RTP-Trust
 match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
 match ip dscp cs3
 match ip dscp af31
!        
!        
policy-map AutoQoS-Policy-Trust
 class AutoQoS-VoIP-RTP-Trust
  priority percent 70
 class AutoQoS-VoIP-Control-Trust
  bandwidth percent 5
 class class-default
  fair-queue
!        

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!        
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.88.xx 255.255.255.0
!        
interface GigabitEthernet0/0.188
 encapsulation dot1Q 188
 ip address 192.168.188.xx 255.255.255.0
 ip helper-address 192.168.189.xx
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.168.188.xx
!        
interface GigabitEthernet0/1
 description - Link to WAN -
 ip address 10.10.xxx.xx 255.255.255.0
 duplex half
 speed 10
 service-policy output AutoQoS-Policy-Trust
!        
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!        
router eigrp 1
 network 10.0.0.xx
 network 192.168.88.xxx
 network 192.168.188.xxx
 auto-summary
!        
ip route 0.0.0.0 0.0.0.0 192.168.89.xxx
!        
!        
ip http server
no ip http secure-server
!        
!        

control-plane
!        
!        
!        
voice-port 0/0/0:15
!        
voice-port 0/1/0
!        
voice-port 0/1/1
!        
voice-port 0/1/2
!        
voice-port 0/1/3
!        
voice-port 0/2/0
!        
voice-port 0/2/1
!        
ccm-manager fallback-mgcp
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 192.168.189.xxx  
ccm-manager config
!        
mgcp      
mgcp call-agent 192.168.189.xxx 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
!        
mgcp profile default
!        
!        
!        
dial-peer voice 999020 pots
 service mgcpapp
 port 0/2/0
!        

dial-peer voice 999021 pots
 service mgcpapp
 port 0/2/1
!        
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
!        
dial-peer voice 2 pots
 description - Emergency -
 destination-pattern 999
 forward-digits 3
!        
dial-peer voice 3 pots
 description - Emergency -
 destination-pattern 9112
 forward-digits 3
!        
dial-peer voice 4 pots
 description - Local 8 -
 destination-pattern 9[2-9].......
 forward-digits 8
!        
dial-peer voice 5 pots
 description - VoIP -
 destination-pattern 9056........
 forward-digits 11
!        
dial-peer voice 6 pots
 description - National <11 -
 destination-pattern 90[1-2]T
 forward-digits 10
!        
dial-peer voice 7 pots
 description - National -
 preference 1
 destination-pattern 90[1-2].........
 forward-digits 11
!        
dial-peer voice 8 pots
 description - International -
 destination-pattern 900T
 prefix 00
!        

dial-peer voice 9 pots
 description - Mobile -
 destination-pattern 907[57-9]........
 forward-digits 11
!        
dial-peer voice 10 pots
 description - Freephone 0800 <11 -
 destination-pattern 9080T
 forward-digits 10
!        
dial-peer voice 11 pots
 description - Freephone -
 preference 1
 destination-pattern 9080........
 forward-digits 11
!        
dial-peer voice 12 pots
 description - Free phone <11 -
 destination-pattern 9050T
 forward-digits 10
!        
dial-peer voice 13 pots
 description - Free phone -
 preference 1
 destination-pattern 9050........
 forward-digits 11
!        
dial-peer voice 14 pots
 description - Reduced Rate -
 destination-pattern 9084........
 forward-digits 11
!        
dial-peer voice 15 pots
 description - National Rates -
 destination-pattern 9087........
 forward-digits 11
!        
dial-peer voice 16 pots
 description - Premium Rate <11 -
 destination-pattern 9090T
 forward-digits 10
!        
dial-peer voice 17 pots
 description - Premium Rate -
 preference 1
 destination-pattern 9090........
 forward-digits 11

dial-peer voice 18 pots
 description - Operator -
 destination-pattern 9100
 forward-digits 3
!        
dial-peer voice 19 pots
 description - Services -
 destination-pattern 9110
 forward-digits 3
!        
dial-peer voice 20 pots
 description - Services -
 destination-pattern 9118...
 forward-digits 6
!        
dial-peer voice 21 pots
 description - Services -
 destination-pattern 912[3-9]
 forward-digits 3
!        
dial-peer voice 22 pots
 description - Services -
 destination-pattern 9141T
 prefix 141
!        
dial-peer voice 23 pots
 description - Services -
 destination-pattern 9147[1-9]
 forward-digits 4
!        
dial-peer voice 24 pots
 description - Services -
 destination-pattern 915[0-5]
 forward-digits 3
!        
dial-peer voice 25 pots
 description - Services -
 destination-pattern 919.
 forward-digits 3
!        
dial-peer voice 26 pots
 description - NHS Direct -
 destination-pattern 908454647
 forward-digits 8
!
dial-peer voice 27 pots
 description - Freephone 030 <11 -
 destination-pattern 9030T
 forward-digits 10
!
dial-peer voice 28 pots
 description - Freephone -
 preference 1
 destination-pattern 9030........
 forward-digits 11
!
dial-peer voice 29 pots
 description - Reduced Rate -
 destination-pattern 9034........
 forward-digits 11
!
dial-peer voice 30 pots
 description - National Rate -
 destination-pattern 9037........
 forward-digits 11
!        
dial-peer voice 31 pots
 description - Freephone 033 <11 -
 destination-pattern 9033T
 forward-digits 10
!        
dial-peer voice 32 pots
 description - Freephone -
 preference 1
 destination-pattern 9033........
 forward-digits 11
!        
dial-peer voice 33 pots
 description - Reduced Rate -
 destination-pattern 9070........
 forward-digits 11
!        
dial-peer voice 34 pots
 description - Paging -
 destination-pattern 9076........
 forward-digits 11
!        
dial-peer voice 35 pots
 description - WiFi -
 destination-pattern 907911[28].....
 forward-digits 11



dial-peer voice 999010 pots
 service mgcpapp
 port 0/1/0
!        
dial-peer voice 999011 pots
 service mgcpapp
 port 0/1/1
!        
dial-peer voice 999012 pots
 service mgcpapp
 port 0/1/2
!        
dial-peer voice 999013 pots
 service mgcpapp
 port 0/1/3
!        
!        
!        
!        
call-manager-fallback
 secondary-dialtone 9
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address 192.168.188.xx port 2000
 max-ephones 30
 max-dn 100
 moh music-on-hold.au
 multicast moh 239.1.1.xx port 16384 route 192.168.188.xx 10.1.1.xx
!        
!        
line con 0
 password cisco
 login    
line aux 0
line vty 0 4
 password cisco
 login    
 length 0
!        
scheduler allocate 20000 1000
ntp clock-period 17179828
ntp server 192.168.189.xx
!        
end      



0
 

Author Comment

by:superludite
ID: 23743571
Also the user is complaining that if someone send a fax from international number fax is coming through, but if some one send or dial the fax number from Inside the office or Local PSTN in the same city, then they get busy signal or out of order message.

Any help will be appreciated.

Thanks
0
 
LVL 28

Expert Comment

by:asavener
ID: 23744539
Your quality of service statements attempt to match the DSCP value of the voice packets, but you don't set the DSCP value.

Every one of your dial peers need the following lines:

dial-peer voice xxx voip
 destination-pattern xxx
 ip qos dscp ef media ip qos dscp cs3 signaling
 
0
 

Author Comment

by:superludite
ID: 23746226
Just a quick question again,

The telephone provider tested the fax line, they tried to call the fax number with out caller ID, they passed through, but when they tried with the caller id active, they couldn't go through. Users only have issue receiving fax from the local city numbers ?
I think there is no issue with QOS on the Router!
All I am thinking that when I upgraded the IOS then it fixed one problem, but introduced another problem. It could be a IOS bug ??

Thanks

0
 
LVL 28

Accepted Solution

by:
asavener earned 1000 total points
ID: 23755683
If caller ID is actually the problem, you can solve it by having the fax pick up on the first ring.

Call ID info is sent between rings.
0
 

Author Comment

by:superludite
ID: 23772988
I am going to check this today and will reply back to you with the feedback ?
0
 

Author Comment

by:superludite
ID: 23845223
Thanks for all your reply,
Actually I found the issue, The  main issue was with the ISDN T1/E1 line, the previous IOS was detecting the default line coding for E1, but when I upgraded the IOS, which effected my fax service, and when I ran debug command and I got a message of standard voilation message, I realized that there is some issue with Line coding, as it was showing the (Line code ami), which suppose to be the European code i.e (Line code hdb3), when I changed this to hdb3, fax started work. Problem solved.

Thanks for your informative comments.
0
 

Author Closing Comment

by:superludite
ID: 31545076
Thanks
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Messaging apps are amazing tools with the power to do a lot of good, but the truth is the process of collaborating with coworkers requires relationships established through meaningful communication - the kind of communication that only happens face-…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question