We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

RPC Server Unavailable Running DCPROMO

Medium Priority
6,322 Views
Last Modified: 2012-08-13
I am trying to promote a win2k3 member server to be a DC in a windows 2000 domain.
When I run DCPROMO I get the following error on the win2k3 server:



"The RPC Server is unavailable"

If I perform a ping -a to my servers it returns the full name so it seems as if DNS is working correctly although from what I have already read on the net it does point to a DNS issue.

I also had a problem when trying to add a workstation to the domain earlier on when the same error was reported by I disabled the firewall and it then connected ok. (There is no firewall installed on my 2003 server)

When I run a 'replicate now' from AD sites and services it fails with RPC server unavailable

What can I do to resolve this?
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2013

Commented:
What box are you pointing to for DNS?
Check and make sure all the SRV records are properly registered for that box.
I'd also download portqry and make sure it is not a port issue
example (run from memberserver)
portqry -n ipaddress of dns server -e 53
Since you already checked that the firewall is not on then we can rule that out.
 
Thanks
Mike

 

Author

Commented:
I have run portqry and tested the following ports:
389 and 636 (LDAP)
88 and 464 (Kerberos)
They seem to be working ok - are there any others I should check?

Im not sure how to check the SRV records can you send me an idiots guide link?

Thanks

Author

Commented:
I have tried port 32 as well and this is 'listening'

Author

Commented:
Sorry I meant 53 (I mistyped that somehow :-p)

Author

Commented:
I may have found this for myself

I have run an nslookup
set type=all
_tcp.<my domain>

This returned the two DNS servers (which are also the two DCs)

so it appers that this is correct?
CERTIFIED EXPERT
Top Expert 2013

Commented:
Yeah and you can check for the SRV records by set type=SRV and querying for them too.  There is also a kb article about that
http://support.microsoft.com/kb/816587
The member server you are trying to promote is pointing to one of those boxes for DNS?
Have you checked the dcpromoui.log  
Sometimes that can provide clues too.
Thanks
Mike

Author

Commented:

Yes the results above were on the member server I am trying to promote.

There is some errors in the log saying that the user does not have the correct privilege to promote a server but I am using a domain admins account. (our domain is part of a forest and I have domain admin acccess to our domain only)

Author

Commented:
The error is
Active directory could not create the NTDS settings object for this domain controller [blah] on the remote domain controller [blah2] ensure the provided network credentials have sufficient permissionsThe RPC server is unavailable

but I think the permissions thing may be a red herring. I have now tried using two domain admin accounts.

Author

Commented:
I still haven't managed to solve this - does anyone have any more ideas?

Is there a way I can check the permissions of the user(s) to make sure they have the correct privilages?
(they are both members of the domain admins group but is there anything else?)
CERTIFIED EXPERT
Top Expert 2013

Commented:

http://forums.techarena.in/active-directory/997458.htm

http://www.petri.co.il/forums/showthread.php?t=4503

There were some other suggestions (time sync being one) in those threads.

This one is tough.
I have managed to circumvent this issue by removing this DC from the domain and promoting another server to be a DC. I think that the server in question was suffering from terminal issues from a previous virus infection so no 'normal' solutions worked - thanks for the responses

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.