• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1736
  • Last Modified:

network latency cisco 1300 wlan bridge

We have 2 remote offices that are connected to the central office via a Cisco 1300 wireless bridge.  We are noticing a problem where the net latency is growing more and more.  If I reboot all 3 of the bridges, the latency is fixed - temporarily.  within an hour, it is back.  I am seeing up to 300ms ping times and after rebooting, we get 1-2ms ping times.  This is causing major issues for our employees.  There is nothing unusual in the logs.  Can anyone help?
0
mis-uwhpwatertown
Asked:
mis-uwhpwatertown
  • 8
  • 7
1 Solution
 
from_expCommented:
i suppose your links are heavily loaded
reboot of a bridge cuts down all active connections, so you have temporarily fix for a problem.
try to monitor bandwidth usage.
802.11 is asynchronous wireless, so when link is saturated, response times are very bad...
0
 
mis-uwhpwatertownAuthor Commented:
I don't think that is the case.  Here are some numbers:

On one of the remote bridges:

avg transmit on dot11radio0 521Kbps or 1.01%
avg receive on dot11radio0 356 Kbps or 0.82%

On the CO end:

avg transmit on dot11radio0 505 Kbps or 1.02%
avg receive  on dot11radio0 418 Kbps or 0.62%
0
 
from_expCommented:
yepp, but it is for last 5 mins,  if you take show interface output
have you checked that output during high latency times?
and one more thing, it is possible, that there are a lot of small packets, so you don't have actual bandwidth, but a lot of packets to transmit
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
mis-uwhpwatertownAuthor Commented:
Here is the output during high latency:

BVI1 is up, line protocol is up
  Hardware is BVI, address is 0019.30dd.9b22 (bia 0019.306a.df30)
  Internet address is 10.0.25.42/24
  MTU 1500 bytes, BW 54000 Kbit, DLY 5000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 8000 bits/sec, 10 packets/sec
     9126 packets input, 1204286 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     218241 packets output, 19493530 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
Dot11Radio0 is up, line protocol is up
  Hardware is 802.11G Radio, address is 0019.306a.df30 (bia 0019.306a.df30)
  MTU 1500 bytes, BW 54000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3126
  Queueing strategy: fifo
  Output queue: 0/30 (size/max)
  5 minute input rate 327000 bits/sec, 251 packets/sec
  5 minute output rate 347000 bits/sec, 244 packets/sec
     1885828 packets input, 416701465 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     1790176 packets output, 327518397 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0 is up, line protocol is up
  Hardware is PowerPCElvis Ethernet, address is 0019.30dd.9b22 (bia 0019.30dd.9b22)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s, MII
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 2/80/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 280000 bits/sec, 240 packets/sec
  5 minute output rate 322000 bits/sec, 240 packets/sec
     1598810 packets input, 256058518 bytes
     Received 45835 broadcasts, 0 runts, 0 giants, 203 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1624468 packets output, 395363128 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Virtual-Dot11Radio0 is up, line protocol is up
  Hardware is Virtual Dot11 interface, address is 0019.306a.df30 (bia 0019.306a.df30)
  MTU 1500 bytes, BW 54000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 10:27:47
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/30 (size/max)
  5 minute input rate 318000 bits/sec, 248 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1907675 packets input, 425017609 bytes, 0 no buffer
     Received 31390 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
mis-uwhpwatertownAuthor Commented:
And this is the latency I am seeing at the time:

time=15ms TTL=254
time=23ms TTL=254
time=19ms TTL=254
time=17ms TTL=254
time=162ms TTL=254
time=32ms TTL=254
time=8ms TTL=254
time=13ms TTL=254
time=2ms TTL=254
time=7ms TTL=254
time=19ms TTL=254
time=20ms TTL=254
time=150ms TTL=254
time=14ms TTL=254
time=19ms TTL=254
time=176ms TTL=254
time=241ms TTL=254
time=97ms TTL=254
time=33ms TTL=254
time=20ms TTL=254
time=29ms TTL=254
time=45ms TTL=254
time=124ms TTL=254
time=48ms TTL=254
time=36ms TTL=254
time=14ms TTL=254
time=269ms TTL=254
time=15ms TTL=254
time=10ms TTL=254
time=3ms TTL=254
time=45ms TTL=254
time=165ms TTL=254
time=160ms TTL=254
time=19ms TTL=254
time=43ms TTL=254
time=100ms TTL=254
time=58ms TTL=254
time=47ms TTL=254
time=402ms TTL=254
time=82ms TTL=254
time=280ms TTL=254
time=21ms TTL=254
time=97ms TTL=254
time=268ms TTL=254
time=92ms TTL=254
time=160ms TTL=254
time=30ms TTL=254
time=95ms TTL=254
time=22ms TTL=254
0
 
from_expCommented:
ok, so my next question is about calibration and signal strength?
have you tried to calibrate antennas for optimal signal transmit/receive?
0
 
mis-uwhpwatertownAuthor Commented:
They are set to the default data rate:
require: 1, 2, 5.5, 11Mbps
enable:  6, 9, 12, 18, 24, 36, 48, 54 Mbps

The CCK Transmitter power is set to max, the OFDM transmitter power is set to max.
The client power local is enabled with the limit client power mW set to max.

The default radio channel is set to channel 4 on the CO site, and the remote offices are set to least congested frequency.  

I am not really familiar with how to calibrate the antennas.  Could you point me in the right direction?

Thanks
0
 
from_expCommented:
you should check actual signal strength (in dBm)
what type of antennas do you use?
0
 
mis-uwhpwatertownAuthor Commented:
Cisco Aironet 12 dBi High Gain Omnidirectional Antenna

Cisco 5.2dbi Omni-Directional Mast Mount Antenna

The signal strength on our CO bridge is:
[2]***pak in 887411 bytes in 222295091 pak out 841426 bytes out 191574487
      dup 3960 decrpyt err 0 mic mismatch 0 mic miss 0
      tx retries 296420 data retries 254345 rts retries 42075
      signal strength 80 signal quality 25
[1]***pak in 13893639 bytes in 2675010360 pak out 14287944 bytes out 3453206531
      dup 25629 decrpyt err 0 mic mismatch 0 mic miss 0
      tx retries 4930650 data retries 4147204 rts retries 783446
      signal strength 73 signal quality 28

One of the remote clients that is having issues:
[1]***pak in 15664703 bytes in 3811816028 pak out 13918555 bytes out 2568245473
      dup 0 decrpyt err 0 mic mismatch 0 mic miss 0
      tx retries 6806183 data retries 5229470 rts retries 1576713
      signal strength 70 signal quality 18

The other remote client that is having issues:
[2]***pak in 967706 bytes in 221087305 pak out 891546 bytes out 217030137
      dup 0 decrpyt err 0 mic mismatch 0 mic miss 0
      tx retries 544662 data retries 422119 rts retries 122543
      signal strength 69 signal quality 22
0
 
from_expCommented:
can you, please, post here config of both aps
0
 
mis-uwhpwatertownAuthor Commented:
CO-Bridge#wr t
Current configuration : 2488 bytes
!
! Last configuration change at 12:17:35 GMT Tue Feb 10 2009
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname *
!
enable secret *
!
clock timezone GMT -6
ip subnet-zero
ip domain name *
ip name-server *
ip name-server *
!
!
no aaa new-model
!
dot11 ssid *
   authentication open
   authentication key-management wpa
   guest-mode
   infrastructure-ssid optional
   wpa-psk ascii 7 *
!
!
!
username **
username **
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid *
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 channel 2427
 station-role root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 10.0.25.40 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.0.25.254
ip http server
!
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
logging history size 500
logging history debugging
logging trap debugging
logging facility syslog
logging *
snmp-server view dot11view ieee802dot11 included
snmp-server community * *
snmp-server community * *
snmp-server community * *
snmp-server location *
snmp-server contact *
snmp-server chassis-id *
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps entity
snmp-server enable traps disassociate
snmp-server enable traps deauthenticate
snmp-server enable traps authenticate-fail
snmp-server enable traps dot11-qos
snmp-server enable traps switch-over
snmp-server enable traps rogue-ap
snmp-server enable traps wlan-wep
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server enable traps cpu threshold
snmp-server enable traps aaa_server
snmp-server enable traps envmon
snmp-server host * *
snmp-server host * *
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
sntp server *
sntp broadcast client
end
CO-Bridge#

_________________________________________________________________


Remote-Bridge-1#wr t
Building configuration...

Current configuration : 2007 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname *
!
enable secret *
!
clock timezone GMT -6
ip subnet-zero
ip domain name *
ip name-server *
ip name-server *
!
!
no aaa new-model
!
dot11 ssid *
   authentication open
   authentication key-management wpa
   guest-mode
   infrastructure-ssid optional
   wpa-psk ascii *
!
dot11 ssid autoinstall
   authentication open
!
!
!
username * privilege 15 password *
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid *
 !
 ssid autoinstall
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role non-root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 10.0.25.42 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.0.25.254
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
logging trap debugging
logging *
logging *
snmp-server community *
snmp-server community *
snmp-server community *
snmp-server location *
snmp-server contact *
snmp-server chassis-id *
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps disassociate
snmp-server enable traps deauthenticate
snmp-server enable traps authenticate-fail
snmp-server host * *  disassociate deauthenticate authenticate-fail
snmp-server host * *
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
sntp server *
sntp broadcast client
end

Remote-Bridge-1#


________________________________________________________________


Remote-Bridge-2#wr t
Building configuration...

Current configuration : 2485 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname *
!
enable secret 5 *
!
clock timezone GMT -6
ip subnet-zero
ip domain name *
ip name-server *
ip name-server *
!
!
no aaa new-model
!
dot11 ssid *
   authentication open
   authentication key-management wpa
   guest-mode
   infrastructure-ssid
   wpa-psk ascii 7 *
!
dot11 ssid tsunami
   authentication open
!
dot11 network-map
!
!
username * password 7 *
username * privilege 15 password 7 *
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid *
 !
 ssid *
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role non-root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 10.0.25.41 255.255.255.0
 no ip route-cache
!        
ip default-gateway 10.0.25.254
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
logging trap debugging
logging *
logging *
snmp-server view dot11view ieee802dot11 included
snmp-server community *
snmp-server community *
snmp-server community *
snmp-server location *
snmp-server contact *
snmp-server chassis-id *
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps entity
snmp-server enable traps disassociate
snmp-server enable traps deauthenticate
snmp-server enable traps authenticate-fail
snmp-server enable traps dot11-qos
snmp-server enable traps switch-over
snmp-server enable traps rogue-ap
snmp-server enable traps wlan-wep
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server enable traps cpu threshold
snmp-server enable traps aaa_server
snmp-server enable traps envmon
snmp-server host * *  disassociate deauthenticate authenticate-fail
snmp-server host * *
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
sntp server *
sntp broadcast client
end
~
Remote-Bridge-2#
0
 
from_expCommented:
I can see you have 3 aps here - one main bridge, and two remote.
my question is: have you tried to switch off one of remote bridged during high latency pings?

configs looks ok, so I suppose you can try to perform carrier busy test.

dot11 interface-number carrier busy

show dot11 carrier busy
0
 
mis-uwhpwatertownAuthor Commented:
This morning, I changed all bridges to 'best throughput' for the data rates setting.  The speed has increased to >11mbps (it will vary from 11-54 depending on when I check the status).  Yesterday, we were getting between 1.0 - 6.0 on two of the bridges and 36.0 on the third.  

These tests were done on the CO Bridge: (They failed on the two troublesome remote bridges)

Link Test Output
 FAIR (18 % retries) Time Strength(dBm) SNR SNR Retries
  msec In Out In Out   In Out
 Sent 1000 Avg 6 - 76 - 71 27 22 Total 69 294
 Lost to Target 0 Max 21 - 69 - 66 37 30 Max 3 6
 Lost to Source 0 Min 2 - 80 - 77 17 5  
 Rates (Source/Target)   11Mb 54/54   12Mb 911/911   18Mb 35/35  


Carrier Busy Test Output
Frequency      Carrier Busy %
2412                       17
2417                        9
2422                        5
2427                        0 - We are operating on this frequency-all indoor APs we run nearby are on 2462
2432                        0
2437                        3
2442                        1
2447                        1
2452                        5
2457                        3
2462                       18

I received these results on the bridge we are not having as many issues with:

Link Test Output
 GOOD (2 % retries) Time Strength(dBm) SNR SNR Retries
  msec In Out In Out   In Out
 Sent 1000 Avg 3 - 64 - 70 30 33 Total 31 15
 Lost to Target 0 Max 47 - 59 - 64 39 42 Max 4 3
 Lost to Source 0 Min 1 - 85 - 94 7 1  
 Rates (Source/Target)   11Mb 197/196   9Mb 1/1   12Mb 422/422   18Mb 251/252   36Mb 23/23   54Mb 106/106  

The carrier busy test failed as well.  

_____________________________________________________

The information below is the current status stats once this particular remote office started utilizing the link:

 IP Address * Class bridge
 Device 11g-bridge Software Version 12.3
 CCX Version NONE    
 State Associated Parent  self  
 SSID *  VLAN  none
 Hops To Infrastructure 1 Communication Over Interface Radio0-802.11G
 Clients Associated 1 Repeaters Associated 0
 Key Mgmt type WPA PSK  Encryption TKIP
 Current Rate (Mb/sec) 2.0 Capability WMM ShortHdr ShortSlot
 Supported Rates(Mb/sec) 1.0, 2.0, 5.5, 6.0, 9.0, 11.0, 12.0, 18.0, 24.0, 36.0, 48.0, 54.0
 Voice Rates(Mb/sec) disabled Association Id 30
 Signal Strength (dBm) -77 Connected For (sec) 1331
 Signal to Noise (dBm) 38 Activity TimeOut (sec) 30
 Power-save Off Last Activity (sec) 0
 Apsd DE AC(s) NONE Posture Token  
 Session TimeOut (sec) 0 Reauthenticate In (sec) Never
Receive/Transmit Statistics
Total Packets Input 2236 Total Packets Output 2224
Total Bytes Input 415177 Total Bytes Output 423273
Duplicates Received 0 Maximum Data Retries 784
Decrypt Errors 0 Maximum RTS Retries  135
MIC Failed 0    
MIC Missing 0  

As you can see, once they started using it, the current rate dropped to 2.0 Mbps and once in awhile jumps up to 5.5 Mbps.

Now, one thing to consider here is the fact that the CO bridge is at a higher elevation in relation to the three remote bridges.  It is probably ~50-100 ft higher than the remote bridges, as the CO is on top of a hill, and the remotes are at the bottom of the hill.  Correct me if I am wrong but doesn't the omni-directional antenna sends waves out in a 'frisbee' like pattern?  If so, would it be advisable to tilt the omni antenna so that the waves will be at an angle as the travel down the hill?
0
 
from_expCommented:
hi!

As you can understand from results of tests signal quality is an issue.

and yes, you should adjust antennas to look at each other in both directions: horizontal and vertical.
and to gain better performance, I would advice to create to point-to-point links instead of point to multipoint solution.

as for antennas, please take a look here for examples:
http://www.l-com.com/category.aspx?id=2073
I would suggest:
porabolic, yagi or diversity
yagi will produce the best signal, but it's beam is very narrow.
0
 
mis-uwhpwatertownAuthor Commented:
We ended up getting a ptp bridge from Motorola that runs 54Mbps full-duplex.

Thanks for your help!
0

Featured Post

What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now