• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3042
  • Last Modified:

Cisco ASA 5505 PPPoE via DSL

Having trouble getting a public IP on the outside interface.

ASA 5505 running 8.0(2)
Westell E90610030-06 DSL box running current firmware.
Service provider is AT&T (Bellsouth)

DSL modem is in bridge mode.
Outside interface of 5505 is set to PPPoE with known good credentials.
I've tried CHAP and PAP authentication.

Last attempt, using MAC cloning, showed a PPPoE address of 0.0.0.0 255.255.255.255 in the client monitor in ASDM. Authentication is still set to CHAP.

I've read that AT&T does a 2-hour IP lease, so my next step is to shut down the DSL router for 2 hours and try again.

I believe PPPoE debug is still broken in this ASA version, unfortunately.

Troubleshooting remotely with the end-user

TIA


interface Ethernet0/0 
mac-address nnnn.nnnn.nnnn
nameif Outside 
security-level 0 
pppoe client vpdn group <group1> 
ip address pppoe setroute 
 
<---> 
 
vpdn group <group1> request dialout pppoe 
vpdn group <group1> localname <username> 
vpdn group <group1> ppp authentication chap 
vpdn username <username> password ******** store-local

Open in new window

0
JayCeeZee
Asked:
JayCeeZee
  • 2
1 Solution
 
JayCeeZeeAuthor Commented:
The "known good" credentials, weren't .

Testing the new config....
0
 
JayCeeZeeAuthor Commented:
It works, using PAP authentication.

It was a bad PPPoE username.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now