We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Ubuntu Blank Screen after Login

misharyth
misharyth asked
on
Medium Priority
1,727 Views
Last Modified: 2013-11-15
Hi,
I installed ubuntu 8.1 on my Pentium 4 computer. The installation process went smooth. I started the computer and Iam getting the login screen. However, after I type the username and the password, the screen go blank. I am able to move the mouse courser, however, nothing else appear on the scree.
I tried to reinstall the ubuntu again, but the same problem happened.
Comment
Watch Question

cjl7freelance for hire

Commented:
sounds like the old graphics problem...

Try logging in with Gnome failsafe. If that works it's the graphics driver or rather the auto-probe resolution that isn't working.

Commented:
Hello,

Try going into runlevel 3 and from run level 3 issued the following command

startx

This should show you any errors. Check the ~/.xsession-errors

Author

Commented:
cjl7,   I tried to login using Gnome failsafe but it didn't work.

xDamox,    I am quite new to Unix and I don't really understand what do you mean by run level 3, could you elaborate more?

Commented:
Hello misharyth,

What boot loader are you using? GRUB or LILO?

I think you will be using GRUB so have a read of

http://www.brunolinux.com/05-Configuring_Your_System/Grub_boot_runlevel-3.html
While moving your mouse in circles on the screen (joking, you don't have to do this), press CTRL+ALT+F1 and you'll be dropped in a prompt. Login and when it gives you back the cursor, type startx to see what happened.
Can you tell me your graphic card?
Oh, to go back to your dull graphics, hit CTRL+ALT+F7

Author

Commented:
I tried the startX and gave me two error:
Fetal Server Error: Server is already active for display 0

error in locking authority fuke /home.mishary/.Xauthority
Actually I was expecting it, but I hoped to get some other messages before it died... ok, run "top" command, find the pid of the X server (it should be Xorg) and ruthlessly kill it. Then, run again startx and see what tells you.
Which graphic card do you have?

Author

Commented:
ai_ja_nai,
I am quite new to Unix, so I really approciate if you could explain the steps in more details.

I am using IBM computer with Built-in Graphic Card

Author

Commented:
I forget to mention that my computer is "IBM NetVista Pentium 4 2.66GHz"
ok, step by step plus Linux lesson:


-press ctrl+alt+f1 and you'll be jumped in a dos like environment; we call it console, terminal, tty (=terminal teletype), shell or bash (an acronim for Bourne Again SHell, the most common shell around, engineered by Stephen Bourne).

-Enter your login credentials and run the command "top"; it's a program to show active processes, mem and cpu usage and lots of other things that now are not interesting.
Look at the list of active processes. Each one has a name (rightmost column) and a PID, a process ID (leftmost column). You should look for a row with name X (or Xorg). No, you can't scroll the list if the process is over the bottom of the screen, but you can rearrange the order criterium of the processes with < and >. You start with the most CPU consuming. 3 '< 'key strokes and you will go for most RAM consuming. Now you should see it, the X process.

-take not of its PID. Press K button and enter the kill mode, the mode ou use to terminate programs. enter the corresponding PID number, press '9' to select the signal n° 9 (the less gentle) and hit ENTER to terminate X.

-you can quit top anytime by pressing 'q'.

-now, we'll have a look at you graphic server configuration file, to investigate your problem. It contains all the parameters for keboard, mouse and graphic card in the point-and-click environment you are used to.
Note that you are not forced to use it, if you want; you are already using Linux in full power mode when typing on command line. The graphic environment is not tied to the system like Windows.

-type 'less /etc/X11/xorg.conf', scroll down the configuration file it appears and look for the Device section. Take note of the Indentifier string and the Driver string. Press 'q' to escape from the file viewer and issue 'startx' to start again the X graphic server. Take note of possible error messages.

Post here whenever you can the strings you saw before in the xorg file, they'll let me identify the type of graphic card you own.

Author

Commented:
Thank you ai_ja_nai for you detail explination.
The only thing that I see in the file under "Devices" section in the xorg.conf' is"
Identifier      "Configured Video Device"
and under that is an empty line!!.

When I enter startX, the same error happended again. That is:
Fetal Server Error: Server is already active for display 0

error in locking authority fuke /home.mishary/.Xauthority


it means that your X server was still running... did you really kill it? Did you see it disappear from the list of running processes?

xorg.conf provided poor info (it could be great if you could post it here). Can you tell me the brand of your graphic card?

>Fetal Server Error:

What is a fetal server error? A computer abortion? xD
Hi,

Check this post, it solved the same problem for me.

http://benaiah41.wordpress.com/2008/11/01/ubuntu-810-freezes-after-login-screen/

BR,
Oliver

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks oliver_shikaloski,
Immediatelly resolved problem.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.