• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 335
  • Last Modified:

How do I set up or know the URL for my FTP site I've just set up. It does not seem apparent to me

Hi,
I have run through all the "apparent" FTP Setup procedures on my SBS.  I have opened port 21 on my router.  Where do I define what address, user name and passwork ouside users use to accees the site?
0
skipbowt
Asked:
skipbowt
  • 5
  • 4
  • 2
1 Solution
 
acromentCommented:
I beleve that the "address" would be the same address that you use for your server when accessing other server items from the internet. eg. https://server.domain.com/exchange goes to exchange. ftp://server.domain.com should go to FTP.

The usernames (I beleive) could be username@domain.com or maybe username@domain.local and their domain password.

Try that - and if you continue to have problems, I can test the setup on my dummy SBS server and provide more detail.

-Eric
0
 
ccpjcCommented:
you need to know the outside IP address for the server
and the user would access with ftp://xxx.xxx.xxx.xxx
they can either enter a username and password or put it in like this
ftp://username:password@xxx.xxx.xxx.xxx

where of course xxx will be replaced with the IP
0
 
skipbowtAuthor Commented:
Thanks for the reply
I access our server from the outside via: remote.domain.com/remote (remote web workplace)
This does not bring up connection to ftp.

In ISS Manager, FTP site tab the IP address aptions are: (all unassigned), 169.254.143.60) or 192.168.16.2

I tried both solutions.  still cant access ftp.  Will it work from inside or should I tyr it from the outside?

0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
ccpjcCommented:
169 is an error IP address

go onto the machine where the FTP server is located, open up IE and goto  www.ipchicken.com that will show you your IP address

then try ftp://ip address
0
 
skipbowtAuthor Commented:
ipchicken displayed the ip of my server
This solutions however failed to provide the desired results.
Any other ideas?

Many Thanks
0
 
acromentCommented:
the address you use from inside your network will be different than from outside.

From outside you would use your public IP adddress.

From the inside, you would use your private IP address ftp://<your server name> or ftp://192.168.16.2

Also when accessing your server from the outside, the address remote.domain.com/remote  would be for remote web workspace... for ftp, you would need to use ftp://remote.domain.com (note that you are not specificing a path to access it.

0
 
skipbowtAuthor Commented:
I tried the IP address provided by ip chicken which I'm assuming is my outside ip from an outside office it did not work.
so, for example if our domain was "spoof.net
I would use ftp://remote.spoof.net, correct?
I tried this and it still did not work.
I tried this from an office outside our net work and we just the the standard "The Web page cannot be displayed" message.
What do you mean by (note that your are not specificing a path to access it)?
Sorry I'm not putting in my correct domain name.
Thanks for any further help you can offer
0
 
ccpjcCommented:
when you setup the FTP in IIS, you can't just set it up and be done with it
you need to configure it as well

the problem will being lying in the firewall if you can't access it from outside but can from inside
it also won't be ftp://remote.domain.com it would be ftp://lalala.com


0
 
skipbowtAuthor Commented:
here is the configuration I set up:
FTP Site Tab:
Description: DKSJFTP
IP address: (All Unassigned) ? is this correct
TCP port 21
Connections limited to: 5
Connection timeout 120
Security Accounts Tab
Allow anonymous connetions is checked
User Name xxxx
Password xxxx
Messages Sure this doesnt matter but I set Maximum connections to 5
Home Directory Tab:
A directory located on this computer:  read is checked. write is unchecked, log visits are checked
MS-DOS is selected
Directory Security:
All computers will be granted access is selected
0
 
skipbowtAuthor Commented:
I think I solved the problem by entering the ip address displayed on ipchicken.com into the ip address on the FTP site tab.

Thank you,
0
 
ccpjcCommented:
This is how one of my FTP Servers is setup
FTP SITE
Description: Cheques
IP Address: 10.3.0.106
TCP Port: 21

HOME DIRECTORY
selected - a directory located on this computer
Local Path: C:\Inetpub\ftproot

Now because this is an internal IP only, change your to your external IP
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now