We help IT Professionals succeed at work.

Accepted community name - Domain Controller

Medium Priority
343 Views
Last Modified: 2012-05-06
I am trying to chnage the SNMP community name on my domain controller, but the "accepted community name" under the security tab is grayed out so that you can't make any changes.  

Is there any way to change the community string on a domain controller?
Comment
Watch Question

Technical Director
Commented:
Hi Rog

have alook at:
http://technet.microsoft.com/en-us/library/cc751216.aspx

Chapter 6- scroll down to:
The community name is stored in the Registry as a registry value with a DWORD value of 4, so you could automate this change by creating a script or adding a line to the baseline.inf security template before importing it into the Member Server Baseline Policy. The value is stored in: HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ValidCommunities


hth
capt.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
Make sure you're logged in as an administrator and you don't have a GPO setting applied overriding that setting. Run RSOP.MSC to see which policies are applied to your DC and check the settings under:

computer configuration > windows settings > security settings > system services > snmp service.

This will show you if any policy is applied and name of the policy. You may then be able to make appropriate adjustments.

Author

Commented:
Thanks capt.  I guess I'm just burnt out and didn't even think of the registry.  I need a vacation.

Author

Commented:
Gracias!

Commented:
@ Captainreiss's suggestion - while valid, I'd reserve that option as a last resort due to the fact that if the setting is in fact pushed out via GPO, the value may be overwritten at the next update interval. If no GPOs are controlling the setting, then by all means - but export the key first, as a precaution.

Commented:
Whooosh! That was a quick close. Well, anyway - good luck, hope it works.

cheers.

Author

Commented:
I did check the GPO settings as this was the first thing that popped into my head, but we did not have anything configured there.
captainTechnical Director

Commented:
Have that vacation....

Thanks for accept.

:o)
capt.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.