[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1599
  • Last Modified:

usb drive not in My Computer - Windows Server 2000 - My Passport

Server 2000 SP4
WD My Passport 320G USB 2.0

We formatted the drive to NTFS, plugged it into the server and the drive shows up in Disk Manager with drive letter g:
The drive doe not show up in My Computer
We installed some drivers from a fourth party location becaue the Western Digital site referenced a zip file but did not have it avail. for download. File name was WD_essentials_usb_driver.zip

Once we installed the driver we restarted and the deveice showed up for a few minutes in My Computer as WD Passport and then disapeared.

We have not restarted the server yet but we have removed all USB controller drivers and rescanned for hardware and no change in status.

We have yet to contact  WD, Microsofft or Asus for support but it is on our list. Any of you fine folks have any guidence?


0
mofmaximus
Asked:
mofmaximus
  • 4
  • 3
  • 3
  • +3
1 Solution
 
crphdCommented:
Usually when you plug in a USB drive to a computer and it doesn't show up in My Computer it is because there is another drive using the same letter (IE a mapped drive or CD ROM).  Try heading into disk management and assigning the USB device to another drive letter higher up in the alphabet like X or Y.  Try that and refresh your My Computer and see if it comes back.
0
 
crphdCommented:
You can also check device manager to see if the USB Root Hub is set for "Allow the computer to turn off this device to save power" is checked off.
0
 
crphdCommented:
Sorry ....Brainstorming here.

Did you try plugging in another USB device to see if it recognizes that?  IE keyboard/mouse/another USB Flash Drive?

Check the BIOS to see if USB is turned off
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
theras2000Commented:
Just as some general troubleshooting steps, try plugging this HD into an XP machine, and also try a different HD into your Win2k machine - just to check if everything else seems right.

This may be related to something that happens to me: I have a Creative Zen (little media player like an ipod).  When I plug it in, I don't get a drive letter (not even in device managre).  I installed the Zen software at the start and I assume this intercepts the drive and uses it in it's own way.  I see "My Zen" in My Computer, instead of a drive letter.  So perhaps your WD installed some custom softwre that does something similar.  Perhaps you could try it on another Win2k machine and try not to let it install anything when you first plug it in.
0
 
mofmaximusAuthor Commented:
Couple details in response to the suggestions, and thank you for those.

We have tried 2 each WD MyPassport usb 2.0 drives, both respond the same way.
Drives were originaly preloaded with WD software and FAT32. We used XP to right click on the drive and format quick ntfs. I'm thinking that might be suspect.
We need to check the PowerSave options also.

We thank you for any other ideas and will report back when we can.
0
 
nobusCommented:
did you try other usb ports ?
0
 
lnkevinCommented:
You may have some previous network drive mounted on g: Right click on my computer and click on disconnect a mapped drive to see if there is g: taken by something else. Otherwise, get in disk manager and change the drive letter for this USB to other than g:

K
0
 
mofmaximusAuthor Commented:
Inkevin, your suggestion is one we were going to look into and all of a sudden the drive started showing up in  My Computer but we seem to be getting usb drdevice popups from system tray but i haven't seen them myself, we'll keep an eye on that.

Here are the things we were going to try as well. We will monitor the drive's connectivitiy and test the backup software as well soon. We are using this USB drive and a second for backup, swap, carry out strategy.

Anyway I'm not sure what I'l do with points at this time, I think I'll wait another couple day till we can confirm the issue is resolved completely.

Thank you, here are the possible solution we found and have yet to try .
=======
=======
#1
 
Try re-formating via command line using the server and if that fails try XP. Seems that the way we formatted in XP might be an issue and this would make sure it wasn't.
 
FORMAT [drive letter]:  /FS:NTFS
for drive G:\  type FORMAT G:  /FSNTFS
 
reference http://www.ss64.com/nt/format.html
 
=======
 
#2
 
Another group of people had an XP machine with the same issue, not showing up in Windows Explorer (based on NT and usually formatted in NTFS)The initial question was regarding a drive that diapered after installing SP3 to XP . the drive had been working prior. Others had the similar disappearing drives and USB drive issues and they said going to Network Connections and disable the Firewire connection, worked, if there was one.
 
Disable Firewire 1384 from network connections
 
reference: http://en.kioskea.net/forum/affich-21877-windows-xp-won-t-recognize-wd-ext-hard-drive
 
 
========
 
#3
Interesting Forum question and replies summarized below are from this link  http://www.tek-tips.com/viewthread.cfm?qid=1264167&page=4
 
Cause:
the usb drive will take the first drive letter after the last physical drive, so normally E: (but could be G: maybe?) .  But there are network drives attached to E so the usb drive will not display because it too maps itself to E.
The current fix is to remap all CD Rom drives to Z so that a usb drive being attached will grab D as its letter, but the better solution is to be able to set any usb drive to automatically connect to a particular drive letter
 
If the above makes sense and applies then the possible Solutions are as follows.
 
 
Resolution
I use a utility called USBDLM

http://www.uwe-sieber.de/usbdlm_e.html

it actually allows you to set drive letters based on (various) criteria...  ie any key over 64MB can be assigned to F:.  a drive with the volume name of 'MYDRIVE' can always be B: etc.
 
Note: I could do this setup or help if needed NP and the site has installation instructions on modifying and extracted file, a .ini file, and put in the right commands. It seems about as complex as setting up a config.cfg file for a  CounterStrike server etc.  If the shit above fails there is a #2 that I am not even sure is confirmed to actually work, just a likely work around that could take a couple\few hours at least to learn and do up right. So good luck to us lol.
 
#4
Try putting an autorun.ini file on the USB key to auto-run a script that assigns the letter.  That is the best I can think of, and I asked some co-workers too.
0
 
mofmaximusAuthor Commented:
We have given up on trying to make this work, we are going to install a PCI-USB expansion card and see if our luck changes :)
Keep ya posted
0
 
theras2000Commented:
I just had your same problem with a friend's PC a few days ago.  I kept restartign and trying to set the drive letter, but I only ever saw the drive letter appear once in My Computer, and that was only for 10mins.  I didn't have time to resolve the problem as I was there for another task.

I suspected that it may have been related to another problem that the computer was having.  Any new USB device that I stuck in wouldn't even try to auto-install drivers.  I saw nothing popup.  I had to always go into Device Manager, find the question mark, and install the drivers automatically (because the drivers were already stored in Windows, but just not getting applied to the devices).  This was a brand new Asus laptop setup with an Asus XP Recovery Disk.  Again, I wasn't able to resolve this as I was there for another task and I'm now in a different country.
0
 
mofmaximusAuthor Commented:
We have had the success we hoped for by installing a PCI - USB adapter card. We did have some trouble at first getting the drive to show up but now it is working after a couple reboots etc.

Thank you for your input etc all i'll close this out now
0
 
Brian_MBCommented:
Just to add to the discussion.  I had similiar trouble with a usb drive on Win2000.  Turns out it was simple as far as my issue.  I was accessing the server via rdp.  Plugged the drive in, and then it looked fine in Disk Managment, but had the red x and no drive letter in explorer/My Computer.  All I had to do to fix this was leave the drive connected, log off rdp, then log back on.  Now the drive letter is showing in Explorer/My Computer and is accessible.  One note, and this is probably specific to the drive, under my computer if I double click the new usb drive there is an error titled "Seage-Release.exe - Entry Point Not Found"  with the error message "The procedure entry point GetUserGeoID could not be located in the dynamic link library KERNEL32.dll"  However, if I right click the drive and go to "explore" I can access the file system.  So far I've just tried copying a file to it and it seems to work.  Also if I click the "folders" view and click the drive in the left pane, then there is no error.  I found this solution at http://us.generation-nt.com/answer/win2k-server-usb-hard-drive-mount-no-go-help-69682012.html
 
0
 
Brian_MBCommented:
Hmmm. That might have been a red question mark on the drive, not a red x.
0
 
Brian_MBCommented:
One more thing, I could not eject/stop the usb drive from the rdp session, had to go to the console.  Nothing happened in the RDP when you press stop, just goes back to the device list.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now