Terminal server printing issues.  Multiple print jobs redirected to local printer from test page.

Posted on 2009-02-10
Last Modified: 2013-11-21
This just started happening out of the blue and this setup has worked for years prior to this problem. There have been no changes to the server or printers to cause this problem.

All other printers connected to the print server work fine.  

Server: Window 2003 terminal server
Printer: HP Laserjet 1000 connected to Window XP Pro workstation via USB. I know the HP 1000 is not supported but it has worked for years.

When a print job is redirected to a certain printer on the terminal server some strange behavior results.  Firstly, there is an error in the session on the terminal server.  It says cannot print.  When you look at the local print queue on the workstation, instead of a just one "Remote Desktop Redirected Printer Doc", there several dozen print jobs and they keep piling up.  This was the result of sending a single test page.  When you print anything locally out of the session to the printer.  It prints just fine.  I have reinstalled the same driver on both the terminal server and the local workstation.  

The printer appears when you log into the terminal session as normal.  Everything looks fine until you print.

Any ideas?
Question by:xweberx
    LVL 1

    Expert Comment

    Try stopping the spooler service and going to your Print Spool Folder location.  In my case it was this:  C:\WINDOWS\system32\spool\PRINTERS.   Once you have the spool service stopped go to this folder and delete anything in it.  Once deleted restart the print spooler service and try to print.
    LVL 3

    Accepted Solution

    First take a backup of the spooler using this tool:

    Download this:

    run cleanspl.exe from the console that it installs. Don't say yes to delete TCP print monitor.

    Now try reinstallling the drivers you had on that server. If everything fails use the first tool to restore printer settings.
    LVL 1

    Author Closing Comment

    The spooler backup tool working perfect to eventually troubleshoot the problem. It was a printer driver conflict that was not compatible with a terminal server.  This tool allowed us to isolate the driver and fix the problem- thanks!

    Featured Post

    Too many email signature changes to deal with?

    Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

    Join & Write a Comment

    Consider a situation when you deploy a seemingly harmless software package to your network without testing and therefore without fully knowing the implications of your actions. I was recently involved in just this situation when a corporate IT netwo…
    This is my 3rd article on SCCM in recent weeks, the 1st ( dealing with installat…
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now