We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Cannot Ping Hyper V guest OS NLB IP from public

Medium Priority
1,791 Views
Last Modified: 2012-05-06
Hi Guys...
I'm having some problem with NLB on Server 2008 guest OS in Hyper V.
I have setup 2 Hyper V box, each of them will host Exchange 2007 CAS/Hub Transport.
I managed to bring up my NLB for both guest OS, its able to ping, browse web pages from internal IP/name. but when i triy to access from public internet, it failed. telnet, ping, web access all failed.
I have tested with Single NIC unicast and multicast, followed few suggesstion from few different forums but no help... below is the few links that we refer..

http://www.msexchange.org/articles_tutorials/exchange-server-2007/planning-architecture/load-balancing-exchange-2007-sp1-hub-transport-servers-windows-network-load-balancing-technology-part1.html
http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/dcda9a2c-a0a9-4fb6-86eb-a2e86ea9f745/
http://support.microsoft.com/kb/953828/en-us

Any of you guys encounter before....?
Comment
Watch Question

Double check this: on the host OS (that the Hyper-V is sitting on), go to Network and Sharing Center, then Manage Network Connections, check the properties for the physical nic that you are using for the Hyper-V's virtual network. It should only have "Microsoft Virtual Network Switch Protocol" checked. This could be causing the behaviour you are seeing. That nic port functions like a switch port, not a standard nic port (and cannot work when Client for Microsoft Networks, ip 4, ip6, etc are enabled). Also, check that the virtual network connection (same place: N&SC/manage connections) associated with that phyical nic has no options checked. Only within your virtual machines should Client for Microsoft, ip4, etc be enabled. Hope this helps!
hell_angelTechnical Manager

Author

Commented:
Hi darkjedi213, thanks for your respone, but it is default that the v switch protocol is enabled on Hyper V nic adapter.... :|
You will need to statically add the NLB virtual MAC address to the Hyper-V host or run in multicast mode with a single nic.
Technical Manager
Commented:
Hi GUys.... Manage to solve the issue by add in static arp at router....

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.