[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1032
  • Last Modified:

Outlook 2007 Running Slow when Sorting Folders...

Hello,

We are in a position where the office of just over 200, is looking at upgrading the users to office 2007.

The only problem is we have users with over 40,000 emails within their inbox.

* They filter by Subject, Received, From...etc...
* And outlook hangs saying "Outlook is trying to retrieve data from the Microsoft Exchange server ***.***.***.com"

Is there any way to resolve this problem with Office Outlook 2007??

We have tried:

* Helping users reduce Inbox size by creating rules (which can only get us so far)
* Recreating the outlook profile
* Making the basic user a Power User
* Recreating the users profile
* Also given users higher spec machines Fujitsu Siemens P5720 (2.4GHz - Core 2 Duo) with 4GB RAM (which has helped with general performance of office, but not Outlook 2007)
* Also followed the steps in:

http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_24011926.html

Any advise would be greatly appreciated.

Thanks for reading :)
0
vitolmis
Asked:
vitolmis
  • 2
  • 2
  • 2
  • +3
1 Solution
 
David LeeCommented:
Hi, vitolmis.

Based on the the message you reported, my guess is that the mailboxes aren't in cached mode.  You will see some improvement if you switch to cached mode, but 40,000 messages in a folder is simply too many, especially in an inbox.  Nothing you do is going to make any really significant difference to how fast the messages are filtered or sorted other than reducing the number of items in the inbox.  
0
 
manav08Commented:
Refer to article http://support.microsoft.com/kb/830829.
I would be trying to increase the value of all objects mentioned in the above link for the time period you are doing this migration.
Let me know how you go..
0
 
snowdog01Commented:
My recommendation is that you force them to place about 35000 of the emails in personal folder (on another server other than the Exchange server).  The problem as stated by BlueDevilFan is that there are too many emails in one folder.  More importantly is the amount of disk space that is being used by them.  For example: if all 40K emails where on 10KB in size that would amount to roughly 400MB (close to 1/2GB).  However, most emails are larger than 10KB, so you are probably looking at well over a GIG of disk space being used by one mailbox.  When Outlook loaded, it has to read all of those emails(files) in order to display them in the sorted/filtered list the user has chosen.  Fewer emails, means faster response.  
I also recommend that you implement some form of email retention policy, so that at the other end of the issue, you don't run into a disk storage space issue, with all of the personal folder (PST) files.  One additional word of Caution: Outlook has known issues with PST files when they approach 1GB in size.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
MesthaCommented:
Outlook has performance issues if there are more than about 5000 items in a single folder. If you reduce the number of items in that folder (move them to sub folders) and get it below 5000 then you shouldn't see any issues.

It is due to the way that Outlook handles views.

-M
0
 
manav08Commented:
Hi MEstha,

This is exactly what I said in by comments above.
0
 
vitolmisAuthor Commented:
Thanks for all the possible solutions everyone.

I am currently testing Outlook after recreating the users profile.

I will accept a solution once the tests have proven successful.

Thanks again :)
0
 
vitolmisAuthor Commented:
Sorry meant I recreated the users mail box in Outlook, not the users profile.

Thanks
0
 
jannepmCommented:
I've seen that when you have all these auto-preview and similar features enabled, it takes much longer time; Outlook does not have to deal with message sorting but also loading, formatting etc the message.

Please try without "AutoPreview" feature and see if that helps. Also grouping is one thing, by default Outlook is grouping messages like day "Today", "Yesterday", "Last week", try disabling these features as well.
0
 
David LeeCommented:
Sorry, I have to object.  I believe a point split between myself and Mestha is appropriate.  The only solution is to reduce the number of items in the folder.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now