We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

IMAP service error when connecting to server

total123
total123 asked
on
Medium Priority
1,125 Views
Last Modified: 2012-05-06
I am in the process of setting up IMAP access on a 2003SBS.
I have enabled the IMAP port 143 to point to the server, started the service and started the Default Virtual Server.
When i test it by trying to log in to the server via Telnet i get to input my username and password, but it says "NO the service has not been started",
In the Event Viewer i get event id 1011, stating
"Authentication attempt from 192.168.1.x
user@xxx.com has failed with error 0x426.

I have searched these errors/event id's but found nothing conclusive to help me.
Would appreciate some help.
Comment
Watch Question

Commented:
A few things I would check -

1. Firstly, check using a port scanner if that particular port(143) is open on the server.
2. Now when entering your userid try your userid with the following combinations -
    a) userid@domain.local
    b) domain\userid

If none of the steps above work let me know.

Author

Commented:
i have tried an online port scanner and 143 comes back as open, and pointing to the server.
Both of those username combinations come back with errors.

Commented:
I have to ask 2 more questions -

1. Does the client machine and server both have all the updates installed.
2. Did you try with 2 different users just to take off any possibility of this being isolated to just one account

Author

Commented:
Tried a dummy account that i created especially for testing and my own Admin account.
Server has SP2, and has all the critical/recommended updates.
For testing i was logging in via Telnet on the server itself.
We have also tried another client, Win XP from remote location.

Commented:
do you know how to use WIRESHARK, packet sniffer. Maybe we could shed some more light using that.

Author

Commented:
no, but i have begun downloading it now,

Author

Commented:
going to have to get back toy tomorrow, as cant acces stheir system.

Author

Commented:
ive installed it, what next?

Commented:
Monitor traffic on that network interface using wireshark and give us the errors.

Commented:
Hi Total,

Any luck yet

Author

Commented:
Sorry, i have been caught up on other jobs.
Some odd things though, it seems that whilst i am unable to get this working, some remote users have been able to get it working.
One user has no issues at all, whilst another has intermittent access, some emails come through but others dont.
I am currently in the process of upgrading the firmware on the router. Once this is done i will post the log from Wireshark. Are you okay to hang on?

Commented:
sure

Author

Commented:
Attached is the capture, let me know if you need more info from it.
below is message from Windows Mail, that i am using to test system.

The server rejected your login. Please verify your username and password are correct.
The service has not been started.
Configuration:
Account- IMAP
Server: xxx.xxx.xxx.xxx
Username: test
Protocol: IMAP
Port: 143
Secure(SSL): 0
Code: 800cccd1
capture.txt

Commented:
Hi total123,

A couple more things I would suggest you try - Try the options below with both username and username@domain.local and antivirus software turned off-

1.In AD USers and Computers, Rightclick a user, Exchange Tasks -> Configure Exchange Features and make sure that IMAP is enabled for that user.
2. Try giving the user "Read permissions" and "Full mailbox access". to their mailbox and see if that helps.

Commented:
Also the WIRESHARK logs that you sent me has the following -

Frame 56 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: 192.168.1.254 (00:09:5b:b0:b2:9a), Dst: 2003sbs.empire.local (00:13:72:3e:48:7a)
Internet Protocol, Src: tcaonline.force9.co.uk (81.174.165.23), Dst: 2003sbs.empire.local (192.168.1.67)
Transmission Control Protocol, Src Port: 52341 (52341), Dst Port: imap (143), Seq: 54, Ack: 293, Len: 0

Can you confirm if tcaonline.force9.co.uk (81.174.165.23) is where your IMAP is hosted. The reason is because port 143 is not open on that server.

Also confirming once again that username@domain.local is what you should be using..

Author

Commented:
tcaonline is us, and as we do not use IMAP the port is closed.
I have tested other companies IMAP systems and do not seem to have issues with the fact that our IMAP port is closed.
I will check the info for username/passwords now.

Author

Commented:
I have given the test user Full Mailbox access and Read permissions, and confirmed that IMAP Is enabled with defaults.
When i type "login test@xxx.local *password*" i get the error message- BAD Protocol Error: "Tag not found in command"

This was using the command prompt on the server itself.

Commented:
Can you confirm what you are typing in "Incoming mail server". I want the exact domain name so that I can check whether or not the port for IMAP is open on the server
Commented:
Also on the server in Application event logs, what eventids etc. are you getting when the connection fails

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
Hii mate,

Can you perhaps comment on how you fixed the problem so others can solve it themselves. What was the issue??
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.