Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1034
  • Last Modified:

Undetected external usb hard drive

I've been running a 500GB Western Digital My Book on my desktop, (Dell Precision T3400 running Vista Ultimate), for the last year.  I ran windows update yesterday which installed an update for .net 3.5.  When the machine rebooted the external drive was not being detected by the OS.  I plugged it into another machine and it was detected just fine from there.  I did a system restore back to the point prior to the update and that had no affect so I undud the restore.  I still don't detect the drive.

For testing purposes I plugged a number of different usb devices into this machine to verify the usb drivers were still functioning appropriately which they appear to be working fine.
0
Guntar66
Asked:
Guntar66
  • 2
1 Solution
 
navdhanjalCommented:
I'm sorry if you've already tried this, but can you plug the drive into another USB port on the same machine?

Secondly, go to computer management (right click my computer, and select 'Manage') and then from the left hand menu, select Disk Management. This shows all the disks connected to your system (internal and external). Can you see your drive there? If so, it may have just 'lost' its drive letter assignment. Select the drive from the list on the right, right click in the 'partition' area (just to the right of where it says Disk X Size XXX) and in the menu select "Change Drive Letters and Path", press the Add button, select a drive letter from the drop down menu, and click OK and OK again. Close Computer Management and check My Computer - the drive should now be visible.

Finally - if none of that has helped so far: with the drive not connected, load up Device Manager (Computer management again, and select Device manager on the left hand menu) then and then plug in the drive - does anything appear in the list?
0
 
Guntar66Author Commented:
Unfortunately I have tried all of your suggestions.  To no avail. I also tried plugging in an entirely different drive abnd it works.  I tried the udetectable drive on a different computer and that appeqrs to e  fine,
0
 
navdhanjalCommented:
With the drive plugged in, please try going to device manager, Universal Serial Bus Controllers, find a setting called "USB Mass Storage device" (or something similar) and right click and remove this device.

Then select Universal Serial Bus Controllers in the list, goto Action (menu at the top) and select Scan for hardware changes.
0
 
manav08Commented:
I have seen this on a no. of USB external drives. It might sound strange but usually it points to a problem with the power cable going from the power adaptor to the wall socket.
Maybe try with a new power adaptor set just to be sure.
I imagine you have already tried a different USB cable so take my suggestion and try a different power adaptor.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now