[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco Configuration Issue

Posted on 2009-02-11
17
Medium Priority
?
861 Views
Last Modified: 2012-06-21
Trying to configure an Cisco 877 router using SDM install on pc. When trying to complete the ADSL setup the Unapplied change dialog box keeps popping up. I select appy changes but nothing seems to happen - don't get dialog box showing the commands applied. Try to perform a Save (running config to router) status bar at bottom shows Running config could not be copied to the startup config.  Connected via hyperterminal and ran wri mem - still no joy.
Has anyone come across this before?
0
Comment
Question by:smythsit
  • 9
  • 8
17 Comments
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23611617
if you are familiar with cisco CLI commands ,, i have same your cisco
so, i can post you config.,,but i need 1st your current config.:
just send results for #sh run
!
then send what's your VPI/VCI
!
BR
 
0
 

Author Comment

by:smythsit
ID: 23612232
Here you go

VPI/VCI is 8/35


Building configuration...

Current configuration : 3156 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Tallaght
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2948831778
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2948831778
 revocation-check none
 rsakeypair TP-self-signed-2948831778
!
!
crypto pki certificate chain TP-self-signed-2948831778
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32393438 38333137 3738301E 170D3032 30343139 32323430
  35375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 39343838
  33313737 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CA61 B42DA110 8323B9E2 8556C87B 6CB9AA0F A54F48A7 646E4637 3FBF4639
  8CF2FE8A 4BD20FC9 3123B22D C50819D7 CEFF991B DBFA917C 09543F8C 4E04AFA0
  C4CCB6BE 8039CDA3 A34AB07B 009F3411 6FF3171D 8F9A08D7 2F026A0D A274C28C
  7FE9977D 510A95E2 E626922C 8B9A328C C7236546 7B7AA3B1 F4FD4726 5B3010A8
  EABB0203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 0854616C 6C616768 74301F06 03551D23 04183016 801457AE
  FD804D8C DE14CB1D ADA7A36E C1F3BE1E 6BAC301D 0603551D 0E041604 1457AEFD
  804D8CDE 14CB1DAD A7A36EC1 F3BE1E6B AC300D06 092A8648 86F70D01 01040500
  03818100 8027ABD9 7F85ADA7 1322140C 3C37E78C 20C0A5E5 B59550F3 1AD6E401
  BA539727 42F93EB8 7DEDC949 48AC6A6E 70CB3CCF 0F34204F E3D5B58F 1A7DB179
  A3A7714F BEE927C3 18F44A15 D45B801E 80A41F22 6C8BE9B5 0D6A6F16 65C455FB
  418C0840 DA436AEE A875E9D0 6FAD0EFE ADA1CE46 A443B738 E86CEAA8 6A4C4C92 CD24E473
        quit
dot11 syslog
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.245
!
ip dhcp pool sdm-pool
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.245
   lease 0 2
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username admin privilege *****!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 192.168.10.245 255.255.255.0
 ip access-group 100 in
 ip nat inside
 ip virtual-reassembly
!
interface Dialer0
 no ip address
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
ip http secure-server
ip nat inside source route-map SDM_RMAP_2 interface Dialer0 overload
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 23 permit 192.168.10.0 0.0.0.7
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 100 permit ip 192.168.1.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 100 permit ip any any
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end

0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23619822
hi
!
interface ATM0
 no ip address
 atm vc-per-vp 64
 no atm ilmi-keepalive
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
 description link to LAN
 hold-queue 100 out
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!

!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 192.168.10.245 255.255.255.0
 ip accounting output-packets
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
!
interface Dialer0
 ip address negotiated
 ip access-group 100 in
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer remote-name redback
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username (username) password (password)
 ppp ipcp dns request
 ppp ipcp wins request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 102 interface Dialer1 overload
!
access-list 102 permit ip 192.168.10.0 0.0.0.255 any
access-list 23 permit 192.168.10.0 0.0.0.7
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 100 permit ip 192.168.1.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 100 permit ip any any
!
end
-----------------------
try this config. and send me results
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:smythsit
ID: 23620545
Just tried this From SDM and interfaces, no longer have access to PPoe interface just ppp.  Trying to set up ATMO.1 connection to add username and password.
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23620557
plz post your current run config.
0
 

Author Comment

by:smythsit
ID: 23620573
Current configuration : 3963 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Tallaght
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2948831778
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2948831778
 revocation-check none
 rsakeypair TP-self-signed-2948831778
!
!
crypto pki certificate chain TP-self-signed-2948831778
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32393438 38333137 3738301E 170D3032 30343139 32323430
  35375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 39343838
  33313737 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CA61 B42DA110 8323B9E2 8556C87B 6CB9AA0F A54F48A7 646E4637 3FBF4639
  8CF2FE8A 4BD20FC9 3123B22D C50819D7 CEFF991B DBFA917C 09543F8C 4E04AFA0
  C4CCB6BE 8039CDA3 A34AB07B 009F3411 6FF3171D 8F9A08D7 2F026A0D A274C28C
  7FE9977D 510A95E2 E626922C 8B9A328C C7236546 7B7AA3B1 F4FD4726 5B3010A8
  EABB0203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 0854616C 6C616768 74301F06 03551D23 04183016 801457AE
  FD804D8C DE14CB1D ADA7A36E C1F3BE1E 6BAC301D 0603551D 0E041604 1457AEFD
  804D8CDE 14CB1DAD A7A36EC1 F3BE1E6B AC300D06 092A8648 86F70D01 01040500
  03818100 8027ABD9 7F85ADA7 1322140C 3C37E78C 20C0A5E5 B59550F3 1AD6E401
  BA539727 42F93EB8 7DEDC949 48AC6A6E 70CB3CCF 0F34204F E3D5B58F 1A7DB179
  A3A7714F BEE927C3 18F44A15 D45B801E 80A41F22 6C8BE9B5 0D6A6F16 65C455FB
  418C0840 DA436AEE A875E9D0 6FAD0EFE ADA1CE46 A443B738 E86CEAA8 6A4C4C92 CD24E473
        quit
dot11 syslog
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.245
!
ip dhcp pool sdm-pool
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.245
   lease 0 2
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username admin privilege *****!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 atm vc-per-vp 64
 no atm ilmi-keepalive
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
 description link to LAN
 hold-queue 100 out
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 192.168.10.245 255.255.255.0
 ip access-group 100 in
 ip accounting output-packets
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Dialer0
 ip address negotiated
 ip access-group 100 in
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer remote-name redback
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username (username) password 0 (password)
 ppp ipcp dns request
 ppp ipcp wins request
!
interface Dialer1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source route-map SDM_RMAP_2 interface Dialer0 overload
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 23 permit 192.168.10.0 0.0.0.7
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 100 permit ip 192.168.1.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 100 permit ip any any
access-list 102 permit ip 192.168.10.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23620597
ok
your router model 877W,,right?
---
you need to remove this:
ip nat inside source route-map SDM_RMAP_2 interface Dialer0 overload
 by
no ip nat inside source route-map SDM_RMAP_2 interface Dialer0 overload

!
plus what are your ISP setting,,PPPoe, or PPPoA,,??
plz post results for this :
#sh dsl int atm 0
and
#sh ip int bri
 
 
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23620691
also change this one
ip nat inside source list 102 interface Dialer1 overload
to
ip nat inside source list 102 interface Dialer0 overload
0
 

Author Comment

by:smythsit
ID: 23620722
ISP setting is PPPoe

#sh dsl int atm 0 ATM0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x2
Vendor ID:       'STMI'                          'BDCM'
Vendor Specific: 0x0000                          0x6193
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   67%                             66%
Noise Margin:    12.0 dB                         12.0 dB
Output Power:    14.0 dBm                        -1.5 dBm
Attenuation:     16.0 dB                          4.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0xB2
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      12385 (0 spurious)
PHY Access Err:  0
Activations:     3
LED Status:      ON
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          7616                0           672                 0
Cells:                 2042                0       3107088                 0
 EC:          0            0            42                 0
CRC Errors:               0                0             1                 0

Header Errors:            0                0             0                 0
Total BER:                0E-0           0E-0
Leakage Average BER:      0E-0           0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 0 3 5 6 9 A 9 9 9 9
010: A A A A A 9 9 9 9 9 9 9 9 7 6 5
020: 0 0 0 0 0 C C D C D D D D D D D
030: D D D D D D D D D D D D E D D C
040: 0 E E E E E E E E E E E E E E E
080: C D D C C C C C C C C C C C C C
090: C C C C C C C D C C C C C C C C
0A0: C C C C C C C C C B B B C C C C
0B0: C B B B C B B B B B B B B B B B
0C0: B 0 B B B B B B 0 0 B B B B B B
0D0: B B B B B 0 B 0 0 0 0 0 0 0 0 0
0E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled



#sh ip int bri
Interface                  IP-Address      OK? Method Status                Prot
ocol
FastEthernet0              unassigned      YES unset  up                    down

FastEthernet1              unassigned      YES unset  up                    up

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

ATM0                       unassigned      YES TFTP   up                    up

Vlan1                      192.168.10.245  YES manual up                    up

NVI0                       192.168.10.245  YES unset  up                    up

Dialer0                    unassigned      YES TFTP   up                    up

Dialer1                    unassigned      YES unset  up                    up

Virtual-Access1            unassigned      YES unset  down                  down


0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23620756
ok
all are ok
just add the following:
!
interface Virtual-Template1
 ip unnumbered Dialer1
 ip nat inside
 ip virtual-reassembly
 peer default ip address pool vpnclient
 ppp encrypt mppe 128
 ppp authentication pap
 ppp ipcp mask 255.255.255.0
 ppp ipcp address accept
!

also change this one
ip nat inside source list 102 interface Dialer1 overload
to
ip nat inside source list 102 interface Dialer0 overload
!
then am sure it will work 100% ok
send me results again for ur config. and sh ip int bri
 
0
 

Author Comment

by:smythsit
ID: 23620903
Still not seeing PPPoe in interface setup just ppp

#sh ip int bri
Interface                  IP-Address      OK? Method Status                Prot
ocol
FastEthernet0              unassigned      YES unset  up                    down

FastEthernet1              unassigned      YES unset  up                    up

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

ATM0                       unassigned      YES TFTP   up                    up

Vlan1                      192.168.10.245  YES manual up                    up

NVI0                       192.168.10.245  YES unset  up                    up

Dialer0                    unassigned      YES TFTP   up                    up

Dialer1                    unassigned      YES unset  up                    up

Virtual-Access1            unassigned      YES unset  down                  down

Virtual-Template1          unassigned      NO  TFTP   down                  down

Virtual-Access2            unassigned      YES unset  down                  down






0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23621031
what do you mean by ppp ??
this is mine:::

#sh ip int brief
Interface                       IP-Address        OK?         Method                 Status                      Protoc
ol
FastEthernet0             unassigned       YES         unset                      up                              up
FastEthernet1             unassigned       YES        unset                       up                           down
FastEthernet2              unassigned       YES       unset                       up                          down
FastEthernet3              unassigned       YES       unset                       up                          down  
ATM0                              unassigned       YES       NVRAM                  up                             up
Vlan1                              192.168.1.1       YES      NVRAM                   up                             up
Virtual-Template1        x.x.x.x                   YES      TFTP                       down                      down
Dialer1                           x.x.x.x                  YES       IPCP                          up                             up
NVI0                              unassigned         YES     unset                         up                             up  
Vlan11                              unassigned      YES     NVRAM                     up                          down
Virtual-Access1            unassigned      YES     unset                          down                      down
Virtual-Access2            unassigned      YES      unset                            up                         up
---------------------------
still you didnt remove this
ip nat inside source route-map SDM_RMAP_2 interface Dialer0 overload
>>>>
plus chekc with your ISP to give you exactly why your not not connecting,,
may it's Authentication problem,,what's their Authentication type???
try and reply
0
 

Author Comment

by:smythsit
ID: 23621335
I am not great with using cisco CLI commands so I am using SDM to configure the interface so I go to Interface and Connections and Configure new connection Wizard.  There are usually 3 options Ethernet LAN, ADSL (PPPoe....) and Aux Backup (PPP).  Since I applied your first config changes I no longer have ADSL in the list.  I never get as far as Authentication with my ISP because I am unable to complete the configuration of the ADSL setup wizard becuase the Unapplied Changes window kept popping up. So really this is more a question to someone who uses SDM to configure the interfaces more that CLI.
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23621578
hi
since the following interfaces appear as dialer0 up ,, and Virtual-Access1 down
that means your DSL connection is up and results from #sh dsl int atm0 ,,confirm this
but still you didnt get the PPP link ,,and this is may due authentication problem or something else
you need to check with your ISP to give you the exact logs..
 
Dialer0                    unassigned      YES TFTP   up                    up

Virtual-Access1            unassigned      YES unset  down                  down
 
P.S,,configuration i sent you and your current config. are 100% right,,
just check with your ISP before any extra loosing of time .......
 
0
 

Author Comment

by:smythsit
ID: 23623348
Not so sure.  My DSL connection may be up in that the phone line is active but How can I check with my ISP if I have never sent them a username and password for authentication.  I am trying to put in the username and password but SDM frontend keeps prompting that Unapplied Changes need to be applied.  I select apply but it pops up again when I try to change to another screen to edit/view the interface settings.  I did try to manually configure the interface by copying the CLI commands from another router and changing the username and password but then I experienced vci/vpi issues so reset to factory default and started all over again.
0
 

Accepted Solution

by:
smythsit earned 0 total points
ID: 23671270
Thanks all the same I just replaced the router and all is working ok now.  
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 23672587
hi smythsit:
am wondering why you closed this question without earning points,,
as you know earning points one of the important issues for this forum,,
and i spent with you to handle your issue all the time,,
all my solution were right except the problem was from your router ,,
have  good time
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question