[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

ASA to Router IPsec site to site VPN, only works one way.

Posted on 2009-02-11
8
Medium Priority
?
3,708 Views
1 Endorsement
Last Modified: 2012-05-06
Hello,

I have setup a VPN site to site link between and asa 5520 and a cisco 850w,

If I ping the a ip at the remote site the link comes  up and it all works, I can ping from the remote site also.

However with the link down if you ping an address on the asa site the link doesnt come up. and I get this error:

5|Feb 11 2009|14:05:40|713904|||||IP = 62.189.127.100, Received encrypted packet with no matching SA, dropping
4|Feb 11 2009|14:05:40|113019|||||Group = 62.189.127.100, Username = 62.189.127.100, IP = 62.189.127.100, Session disconnected. Session Type: IKE, Duration: 0h:00m:00s, Bytes xmt: 0, Bytes rcv: 0, Reason: Phase 2 Mismatch
3|Feb 11 2009|14:05:40|713902|||||Group = 62.189.127.100, IP = 62.189.127.100, Removing peer from correlator table failed, no match!
3|Feb 11 2009|14:05:40|713902|||||Group = 62.189.127.100, IP = 62.189.127.100, QM FSM error (P2 struct &0xcc190a48, mess id 0xf42c2f72)!
5|Feb 11 2009|14:05:40|713904|||||Group = 62.189.127.100, IP = 62.189.127.100, All IPSec SA proposals found unacceptable!
5|Feb 11 2009|14:05:40|713119|||||Group = 62.189.127.100, IP = 62.189.127.100, PHASE 1 COMPLETED
4|Feb 11 2009|14:05:40|713903|||||Group = 62.189.127.100, IP = 62.189.127.100, Freeing previously allocated memory for authorization-dn-attributes


I have looked up the error All IPSec SA proposals found unacceptable! which mean the transform sets dont match, but they do, and it works one way, what have I missed?

Thanks



 
1
Comment
Question by:LMS-PSG
  • 4
  • 3
8 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 23611565
A phase 2 mismatch is not only the transform set, but can also indicate issues with the IP addresses used for IPsec tunnel termination and the scope of protected traffic in the crypto lists.  

The cryptos and nonats must match exactly and is an easy thing to overlook.  

0
 

Author Comment

by:LMS-PSG
ID: 23612017
So which side is wrong, the ASA?, I am finding it difficult to spot.
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 23612054
I'll give it a look if you'd like to post your configs.... just take out any personal details.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:LMS-PSG
ID: 23612397
Here are the configs, I cut down the ASA config to the relevent VPN parts because its huge and would take an age to cut out stuff.
ASA config-
 
access-list inside_nat0_outbound extended permit ip 10.221.20.0 255.255.255.0 10.221.20.0 255.255.255.0 
 
access-list outside_cryptomap_1 extended permit ip any 10.221.20.0 255.255.255.0 
 
 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set sharks esp-des esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto ipsec df-bit clear-df outside
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_cryptomap_1
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 62.189.127.100 
crypto map outside_map 1 set transform-set ESP-3DES-SHA ESP-DES-MD5 sharks
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map Site2site 21 set security-association lifetime seconds 28800
crypto map Site2site 21 set security-association lifetime kilobytes 4608000
crypto isakmp identity address 
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
 
 
tunnel-group 62.189.127.100 type ipsec-l2l
tunnel-group 62.189.127.100 general-attributes
 default-group-policy Site2Site
tunnel-group 62.189.127.100 ipsec-attributes
 pre-shared-key *
 
 
 
Router Config:
 
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco851w
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
enable secret 5 $1$94io$9uij0WUrjJ/DV8webO802.
!
no aaa new-model
!
!
dot11 syslog
!
!
ip cef
no ip domain lookup
!
!
!
 
! 
!
crypto isakmp policy 11
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key psgsite2site address 193.129.1.157
!
!
crypto ipsec transform-set sharks esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
!
crypto map nolan 11 ipsec-isakmp 
 set peer 193.129.1.157
 set transform-set ESP-3DES-SHA 
 match address 120
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address 62.189.127.100 255.255.255.224
 ip nat outside
 ip virtual-reassembly
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
 crypto map nolan
!
interface Dot11Radio0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 ip address 10.221.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 193.129.1.157
ip route 193.129.1.157 255.255.255.255 62.189.127.98
!
ip http server
no ip http secure-server
ip nat pool branch 62.189.127.100 62.189.127.100 netmask 255.255.255.0
ip nat inside source route-map nonat pool branch overload
!
access-list 120 permit ip 10.221.20.0 0.0.0.255 any
access-list 130 deny   ip 10.221.20.0 0.0.0.255 any
route-map nonat permit 10
 match ip address 130

Open in new window

0
 
LVL 33

Expert Comment

by:MikeKane
ID: 23612508
This can't be correct:
access-list inside_nat0_outbound extended permit ip 10.221.20.0 255.255.255.0 10.221.20.0 255.255.255.0

The source and dest are the same subnet so the nonat would not catch anything.  
0
 

Author Comment

by:LMS-PSG
ID: 23612715
Thats only because I was messing with it trying to get it to work, it was set to any to 10.221.20.0, it still works with that though
0
 
LVL 9

Accepted Solution

by:
Donboo earned 2000 total points
ID: 23616142
On the router under crypto map nolan 11 ipsec-isakmp
type "set pfs group2"
0
 

Author Closing Comment

by:LMS-PSG
ID: 31545552
I think thats done it, good eyes!
0

Featured Post

Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month20 days, 7 hours left to enroll

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question