We help IT Professionals succeed at work.

AIX ftp of files larger than 2Gb

knel1234
knel1234 asked
on
Medium Priority
4,020 Views
Last Modified: 2013-11-17
Hi,

I am attempting to ftp (or copy) files (tar files but shouldnt matter) that are larger than 2Gb.
I can do this via ftp or via a "remote mount" from machine A to machine B.  

I made some attempts by adjusting the values in /etc/security/limits

However, these attempts and the adjustments have not been successful

Any thoughts, suggestions, etc would be appreciated.

Thanks
knel
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2013

Commented:
Hi,
as a first step, looking at /etc/security limits is OK.
You must adjust the limits at the 'target' machine (the one you want to copy the files to).
Take care to modify both 'fsize' and 'fsize_hard' (value is in 512-byte blocks) and to logout/login for this to take effect.
If you made the changes for 'root', all involved processes must be recycled, e.g. sshd, or perhaps ftpd if not run via inetd.
wmp
Top Expert 2015
Commented:
I have had success with proftpd from http://www-03.ibm.com/systems/power/software/aix/linux/toolbox/alpha.html
You can try sftp or scp - kind of world moves encryption way.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Top Expert 2015

Commented:
This problem is present with most GNU tools using ./configure since until now they are unable to get using 64bit file functions in AIX
CERTIFIED EXPERT
Commented:
You can remove the max file size limit of 2GB completely by editing /etc/security/limits. In the 'default' stanza change the value of fsize to -1. This sets the max file size to unlimited. You could also change this to some other value, less than 2GB, if you want.

default:
fsize = 2097151

Changing this to

default:
fsize = -1

This is fine however large-file enabled filesystems have poorer performance if they contain lots of small files so don't create them unless you need them.
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2013
Commented:
Need to change fsize_hard, too!
Top Expert 2015

Commented:
fsize_hard -1 ...

Author

Commented:
Thanks for all the input...
 
the actual isse was jfs vs jfs2.
I was filling in for someone and for whatever reason they had the target file system set to jsf(cant hold larger than 2Gb).  I changed the place that I copied to which was on a jfs2 (can hold greater than 2Gb)
 
knel
Top Expert 2015

Commented:
jfs1 has attribute that allows holding files >2GB
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2013

Commented:
Yes, that's the bf=true attribute
It's been a long time since I saw the last jfs1, and even a much longer time since I saw the last jfs1 without bf=true (must have been some AIX 4.x filesystem in rootvg)

Glad you found the solution!

Cheers

wmp


Top Expert 2015

Commented:
This is a problem and solution - it forces you to create separate filesystem for /var/ftp with large files support.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.