Install a downloaded rpm with newer version than the one yum finds

i'm running RHEL5.

if yum finds no updates to a certain package (namely ImageMagick), but a newer rpm is available directly from the ImageMagick site, is it safe to install the rpm?

if yes, how do i do that?
thomers1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fosiul01Commented:
if you download the stable verstion, its should be safe

redhat people might to update their yum site to get new update for that software .

download the rpm from that site
suuport its magic.rpm

you need to install like this

rpm- ivh rpmfilename

or you can upgrade from old to new

rpm - uvh rpmname

0
thomers1Author Commented:
thanks, trying to install ImageMagick-6.4.9-2.x86_64.rpm from http://www.imagemagick.org/download/linux/fedora/x86_64/ImageMagick-6.4.9-2.x86_64.rpm

got this error:

error: Failed dependencies:
    libHalf.so.6()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libIex.so.6()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libIlmImf.so.6()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libIlmThread.so.6()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libImath.so.6()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libcdt.so.4()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libgraph.so.4()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libgvc.so.4()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libjasper.so.1()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    libltdl.so.7()(64bit) is needed by ImageMagick-6.4.9-2.x86_64
    librsvg-2.so.2()(64bit) is needed by ImageMagick-6.4.9-2.x86_64


note:
yum list|grep Magick
HEImageMagick64.x86_64                   6.4.2.4-1.rhel5        installed      
HEImageMagick64-lib.x86_64               6.4.2.4-1.rhel5        installed      
HEImageMagick64-c++.x86_64               6.4.2.4-1.rhel5        HE-main        
HEImageMagick64-c++-devel.x86_64         6.4.2.4-1.rhel5        HE-main        
HEImageMagick64-devel.x86_64             6.4.2.4-1.rhel5        HE-main        
HEImageMagick64-perl.x86_64              6.4.2.4-1.rhel5        HE-main        
ImageMagick.i386                         6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick.x86_64                       6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-c++.i386                     6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-c++.x86_64                   6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-c++-devel.i386               6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-c++-devel.x86_64             6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-devel.i386                   6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-devel.x86_64                 6.2.8.0-4.el5_1.1      rhel-x86_64-serv
ImageMagick-perl.x86_64                  6.2.8.0-4.el5_1.1      rhel-x86_64-serv


so, the HE ones are installed, so i'm wondering why the dependencies are not met.


0
fosiul01Commented:
no its asking for bellow files

  libHalf.so.6()(64bit)
   libIex.so.6()(64bit)
   libIlmImf.so.6()(64bit)
   libIlmThread.so.6()(64bit)
   libImath.so.6()(64bit)
   libcdt.so.4()(64bit)
   libgraph.so.4()(64bit)
   libgvc.so.4()(64bit)
   libjasper.so.1()(64bit)
   libltdl.so.7()(64bit)
   librsvg-2.so.2()(64bit)

you will have to make sure that those are available in your system  or up to date


0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

thomers1Author Commented:
yeah i know, but how do i check which library/module these files contains?
0
fosiul01Commented:
do

locate  libHalf.so.6

it should show you if you have this file
if it exists it might need up date aswel...

hate this install from rpm!!!!
0
thomers1Author Commented:
hmm i tried installing from source.

after ./configure, i saw that most options with default set to "yes" were set to "false", especially PNG (which we need).

any ideas?


ImageMagick is configured as follows. Please verify that this configuration
matches your expectations.

Host system type: x86_64-unknown-linux-gnu
Build system type: x86_64-unknown-linux-gnu

                  Option                        Value
-------------------------------------------------------------------------------
Shared libraries  --enable-shared=yes        yes
Static libraries  --enable-static=yes        yes
Module support    --with-modules=yes        yes
GNU ld            --with-gnu-ld=yes        yes
Quantum depth     --with-quantum-depth=16    16
High Dynamic Range Imagery
                  --enable-hdri=no        no

Delegate Configuration:
BZLIB             --with-bzlib=yes        no
Autotrace         --with-autotrace=no        no
DJVU              --with-djvu=yes        no
DPS               --with-dps=yes        no
FlashPIX          --with-fpx=yes            no
FontConfig        --with-fontconfig=no        no
FreeType          --with-freetype=yes        no
GhostPCL          None                pcl6 (unknown)
GhostXPS          None                gxps (unknown)
Ghostscript       None                gs (8.15.2)
result_ghostscript_font_dir='none'
Ghostscript fonts --with-gs-font-dir=default    
Ghostscript lib   --with-gslib=yes        no (failed tests)
Graphviz          --with-gvc=yes        no
JBIG              --with-jbig=yes        no
JPEG v1           --with-jpeg=yes        no
JPEG-2000         --with-jp2=yes        no
LCMS              --with-lcms=yes        no
LQR               --with-lqr=yes        no
Magick++          --with-magick-plus-plus=yes    yes
OpenEXR           --with-openexr=yes        no
PERL              --with-perl=yes        /usr/bin/perl
PNG               --with-png=yes        no
RSVG              --with-rsvg=no        no
TIFF              --with-tiff=yes        no
Windows fonts     --with-windows-font-dir=    
WMF               --with-wmf=yes        no
X11               --with-x=            no
XML               --with-xml=no        no
ZLIB              --with-zlib=yes        no

0
fosiul01Commented:
HI sorry

i dont have any idea about this software.

but have a  look to this one if this help

http://www.imagemagick.org/discourse-server/viewtopic.php?f=2&t=10325
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thomers1Author Commented:
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.