swinstall

I'm having trouble installing HP CIM Extension agent on an HP-UX 11.11. I'm a novice at this so please bear with me.
I went to HP web site and found the agent installation depot, copied the file to a directory on the HP-UX.  Then I run # swinstall -s APPQcime.depot APPQcime in the directory where I copied the depot.  I received an error message "sh: swinstall: not found".
shong1997Asked:
Who is Participating?
 
Michael WorshamConnect With a Mentor Infrastructure / Solutions ArchitectCommented:
swinstall needs to be run as either 'sudo' or root.
0
 
Michael WorshamInfrastructure / Solutions ArchitectCommented:
Try doing 'where swinstall' to see if the swinstall is found in your $PATH environment.

SWinstall is usually found under /usr/sbin/swinstall
0
 
shong1997Author Commented:
I have gone a lot further this time, but still received an error when executing the swinstall.  

$ ./swinstall -s /tmp/se/AppQcime.depot APPQcime
WARNING: Could not create the session directory
         "/home/kz4mcd/.sw/sessions/":  Permission denied (13).  This
         directory is where a session's selections are stored.
WARNING: Could not create the session directory
         "/home/kz4mcd/.sw/targets/":  Permission denied (13).  This
         directory is where a session's selections are stored.
WARNING: Could not create the session directory
         "/home/kz4mcd/.sw/software/":  Permission denied (13).  This
         directory is where a session's selections are stored.

=======  02/11/09 11:06:50 EST  BEGIN swinstall SESSION
         (non-interactive)

       * Session started for user "kz4mcd@fledns02".

       * Beginning Selection
ERROR:   "fledns02:/":  You do not have the required permissions to
         select this target.  Check permissions using the "swacl"
         command or see your system administrator for assistance.  Or,
         to manage applications designed and packaged for nonprivileged
         mode, see the "run_as_superuser" option in the "sd" man page.
       * Target connection failed for "fledns02:/".
ERROR:   More information may be found in the daemon logfile on this
         target (default location is
         fledns02:/var/adm/sw/swagentd.log).
       * Selection had errors.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.