We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Connect DID to analog phone through VG224

Medium Priority
3,879 Views
Last Modified: 2012-05-06
Hello,

We currently have 100 DIDs from our service provider.  Most of these are used as direct lines for our users, and are forwarded to directory numbers through our callmanager.  I would like to use some of these as analog fax lines if possible.  I have added the translation patterns in the callmanager to convert the DID to a directory number.  I then have the directory number attached to a fxs port (2/4) through our vg224 gateway.  The vg224 is connected to a punchdown block with a 25 pair cable.  I punched wires down from the block into a phone jack, and then connected a phone.  Now, when I try to call the number, I get a fast busy signal.  When I pick up the phone connected to the block, I get no dial tone, but it does show a call time when I do a sh voice call on the vg224.  The strange this is that it shows the call on two ports (2/4 and 2/5).  Any ideas?

Any help will be much appreciated.

Thanks.
Comment
Watch Question

Les MooreSr. Systems Engineer
CERTIFIED EXPERT
Top Expert 2008

Commented:
Are you sure you punched down the wires on the right pair on the 66 block? Sounds like you have one wire on each pair.
Make sure the directory number is assigned a css.

Author

Commented:
I tried rewiring it several times, and although I repeated the same thing, it seems to be working on a single line now.  I still don't get a dial tone though, and I still get a fast busy whenever I dial the phone number.  The directory number does have a css.
Les MooreSr. Systems Engineer
CERTIFIED EXPERT
Top Expert 2008

Commented:
Is the VG224 registered to the CM?

Author

Commented:
I'm very new to Cisco Voip, so please excuse me if I sound stupid here.  When I go to gateways in the callmanager, the vg224 is listed there, and I can change port settings from there, so I'm assuming yes it is registered.  Is there something else I need to check to make sure it is?
Les MooreSr. Systems Engineer
CERTIFIED EXPERT
Top Expert 2008

Commented:
What version of Call Manager?
If you drill down into a port is there a line assigned to the port and is that line in a partition, and does it show as Registered with call manager <ip address of CM> ?

Author

Commented:
Version is 5.1.2.3000.
When I click on the port I'm trying to test, Line 1 is there, and it is the directory number I want, but the Registration and IP Address are both Unknown.  I assume that means this port isn't registered with the callmanager then.  How would I go about registering it?
Sr. Systems Engineer
CERTIFIED EXPERT
Top Expert 2008
Commented:
Really depends on how the VG224 is configured. MGCP gateway, h.323 gateway? STCAPP sccp ports?
This document might help.
http://www.cisco.com/en/US/docs/routers/access/vg224/software/configuration/guide/scgappa.html

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
It's configured using MGCP with mgcpapp ports.  Looking at how it was originally set up, everything is basic.  I see the ccm-manager configuration is present.  Here is the mgcp config with one of the ports:
!
mgcp
mgcp call-agent CCM 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!        
mgcp profile default
!        
!        
!        
dial-peer voice 99920 pots
 service mgcpapp
 port 2/0
!        

Is there anything here that you can see is wrong?

Author

Commented:
Ok, you pointed me in the right direction.  Everything is working now.  Thanks
Les MooreSr. Systems Engineer
CERTIFIED EXPERT
Top Expert 2008

Commented:
What did you do to fix it?
Thanks!

Author

Commented:
Seems kind of silly now actually.  I added the line: ip host <name of ccm> x.x.x.x.  After that, the gateway showed as registered in the callmanager and any call I made to the DID made the attached phone ring.  Thanks again for your help.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.