We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

How do I prepend an area code into a digitmap on a Polycom 501 phone?

Medium Priority
1,337 Views
Last Modified: 2012-05-06
I am using Vocalocity as my hosted PBX.  Vocalocity has no option on their system to allow me to prepend the "913" area code when I dial 7 digit numbers.  They require ten digit dialing on all outbound calls.  Now, Polycom phones have a web interface that allows me to go in and alter the digitmap on its local configuration.  I have included the original digitmap below.  How do I alter it so that if a user dials seven digits, it automatically prepends the "913"?

Here is the current digitmap as it exists in the Polycom Phone.

[2-9]11|0T|011xxx.T|[0-1][2-9]xxxxxxxxx|[2-9]xxxxxxxxx|[2-9]xxxT

Thank you in advance for your help.
Comment
Watch Question

Commented:
This can be done.  Get the Admin Guide and follow the example for prepending on page A-18
 
http://www.polycom.com/global/documents/support/setup_maintenance/products/voice/spip_ssip_Admin_Guide_SIP_3_1.pdf
 

Author

Commented:
API_NOC,

I appreciate your response.   I have downloaded the manual, read the pertinent information and tried to effect the change.  Neither adding RR913Rxxxxxxx or adding RR1913Rxxxxxxx to the digitmap succeeded.  The first case causes the phone to respond that not enough digits were dialled.  The second change removes the phone user's ability to make outbound calls at all.

I am at a loss.  I am about to tell them that dialing 3 extra digits is no big thing.

Any other thoughts?
Commented:
RR913Rxxxxxxx|[2-9]11|0T|011xxx.T|[0-1][2-9]xxxxxxxxx|[2-9]xxxxxxxxx|[2-9]xxxT
The above code worked for me in a Polycom 501 running firmware 2.2.0, so the syntax works.  I checked the sip messaging both with the above option, and without, and was able to see the difference.  When the prepending option (above) was added, a local seven digit dial added the area code prefix.  When testing without the modification above, the phone sent just the seven digits.  Also, placement of the string is important.  It has to be matched before other similar conditions are queried.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Very good.  I was trying to put it at the tail end.  Let me give it a shot.

Author

Commented:
It did not work.  Here is the dialling plan from the phone.

RR913Rxxxxxxx|[2-9]11|0T|011xxx.T|[0-1][2-9]xxxxxxxxx|[2-9]xxxxxxxxx|[2-9]xxxT

I get a recording that I have not dialled enough numbers.  This recording must be coming from Vocalocity.  They must be stripping numbers, not recognizing syntax, or some other similar thing that I do not understand.  

I have decided to formally give up on this matter.  Dialling 3 extra digits is not worth the added expense of pursuing this issue.  Thank you for your help.  I will award you points for directing me tot he location where the answers were located.

Author

Commented:
While the solution did not resolve my particular issue, no other answer did either.  Therefore, given that Polycom and Vocalocity both claim that this is the proper answer, I am awarding points for a full answer.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.