[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Connection Failed, check SQL Server Registration Properties

Posted on 2009-02-11
5
Medium Priority
?
2,298 Views
Last Modified: 2012-06-21
Ok here's the situation, we backed up a database on SQL 2000 and restored it to SQL 2008.  The vendor then told me to disconecct the database from SQL 2000, problem is that their program craped out on SQL 2008 and now the want to move back to SQL 2000 but they forgot that they set their database to as the default database.  With it now offline we get the error message in the title and don't know how to change the default database to be able to get back online with the SQL server.  They also don't know what the sa password is.  Any help and suggestions are more than welcome.

Thanks,
Ronnie
2-11-2009-12-12-17-PM.png
0
Comment
Question by:HAC_ITS
  • 2
  • 2
5 Comments
 
LVL 32

Expert Comment

by:Daniel Wilson
ID: 23614300
Can you log into the box that hosts SQL server w/ local admin rights?  Then connect to the DB using Windows authentication.  

that should let you regain control and fix things up.
0
 

Author Comment

by:HAC_ITS
ID: 23614361
That message is from being logged in as the domain admin with windows authentication selected.  The problem seems to be that the default database was taken offline and now I can't get into any of the databases that were previously there.  I guess I want to know if it's possible to change the default database back to master without knowing the sa password.

Thanks
0
 
LVL 32

Expert Comment

by:Daniel Wilson
ID: 23621614
I have to admit I'm stumped.  I'll as the moderators to send out an alert on this.
0
 
LVL 1

Accepted Solution

by:
FiveForFighting earned 1500 total points
ID: 23622348
You could try using the 3608 Trace Flag - that makes SQL Server start up w/ only the Master DB.

See this site for details > http://support.microsoft.com/kb/224071
0
 

Author Closing Comment

by:HAC_ITS
ID: 31545653
I found a solution on another forum but htis was close.  I was able to change the default database from the one was taken offline back to the master using osql in the command prompt:

OSQL -d master -E -Q"EXEC sp_defaultdb 'MyDomain\MyAccount','master'"

Thanks for the help,
Ronnie
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have a large data set and a SSIS package. How can I load this file in multi threading?
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Viewers will learn how the fundamental information of how to create a table.
Viewers will learn how to use the SELECT statement in SQL and will be exposed to the many uses the SELECT statement has.
Suggested Courses

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question