We help IT Professionals succeed at work.

Citrix session defaults to local machine instead of domain

VWBug5000
VWBug5000 asked
on
Medium Priority
846 Views
Last Modified: 2012-05-06
Currently when users access any of our windows 2003 citrix servers via the web interface, locked sessions default to "<ServerName> (this computer)" instead of the domain that they are logged in with. I have checked the DEFAULTDOMAIN and ALTDEFAULTDOMAIN reg keys and they are set to the proper domain. When logging into these same servers via Program neighborhood or through remote desktop, the problem goes away, so I know it is an issue with the web interface.

Any help would be appreciated. Our clients are rather annoyed that they have to hit the drop down box when unlocking their sessions.
Comment
Watch Question

Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
I am not seeing a "lock" option.  I see Log Off, Reconnect and Disconnect.

Author

Commented:
Not directly on the web interface, but when they log into a published server desktop via the web interface. Once logged into the server, if their session locks due to inactivity (or if they manually lock the session), they need to provide their credentials to unlock it. However the way it is working right now, the users need to click the options button and change "<servername> This Computer" to the domain that they are already logged in with. This is very frustrating for the users since some of them aren't very technical.
Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
In the Web Interface for the site in question, did you restrict the domains and enter the domain(s) you want?

Author

Commented:
Yes, it is manually entered so the end user on needs to sign into the web interface with username/password.
Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
Then you have me stumped.

The users wouldn't happen to have local accounts on the server in question would they?

Author

Commented:
No, they are using normal AD domain accounts.

I've never seen this before either. I've set up several 4.5 Web Interfaces before and they work perfectly. However all of the published desktops through this one all do the same thing, but only when accessed through this 4.6 Web Interface so I must have some setting wrong, I just can't think of what it could be.

Author

Commented:
I've also noticed that the username is not populated either when unlocking the session, while it IS present when unlocking a locked session via PN or RDP... not sure if this will help any but I am at a loss here. I am about ready to attempt an upgrade to Web Interface 5.0 or 5.1 just to see if it fixes the problem but I'm afraid that it might cause more of a headache than the one I've got right now!
I solved my problem. In the Web Interface > Authentication Methods > Explicit > Properties... I had my full domain typed out (domain.local) when I just needed the domain (sans ".local"). I also specified this under my pre-populated UPN settings. Now when I lock my session it prepopulates the proper domain instead of the computer name.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.